New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

installation failing on centos box #115

Closed
bikerd opened this Issue Jan 13, 2014 · 23 comments

Comments

Projects
None yet
3 participants
@bikerd

bikerd commented Jan 13, 2014

hello,

i'm new to new to node, npm and github and would like to install codebox on my system - CentOS release 5.10 (Final), but failing on the install (see output below).

can you provide guidance?

thank you!

root@server [~/codebox]# npm install -g codebox
npm http GET https://registry.npmjs.org/codebox
npm http 304 https://registry.npmjs.org/codebox
npm http GET https://registry.npmjs.org/readable-stream/1.0.2
npm http GET https://registry.npmjs.org/event-stream/3.0.11
npm http GET https://registry.npmjs.org/request/2.27.0
npm http GET https://registry.npmjs.org/hr.js/0.4.0
npm http GET https://registry.npmjs.org/commander/1.1.1
npm http GET https://registry.npmjs.org/googlediff/0.1.0
npm http GET https://registry.npmjs.org/cryptojs/2.5.3
npm http GET https://registry.npmjs.org/eventemitter2/0.4.13
npm http GET https://registry.npmjs.org/engineer/0.1.0
npm http GET https://registry.npmjs.org/express/3.3.5
npm http GET https://registry.npmjs.org/socket.io/0.9.16
npm http GET https://registry.npmjs.org/loadfire/1.3.4
npm http GET https://registry.npmjs.org/shux/0.2.0
npm http GET https://registry.npmjs.org/vfs-local/0.3.13
npm http GET https://registry.npmjs.org/watchr/2.4.7
npm http GET https://registry.npmjs.org/gittle/0.1.2
npm http GET https://registry.npmjs.org/uuid/1.4.1
npm http GET https://registry.npmjs.org/glob/3.2.6
npm http GET https://registry.npmjs.org/temp/0.6.0
npm http GET https://registry.npmjs.org/wrench/1.5.4
npm http 304 https://registry.npmjs.org/readable-stream/1.0.2
npm http 304 https://registry.npmjs.org/hr.js/0.4.0
npm http 304 https://registry.npmjs.org/commander/1.1.1
npm http 304 https://registry.npmjs.org/request/2.27.0
npm http 304 https://registry.npmjs.org/event-stream/3.0.11
npm http 304 https://registry.npmjs.org/cryptojs/2.5.3
npm http 304 https://registry.npmjs.org/googlediff/0.1.0
npm http 304 https://registry.npmjs.org/engineer/0.1.0
npm http 304 https://registry.npmjs.org/eventemitter2/0.4.13
npm http 304 https://registry.npmjs.org/express/3.3.5
npm http 304 https://registry.npmjs.org/socket.io/0.9.16
npm http 304 https://registry.npmjs.org/vfs-local/0.3.13
npm http 304 https://registry.npmjs.org/loadfire/1.3.4
npm http 304 https://registry.npmjs.org/shux/0.2.0
npm http 304 https://registry.npmjs.org/watchr/2.4.7
npm http 304 https://registry.npmjs.org/uuid/1.4.1
npm http 304 https://registry.npmjs.org/gittle/0.1.2
npm http 304 https://registry.npmjs.org/temp/0.6.0
npm http 304 https://registry.npmjs.org/glob/3.2.6
npm http 304 https://registry.npmjs.org/wrench/1.5.4
npm http GET https://registry.npmjs.org/tar/0.1.19
npm http GET https://registry.npmjs.org/requirejs/2.1.0
npm http GET https://registry.npmjs.org/less/1.5.0
npm http GET https://registry.npmjs.org/underscore/1.4.4
npm http GET https://registry.npmjs.org/csso/1.3.9
npm http GET https://registry.npmjs.org/fstream/0.1.25
npm http GET https://registry.npmjs.org/q/0.9.6
npm http GET https://registry.npmjs.org/open/0.0.4
npm http GET https://registry.npmjs.org/grunt/0.4.2
npm http GET https://registry.npmjs.org/grunt-cli/0.1.11
npm http GET https://registry.npmjs.org/harbor/0.2.0
npm http GET https://registry.npmjs.org/qpatch/0.0.3
npm http 304 https://registry.npmjs.org/tar/0.1.19
npm http 304 https://registry.npmjs.org/underscore/1.4.4
npm http 304 https://registry.npmjs.org/less/1.5.0
npm http 304 https://registry.npmjs.org/requirejs/2.1.0
npm http 304 https://registry.npmjs.org/fstream/0.1.25
npm http 304 https://registry.npmjs.org/q/0.9.6
npm http 304 https://registry.npmjs.org/open/0.0.4
npm http 304 https://registry.npmjs.org/csso/1.3.9
npm http 304 https://registry.npmjs.org/grunt/0.4.2
npm http 304 https://registry.npmjs.org/grunt-cli/0.1.11
npm http 304 https://registry.npmjs.org/qpatch/0.0.3
npm http 304 https://registry.npmjs.org/harbor/0.2.0
npm WARN excluding symbolic link test/browser/public/ss.js -> ../../../socket.io-stream.js
npm WARN excluding symbolic link test/support/chai.js -> ../../node_modules/chai/chai.js
npm WARN excluding symbolic link test/support/mocha.css -> ../../node_modules/mocha/mocha.css
npm WARN excluding symbolic link test/support/mocha.js -> ../../node_modules/mocha/mocha.js
npm WARN excluding symbolic link test/support/socket.io.js -> ../../node_modules/socket.io-client/dist/socket.io.js
npm WARN excluding symbolic link test/support/ss.js -> ../../socket.io-stream.js
npm http GET https://registry.npmjs.org/rimraf
npm http GET https://registry.npmjs.org/osenv/0.0.3
npm http GET https://registry.npmjs.org/keypress
npm http GET https://registry.npmjs.org/resolve
npm http GET https://registry.npmjs.org/findup-sync
npm http GET https://registry.npmjs.org/nopt
npm http GET https://registry.npmjs.org/inherits
npm http GET https://registry.npmjs.org/pty.js
npm http GET https://registry.npmjs.org/duplexer
npm http GET https://registry.npmjs.org/headless-terminal/0.0.3
npm http GET https://registry.npmjs.org/through
npm http GET https://registry.npmjs.org/eachr
npm http GET https://registry.npmjs.org/safefs
npm http GET https://registry.npmjs.org/taskgroup
npm http GET https://registry.npmjs.org/ignorefs
npm http GET https://registry.npmjs.org/extract-opts
npm http GET https://registry.npmjs.org/typechecker
npm http GET https://registry.npmjs.org/extendr
npm http GET https://registry.npmjs.org/bal-util
npm http GET https://registry.npmjs.org/optimist/0.3.0
npm http GET https://registry.npmjs.org/http-proxy/0.10.0
npm http 304 https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/osenv/0.0.3
npm http GET https://registry.npmjs.org/from
npm http GET https://registry.npmjs.org/map-stream/0.0.1
npm http GET https://registry.npmjs.org/pause-stream/0.0.4
npm http GET https://registry.npmjs.org/split
npm http 304 https://registry.npmjs.org/keypress
npm http GET https://registry.npmjs.org/stream-combiner/0.0.0
npm http GET https://registry.npmjs.org/through/1.1.0
npm http GET https://registry.npmjs.org/duplexer
npm http 304 https://registry.npmjs.org/resolve
npm http 304 https://registry.npmjs.org/findup-sync
npm http GET https://registry.npmjs.org/simple-mime
npm http GET https://registry.npmjs.org/pty.js/0.2.3
npm http 304 https://registry.npmjs.org/nopt
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/duplexer
npm http 304 https://registry.npmjs.org/headless-terminal/0.0.3
npm http 304 https://registry.npmjs.org/pty.js
npm http GET https://registry.npmjs.org/minimatch
npm http GET https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/through
npm http 304 https://registry.npmjs.org/safefs
npm http 304 https://registry.npmjs.org/eachr
npm http 304 https://registry.npmjs.org/ignorefs
npm http GET https://registry.npmjs.org/minimatch
npm http GET https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/underscore.string
npm http GET https://registry.npmjs.org/which
npm http GET https://registry.npmjs.org/js-yaml
npm http GET https://registry.npmjs.org/exit
npm http GET https://registry.npmjs.org/getobject
npm http GET https://registry.npmjs.org/coffee-script
npm http GET https://registry.npmjs.org/colors
npm http GET https://registry.npmjs.org/dateformat/1.0.2-1.2.3
npm http GET https://registry.npmjs.org/glob
npm http GET https://registry.npmjs.org/async
npm http GET https://registry.npmjs.org/hooker
npm http GET https://registry.npmjs.org/iconv-lite
npm http 304 https://registry.npmjs.org/extract-opts
npm http 304 https://registry.npmjs.org/typechecker
npm http 304 https://registry.npmjs.org/taskgroup
npm http 304 https://registry.npmjs.org/extendr
npm http GET https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/buffer-crc32/0.2.1
npm http GET https://registry.npmjs.org/fresh/0.2.0
npm http GET https://registry.npmjs.org/methods/0.0.1
npm http GET https://registry.npmjs.org/send/0.1.4
npm http GET https://registry.npmjs.org/cookie-signature/1.0.1
npm http GET https://registry.npmjs.org/debug
npm http GET https://registry.npmjs.org/connect/2.8.5
npm http GET https://registry.npmjs.org/commander/1.2.0
npm http GET https://registry.npmjs.org/range-parser/0.0.4
npm http GET https://registry.npmjs.org/mkdirp/0.3.5
npm http GET https://registry.npmjs.org/cookie/0.1.0
npm http 304 https://registry.npmjs.org/optimist/0.3.0
npm http 304 https://registry.npmjs.org/from
npm http 304 https://registry.npmjs.org/http-proxy/0.10.0
npm http GET https://registry.npmjs.org/abbrev
npm http GET https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/bal-util
npm http 304 https://registry.npmjs.org/map-stream/0.0.1
npm http 304 https://registry.npmjs.org/split
npm http 304 https://registry.npmjs.org/pause-stream/0.0.4
npm http 304 https://registry.npmjs.org/stream-combiner/0.0.0
npm http 304 https://registry.npmjs.org/through/1.1.0
npm http GET https://registry.npmjs.org/block-stream
npm http 304 https://registry.npmjs.org/duplexer
npm http 304 https://registry.npmjs.org/minimatch
npm http 304 https://registry.npmjs.org/minimatch
npm http 304 https://registry.npmjs.org/mkdirp
npm http 304 https://registry.npmjs.org/simple-mime
npm http 304 https://registry.npmjs.org/pty.js/0.2.3
npm http GET https://registry.npmjs.org/base64id/0.1.0
npm http GET https://registry.npmjs.org/redis/0.7.3
npm http GET https://registry.npmjs.org/socket.io-client/0.9.16
npm http GET https://registry.npmjs.org/policyfile/0.0.4
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/ignorepatterns
npm http 304 https://registry.npmjs.org/underscore.string
npm http 304 https://registry.npmjs.org/which
npm http 304 https://registry.npmjs.org/js-yaml

safefs@3.1.0 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/safefs
node ./cyclic.js

npm http 304 https://registry.npmjs.org/exit
npm http 304 https://registry.npmjs.org/getobject
npm http 304 https://registry.npmjs.org/colors
npm http 304 https://registry.npmjs.org/coffee-script
npm http 304 https://registry.npmjs.org/dateformat/1.0.2-1.2.3

typechecker@2.0.8 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/typechecker
node ./cyclic.js

npm http 304 https://registry.npmjs.org/glob
npm http GET https://registry.npmjs.org/duplexer/0.0.2
npm http 304 https://registry.npmjs.org/async
npm http 304 https://registry.npmjs.org/hooker
npm http 304 https://registry.npmjs.org/iconv-lite
npm http 304 https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/ambi
npm http 304 https://registry.npmjs.org/buffer-crc32/0.2.1
npm http 304 https://registry.npmjs.org/fresh/0.2.0

taskgroup@3.3.6 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/taskgroup
node ./cyclic.js

npm http 304 https://registry.npmjs.org/send/0.1.4
npm http 304 https://registry.npmjs.org/methods/0.0.1
npm http 304 https://registry.npmjs.org/cookie-signature/1.0.1
npm http GET https://registry.npmjs.org/ambi
npm http 304 https://registry.npmjs.org/debug
npm http 304 https://registry.npmjs.org/commander/1.2.0
npm http 304 https://registry.npmjs.org/range-parser/0.0.4
npm http 304 https://registry.npmjs.org/connect/2.8.5
npm http GET https://registry.npmjs.org/wordwrap
npm http 304 https://registry.npmjs.org/mkdirp/0.3.5
npm http GET https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/cookie/0.1.0
npm http 304 https://registry.npmjs.org/abbrev
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/block-stream
npm http 304 https://registry.npmjs.org/base64id/0.1.0
npm http 304 https://registry.npmjs.org/redis/0.7.3
npm http 304 https://registry.npmjs.org/socket.io-client/0.9.16
npm http 304 https://registry.npmjs.org/policyfile/0.0.4
npm http 304 https://registry.npmjs.org/ignorepatterns
npm http 304 https://registry.npmjs.org/duplexer/0.0.2
npm http GET https://registry.npmjs.org/aws-sign
npm http GET https://registry.npmjs.org/http-signature
npm http GET https://registry.npmjs.org/oauth-sign
npm http GET https://registry.npmjs.org/cookie-jar
npm http GET https://registry.npmjs.org/node-uuid
npm http GET https://registry.npmjs.org/mime
npm http GET https://registry.npmjs.org/form-data
npm http GET https://registry.npmjs.org/hawk
npm http GET https://registry.npmjs.org/qs
npm http GET https://registry.npmjs.org/json-stringify-safe
npm http GET https://registry.npmjs.org/forever-agent
npm http GET https://registry.npmjs.org/tunnel-agent
npm http 304 https://registry.npmjs.org/wordwrap
npm http 304 https://registry.npmjs.org/ambi
npm http 304 https://registry.npmjs.org/lru-cache
npm http 304 https://registry.npmjs.org/ambi
npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/aws-sign
npm http 304 https://registry.npmjs.org/http-signature
npm http 304 https://registry.npmjs.org/oauth-sign
npm http 304 https://registry.npmjs.org/cookie-jar
npm http 304 https://registry.npmjs.org/node-uuid
npm http 304 https://registry.npmjs.org/mime
npm http 304 https://registry.npmjs.org/form-data
npm http 304 https://registry.npmjs.org/hawk
npm http 304 https://registry.npmjs.org/json-stringify-safe
npm http 304 https://registry.npmjs.org/qs
npm http 304 https://registry.npmjs.org/forever-agent
npm http 304 https://registry.npmjs.org/tunnel-agent
npm http GET https://registry.npmjs.org/combined-stream

ambi@2.1.6 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/bal-util/node_modules/ambi
node ./cyclic.js

npm http GET https://registry.npmjs.org/ctype/0.5.2
npm http GET https://registry.npmjs.org/assert-plus/0.1.2
npm http GET https://registry.npmjs.org/asn1/0.1.11
npm http 304 https://registry.npmjs.org/combined-stream

ambi@2.1.6 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/taskgroup/node_modules/ambi
node ./cyclic.js

npm http GET https://registry.npmjs.org/argparse
npm http GET https://registry.npmjs.org/esprima
npm http 304 https://registry.npmjs.org/assert-plus/0.1.2
npm http 304 https://registry.npmjs.org/ctype/0.5.2
npm http 304 https://registry.npmjs.org/asn1/0.1.11
npm http GET https://registry.npmjs.org/delayed-stream/0.0.5
npm http 304 https://registry.npmjs.org/argparse
npm http 304 https://registry.npmjs.org/esprima

pty.js@0.2.3 install /usr/local/lib/node_modules/codebox/node_modules/vfs-local/node_modules/pty.js
node-gyp rebuild

Traceback (most recent call last):
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py", line 18, in
sys.exit(gyp.script_main())
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 534, in script_main
return main(sys.argv[1:])
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 527, in main
return gyp_main(args)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 503, in gyp_main
options.circular_check)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 129, in Load
params['parallel'], params['root_targets'])
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 2687, in Load
generator_input_info)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 594, in LoadTargetBuildFilesParallel
parallel_state.pool = multiprocessing.Pool(8)
File "/usr/local/lib/python2.6/multiprocessing/init.py", line 227, in Pool
return Pool(processes, initializer, initargs)
File "/usr/local/lib/python2.6/multiprocessing/pool.py", line 84, in init
self._setup_queues()
File "/usr/local/lib/python2.6/multiprocessing/pool.py", line 131, in _setup_queues
self._inqueue = SimpleQueue()
File "/usr/local/lib/python2.6/multiprocessing/queues.py", line 328, in init
self._rlock = Lock()
File "/usr/local/lib/python2.6/multiprocessing/synchronize.py", line 117, in init
SemLock.init(self, SEMAPHORE, 1, 1)
File "/usr/local/lib/python2.6/multiprocessing/synchronize.py", line 49, in init
sl = self._semlock = _multiprocessing.SemLock(kind, value, maxvalue)
OSError: [Errno 13] Permission denied
gyp ERR! configure error
gyp ERR! stack Error: gyp failed with exit code: 1
gyp ERR! stack at ChildProcess.onCpExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:337:16)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:789:12)
gyp ERR! System Linux 2.6.32-042stab083.2
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/codebox/node_modules/vfs-local/node_modules/pty.js
gyp ERR! node -v v0.10.24
gyp ERR! node-gyp -v v0.12.1
gyp ERR! not ok
npm http GET https://registry.npmjs.org/pkginfo
npm http GET https://registry.npmjs.org/utile
npm http 304 https://registry.npmjs.org/delayed-stream/0.0.5
npm http GET https://registry.npmjs.org/cryptiles
npm http GET https://registry.npmjs.org/sntp
npm http GET https://registry.npmjs.org/hoek
npm http GET https://registry.npmjs.org/boom
npm http 304 https://registry.npmjs.org/utile
npm http 304 https://registry.npmjs.org/pkginfo
npm http 304 https://registry.npmjs.org/hoek
npm http 304 https://registry.npmjs.org/cryptiles
npm http 304 https://registry.npmjs.org/sntp
npm http 304 https://registry.npmjs.org/boom
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/csso/test/data/test_attrselector'
npm ERR! error rolling back codebox@0.4.5 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/csso/test/data/test_attrselector']
npm ERR! error rolling back errno: 53,
npm ERR! error rolling back code: 'ENOTEMPTY',
npm ERR! error rolling back path: '/usr/local/lib/node_modules/codebox/node_modules/csso/test/data/test_attrselector' }
npm ERR! pty.js@0.2.3 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the pty.js@0.2.3 install script.
npm ERR! This is most likely a problem with the pty.js package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls pty.js
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! code ELIFECYCLE
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/pkginfo/lib/pkginfo.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/pkginfo/lib/pkginfo.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/pkginfo/lib/pkginfo.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/utile/test/function-args-test.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/utile/test/function-args-test.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/utile/test/function-args-test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt-cli/node_modules/findup-sync/node_modules/lodash/dist/lodash.underscore.min.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt-cli/node_modules/findup-sync/node_modules/lodash/dist/lodash.underscore.min.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt-cli/node_modules/findup-sync/node_modules/lodash/dist/lodash.underscore.min.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/node_modules/esprima/test/runner.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/node_modules/esprima/test/runner.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/node_modules/esprima/test/runner.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/request/node_modules/http-signature/node_modules/ctype/tst/ctio/uint/tst.64.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/request/node_modules/http-signature/node_modules/ctype/tst/ctio/uint/tst.64.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/request/node_modules/http-signature/node_modules/ctype/tst/ctio/uint/tst.64.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/encodings/table/gbk.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/encodings/table/gbk.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/encodings/table/gbk.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/dist/WebSocketMain.swf'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/dist/WebSocketMain.swf
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/dist/WebSocketMain.swf
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.2.2.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.2.2.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.2.2.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/hr.js/vendors/hr.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/hr.js/vendors/hr.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/hr.js/vendors/hr.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)

@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 13, 2014

@bikerd First of all welcome to GitHub, the node and codebox.

So to install codebox on a linux system, you need the following :

  • A modern install of node and npm
  • The git package
  • The build-essential package (which provides make, gcc, and a bunch of other stuff ..,)

Once you've got those you can install codebox globally with :

npm install -g codebox

You can install build-essential and git on ubuntu with :

sudo apt-get -y install git build-essential

I'm not too familiar with CentOS but I guess this should do the job :

yum install git build-essential
@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 13, 2014

@bikerd Let me know if the above works.

Good luck ! And thanks for joining the codebox community.

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

@AaronO Thanks a bunch! I'll give it a roll.

Also, can codebox be access remotely over the web or can it only be access on the local system? If there is remote access, is there any type of user authentication?

Thanks again!!

@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 14, 2014

@bikerd You're more than welcome.

codebox can of course be accessed remotely (that's how we run it on our https://www.codebox.io service, which offers hosted ubuntu VMs running codebox).

If you're wanting to protect your codebox instance from malicious access from third parties, you'll probably want to run it behind nginx or apache and reverse proxy to your codebox instance while adding http basic authentication.

codebox will still prompt you for your email when you open it the first time though (it uses for email to identify you amongst other collaborators), but you can default the email by supplying the --email flag to the codebox command line executable when you spin it up.

As I mentioned above, we run a hosted service at https://www.codebox.io, so you might want to check that out if you want a no hassle setup.

@bikerd Hope this helps ! I'm closing this issue for now, but feel free to ask here if you have any additional questions and to update me on your progress.

@AaronO AaronO closed this Jan 14, 2014

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

greatly appreciate it @AaronO

is it also possible to specify a non-default port number on the command line?

i'll get build-essential installed, re-run the install, and let you know how things go

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

for other folks who might reference this thread in the future...

here's the centos equiv to y'um install git build-essential' mentioned by @AaronO above:

yum groupinstall "Development Tools"

for this to run successfully, i had to install the following first:

rpm -ivh http://mirror.centos.org/centos-5/5.10/os/i386/CentOS/perl-URI-1.35-3.noarch.rpm

@AaronO - i'm still getting the following error when i run 'npm install -g codebox'

any suggestions?

thanks!

npm http GET https://registry.npmjs.org/combined-stream
npm http 304 https://registry.npmjs.org/combined-stream
npm http GET https://registry.npmjs.org/ctype/0.5.2
npm http GET https://registry.npmjs.org/assert-plus/0.1.2
npm http GET https://registry.npmjs.org/asn1/0.1.11
npm http 304 https://registry.npmjs.org/ctype/0.5.2
npm http 304 https://registry.npmjs.org/assert-plus/0.1.2
npm http 304 https://registry.npmjs.org/asn1/0.1.11

pty.js@0.2.3 install /usr/local/lib/node_modules/codebox/node_modules/shux/node_modules/pty.js
node-gyp rebuild

Traceback (most recent call last):
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py", line 18, in
sys.exit(gyp.script_main())
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 534, in script_main
return main(sys.argv[1:])
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 527, in main
return gyp_main(args)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 503, in gyp_main
options.circular_check)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 129, in Load
params['parallel'], params['root_targets'])
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 2687, in Load
generator_input_info)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 594, in LoadTargetBuildFilesParallel
parallel_state.pool = multiprocessing.Pool(8)
File "/usr/local/lib/python2.6/multiprocessing/init.py", line 227, in Pool
return Pool(processes, initializer, initargs)
File "/usr/local/lib/python2.6/multiprocessing/pool.py", line 84, in init
self._setup_queues()
File "/usr/local/lib/python2.6/multiprocessing/pool.py", line 131, in _setup_queues
self._inqueue = SimpleQueue()
File "/usr/local/lib/python2.6/multiprocessing/queues.py", line 328, in init
self._rlock = Lock()
File "/usr/local/lib/python2.6/multiprocessing/synchronize.py", line 117, in init
SemLock.init(self, SEMAPHORE, 1, 1)
File "/usr/local/lib/python2.6/multiprocessing/synchronize.py", line 49, in init
sl = self._semlock = _multiprocessing.SemLock(kind, value, maxvalue)
OSError: [Errno 13] Permission denied
gyp ERR! configure error
gyp ERR! stack Error: gyp failed with exit code: 1
gyp ERR! stack at ChildProcess.onCpExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:337:16)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:789:12)
gyp ERR! System Linux 2.6.32-042stab083.2
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/codebox/node_modules/shux/node_modules/pty.js
gyp ERR! node -v v0.10.24
gyp ERR! node-gyp -v v0.12.1
gyp ERR! not ok
npm http GET https://registry.npmjs.org/delayed-stream/0.0.5
npm http GET https://registry.npmjs.org/pkginfo
npm http GET https://registry.npmjs.org/utile
npm http 304 https://registry.npmjs.org/delayed-stream/0.0.5
npm http 304 https://registry.npmjs.org/pkginfo
npm http 304 https://registry.npmjs.org/utile
npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/codebox/node_modules/csso/test/data/test_atrules/atrules.2.css'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/csso/test/data/test_atrules/atrules.2.css
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/colors/example.html'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/colors/example.html
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! Error: ENOENT, chown '/usr/local/lib/node_modules/codebox/node_modules/vfs-local/node_modules/pty.js/deps/winpty/agent/ConsoleInput.cc'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/vfs-local/node_modules/pty.js/deps/winpty/agent/ConsoleInput.cc
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/vfs-local/node_modules/pty.js/deps/winpty/agent/ConsoleInput.cc
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chown
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:133:7
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/express/node_modules/connect/lib/public/icons'
npm ERR! error rolling back codebox@0.4.6 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/express/node_modules/connect/lib/public/icons']
npm ERR! error rolling back errno: 53,
npm ERR! error rolling back code: 'ENOTEMPTY',
npm ERR! error rolling back path: '/usr/local/lib/node_modules/codebox/node_modules/express/node_modules/connect/lib/public/icons' }
npm ERR! pty.js@0.2.3 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the pty.js@0.2.3 install script.
npm ERR! This is most likely a problem with the pty.js package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls pty.js
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! code ELIFECYCLE
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/pkginfo/docs/pkginfo.html'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/pkginfo/docs/pkginfo.html
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/loadfire/node_modules/http-proxy/node_modules/pkginfo/docs/pkginfo.html
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/findup-sync/node_modules/lodash/README.md'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/findup-sync/node_modules/lodash/README.md
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/findup-sync/node_modules/lodash/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/request/node_modules/hawk/test/server.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/request/node_modules/hawk/test/server.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/request/node_modules/hawk/test/server.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/request/node_modules/http-signature/node_modules/ctype/tst/ctf/typedef.json'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/request/node_modules/http-signature/node_modules/ctype/tst/ctf/typedef.json
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/request/node_modules/http-signature/node_modules/ctype/tst/ctf/typedef.json
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/encodings/table/gbk.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/encodings/table/gbk.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/encodings/table/gbk.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/dist/WebSocketMain.swf'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/dist/WebSocketMain.swf
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/dist/WebSocketMain.swf
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.3.1.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.3.1.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.3.1.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/hr.js/vendors/hr.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/hr.js/vendors/hr.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/hr.js/vendors/hr.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/node_modules/esprima/test/test.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /root/codebox
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/node_modules/esprima/test/test.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/node_modules/esprima/test/test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /root/codebox/npm-debug.log
npm ERR! not ok code 0

@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 14, 2014

@bikerd Yes of course.

You can use the --port flag. So if you want codebox to listen on the port 3400 for example, simply add --port 3400 to the command line and codebox will listen on 3400 instead of the default 8000.

The port can also be specified via the PORT environment variable, as well as many other settings, if interested check out https://github.com/FriendCode/codebox/blob/master/core/codebox.js#L68.

Keep me updated. And let me know if this works for you.

@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 14, 2014

@bikerd Regarding your error on installation.

I think you need to run the install with root rights. So try:

sudo npm install -g codebox
@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

thanks

i had run the initial install with the root account, so i don't think that's it

based on the error msgs, i thought that node-gyp was not installed (which it wasn't).

it still fails after manually installing node-gyp (log below)

i'm new to npm, so i'm not sure if i need to be manually all these other things that seem to be missing or if the codebox install should take care of that

i'll keep digging & trying, but any help is appreciated as i'd really like to get working with codebox. Thanks!!

pty.js@0.2.3 install /usr/local/lib/node_modules/codebox/node_modules/shux/node_modules/pty.js
node-gyp rebuild

Traceback (most recent call last):
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/gyp_main.py", line 18, in
sys.exit(gyp.script_main())
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 534, in script_main
return main(sys.argv[1:])
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 527, in main
return gyp_main(args)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 503, in gyp_main
options.circular_check)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py", line 129, in Load
params['parallel'], params['root_targets'])
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 2687, in Load
generator_input_info)
File "/usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/input.py", line 594, in LoadTargetBuildFilesParallel
parallel_state.pool = multiprocessing.Pool(8)
File "/usr/local/lib/python2.6/multiprocessing/init.py", line 227, in Pool
return Pool(processes, initializer, initargs)
File "/usr/local/lib/python2.6/multiprocessing/pool.py", line 84, in init
self._setup_queues()
File "/usr/local/lib/python2.6/multiprocessing/pool.py", line 131, in _setup_queues
self._inqueue = SimpleQueue()
File "/usr/local/lib/python2.6/multiprocessing/queues.py", line 328, in init
self._rlock = Lock()
File "/usr/local/lib/python2.6/multiprocessing/synchronize.py", line 117, in init
SemLock.init(self, SEMAPHORE, 1, 1)
File "/usr/local/lib/python2.6/multiprocessing/synchronize.py", line 49, in init
sl = self._semlock = _multiprocessing.SemLock(kind, value, maxvalue)
OSError: [Errno 13] Permission denied
gyp ERR! configure error
gyp ERR! stack Error: gyp failed with exit code: 1
gyp ERR! stack at ChildProcess.onCpExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:337:16)
gyp ERR! stack at ChildProcess.EventEmitter.emit (events.js:98:17)
gyp ERR! stack at Process.ChildProcess._handle.onexit (child_process.js:789:12)
gyp ERR! System Linux 2.6.32-042stab083.2
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/codebox/node_modules/shux/node_modules/pty.js
gyp ERR! node -v v0.10.24
gyp ERR! node-gyp -v v0.12.1
gyp ERR! not ok
npm http 304 https://registry.npmjs.org/hooker
npm http 304 https://registry.npmjs.org/which
npm http 304 https://registry.npmjs.org/glob
npm http 304 https://registry.npmjs.org/iconv-lite
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/underscore.string
npm http 304 https://registry.npmjs.org/exit
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/js-yaml
npm http 304 https://registry.npmjs.org/getobject
npm http 304 https://registry.npmjs.org/cookie/0.1.0
npm http 304 https://registry.npmjs.org/buffer-crc32/0.2.1
npm http 304 https://registry.npmjs.org/fresh/0.2.0
npm http 304 https://registry.npmjs.org/methods/0.0.1
npm http 304 https://registry.npmjs.org/send/0.1.4
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/colors/MIT-LICENSE.txt'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/colors/MIT-LICENSE.txt
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/colors/MIT-LICENSE.txt
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/.travis.yml'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/.travis.yml
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/iconv-lite/.travis.yml
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/underscore.string/README.markdown'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/underscore.string/README.markdown
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/underscore.string/README.markdown
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/hooker'
npm ERR! error rolling back codebox@0.4.6 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/hooker']
npm ERR! error rolling back errno: 53,
npm ERR! error rolling back code: 'ENOTEMPTY',
npm ERR! error rolling back path: '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/hooker' }
npm ERR! pty.js@0.2.3 install: node-gyp rebuild
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the pty.js@0.2.3 install script.
npm ERR! This is most likely a problem with the pty.js package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls pty.js
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! code ELIFECYCLE
npm http 304 https://registry.npmjs.org/cookie-signature/1.0.1
npm http 304 https://registry.npmjs.org/debug

pty.js@0.2.3 install /usr/local/lib/node_modules/codebox/node_modules/vfs-local/node_modules/pty.js
node-gyp rebuild

gyp ERR! UNCAUGHT EXCEPTION
gyp ERR! stack Error: ENOENT, no such file or directory
gyp ERR! stack at process.cwd (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:8:19)
gyp ERR! stack at Object.exports.resolve (path.js:309:52)
gyp ERR! stack at configure (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:26:23)
gyp ERR! stack at Object.self.commands.(anonymous function) as configure
gyp ERR! stack at run (/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js:72:30)
gyp ERR! stack at process._tickCallback (node.js:415:13)

gyp ERR! System Linux 2.6.32-042stab083.2
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"

/usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:8
cwd = origCwd.call(process)
^
Error: ENOENT, no such file or directory
at process.cwd (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:8:19)
at errorMessage (/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js:119:28)
at issueMessage (/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js:125:3)
at process. (/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js:109:3)
at process.EventEmitter.emit (events.js:95:17)
at process._fatalException (node.js:272:26)
npm ERR! Error: ENOENT, chmod '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/coffee-script/bin/coffee'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/coffee-script/bin/coffee
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/coffee-script/bin/coffee
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chmod
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:305:19
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! EEXIST, mkdir '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/rimraf/test'
File exists: /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/rimraf/test
Move it away, and try again.
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/rimraf/test
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/rimraf/test/run.sh
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code EEXIST
npm ERR! errno 47
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:171:23
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/mkdirp/index.js:37:53
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, chown '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/findup-sync/test'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/findup-sync/test
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/findup-sync/test/findup-sync_test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call setupMadeDir
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack end (/usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:319:21)
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:336:20
npm ERR! fstream_stack next (/usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:366:20)
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:133:7
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/connect/2.8.5
npm http 304 https://registry.npmjs.org/commander/1.2.0
npm http 304 https://registry.npmjs.org/range-parser/0.0.4
npm http 304 https://registry.npmjs.org/abbrev
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/async/README.md'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/async/README.md
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/async/README.md
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/glob/glob.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/glob/glob.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/glob/glob.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/nopt/lib/nopt.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/nopt/lib/nopt.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/nopt/lib/nopt.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/minimatch/minimatch.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/minimatch/minimatch.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/minimatch/minimatch.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/examples/sample_document.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/examples/sample_document.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/js-yaml/examples/sample_document.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/exit/test/fixtures'
npm ERR! error rolling back grunt@0.4.2 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/exit/test/fixtures']
npm ERR! error rolling back errno: 53,
npm ERR! error rolling back code: 'ENOTEMPTY',
npm ERR! error rolling back path: '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/exit/test/fixtures' }
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/hooker/lib/hooker.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/hooker/lib/hooker.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/hooker/lib/hooker.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/mkdirp/0.3.5
npm http 304 https://registry.npmjs.org/block-stream
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/base64id/0.1.0
npm http 304 https://registry.npmjs.org/socket.io-client/0.9.16
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/lodash/lodash.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/lodash/lodash.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/grunt/node_modules/lodash/lodash.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/policyfile/0.0.4
npm http 304 https://registry.npmjs.org/redis/0.7.3
npm http 304 https://registry.npmjs.org/qs
npm http 304 https://registry.npmjs.org/json-stringify-safe
npm http 304 https://registry.npmjs.org/http-signature
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.4.1.js'
npm ERR! If you need help, you may report this entire log,
npm ERR! including the npm and node versions, at:
npm ERR! http://github.com/isaacs/npm/issues

npm ERR! System Linux 2.6.32-042stab083.2
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "install" "-g" "codebox"
npm ERR! cwd /usr/local/lib
npm ERR! node -v v0.10.24
npm ERR! npm -v 1.3.21
npm ERR! path /usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.4.1.js
npm ERR! fstream_path /usr/local/lib/node_modules/codebox/node_modules/less/dist/less-1.4.1.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/forever-agent
npm http 304 https://registry.npmjs.org/hawk
npm http 304 https://registry.npmjs.org/tunnel-agent
npm http 304 https://registry.npmjs.org/aws-sign
npm http 304 https://registry.npmjs.org/oauth-sign
npm http 304 https://registry.npmjs.org/cookie-jar
npm http 304 https://registry.npmjs.org/node-uuid
npm http 304 https://registry.npmjs.org/mime
npm http 304 https://registry.npmjs.org/form-data
npm http 304 https://registry.npmjs.org/ignorepatterns
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/ambi
npm http 304 https://registry.npmjs.org/wordwrap
npm http 304 https://registry.npmjs.org/duplexer/0.0.2
npm http GET https://registry.npmjs.org/combined-stream
npm http 304 https://registry.npmjs.org/ambi
npm http GET https://registry.npmjs.org/assert-plus/0.1.2
npm http GET https://registry.npmjs.org/asn1/0.1.11
npm http GET https://registry.npmjs.org/ctype/0.5.2
npm http 304 https://registry.npmjs.org/utile
npm http 304 https://registry.npmjs.org/colors

ambi@2.1.6 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/bal-util/node_modules/ambi
node ./cyclic.js

ambi@2.1.6 preinstall /usr/local/lib/node_modules/codebox/node_modules/watchr/node_modules/taskgroup/node_modules/ambi
node ./cyclic.js

npm http 304 https://registry.npmjs.org/pkginfo
npm http 304 https://registry.npmjs.org/lru-cache
npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/express/3.0.0
npm http 304 https://registry.npmjs.org/requirejs/2.1.6
npm http GET https://registry.npmjs.org/bytes/0.2.0
npm http GET https://registry.npmjs.org/qs/0.6.5
npm http GET https://registry.npmjs.org/uid2/0.0.2
npm http GET https://registry.npmjs.org/pause/0.0.1
npm http GET https://registry.npmjs.org/formidable/1.0.14
npm http 304 https://registry.npmjs.org/less/1.3.3
npm http GET https://registry.npmjs.org/i
npm http GET https://registry.npmjs.org/deep-equal
npm http 304 https://registry.npmjs.org/wrench/1.5.1
npm http GET https://registry.npmjs.org/ncp
npm http 304 https://registry.npmjs.org/cli-color/0.2.2
npm http GET https://registry.npmjs.org/hoek
npm http GET https://registry.npmjs.org/boom
npm http GET https://registry.npmjs.org/sntp
npm http GET https://registry.npmjs.org/cryptiles
npm http 304 https://registry.npmjs.org/combined-stream
npm http 304 https://registry.npmjs.org/assert-plus/0.1.2
npm http 304 https://registry.npmjs.org/asn1/0.1.11
npm http 304 https://registry.npmjs.org/ctype/0.5.2
npm http 200 https://registry.npmjs.org/bytes/0.2.0
npm http GET https://registry.npmjs.org/bytes/-/bytes-0.2.0.tgz
npm http 200 https://registry.npmjs.org/qs/0.6.5
npm http 200 https://registry.npmjs.org/uid2/0.0.2
npm http GET https://registry.npmjs.org/qs/-/qs-0.6.5.tgz
npm http GET https://registry.npmjs.org/uid2/-/uid2-0.0.2.tgz
npm http 200 https://registry.npmjs.org/bytes/-/bytes-0.2.0.tgz
npm http 304 https://registry.npmjs.org/pause/0.0.1
npm http 200 https://registry.npmjs.org/qs/-/qs-0.6.5.tgz
npm http 200 https://registry.npmjs.org/uid2/-/uid2-0.0.2.tgz
npm http 304 https://registry.npmjs.org/i
npm http 200 https://registry.npmjs.org/formidable/1.0.14
npm http GET https://registry.npmjs.org/formidable/-/formidable-1.0.14.tgz
npm http 304 https://registry.npmjs.org/ncp
npm http 304 https://registry.npmjs.org/deep-equal
npm http GET https://registry.npmjs.org/es5-ext
npm http 200 https://registry.npmjs.org/formidable/-/formidable-1.0.14.tgz
npm http GET https://registry.npmjs.org/memoizee
npm http 304 https://registry.npmjs.org/hoek
npm http 304 https://registry.npmjs.org/sntp
npm http 304 https://registry.npmjs.org/boom
npm http GET https://registry.npmjs.org/delayed-stream/0.0.5
npm http 304 https://registry.npmjs.org/cryptiles
npm http 304 https://registry.npmjs.org/memoizee
npm http 304 https://registry.npmjs.org/es5-ext
npm http 304 https://registry.npmjs.org/delayed-stream/0.0.5
npm http GET https://registry.npmjs.org/commander/0.6.1
npm http GET https://registry.npmjs.org/cookie/0.0.4
npm http GET https://registry.npmjs.org/crc/0.2.0
npm http GET https://registry.npmjs.org/send/0.1.0
npm http GET https://registry.npmjs.org/connect/2.6.0
npm http GET https://registry.npmjs.org/fresh/0.1.0
npm http GET https://registry.npmjs.org/mkdirp/0.3.3
npm http 304 https://registry.npmjs.org/cookie/0.0.4
npm http 304 https://registry.npmjs.org/crc/0.2.0
npm http 304 https://registry.npmjs.org/commander/0.6.1
npm http 304 https://registry.npmjs.org/send/0.1.0
npm http 304 https://registry.npmjs.org/connect/2.6.0
npm http GET https://registry.npmjs.org/event-emitter
npm http GET https://registry.npmjs.org/next-tick
npm http 304 https://registry.npmjs.org/fresh/0.1.0
npm http 304 https://registry.npmjs.org/mkdirp/0.3.3
npm http 304 https://registry.npmjs.org/event-emitter
npm http 304 https://registry.npmjs.org/next-tick
npm http GET https://registry.npmjs.org/mime/1.2.6
npm http 304 https://registry.npmjs.org/mime/1.2.6
npm http GET https://registry.npmjs.org/ycssmin
npm http GET https://registry.npmjs.org/bytes/0.1.0
npm http GET https://registry.npmjs.org/formidable/1.0.11
npm http GET https://registry.npmjs.org/qs/0.5.1
npm http GET https://registry.npmjs.org/send/0.0.4
npm http 304 https://registry.npmjs.org/ycssmin
npm http 304 https://registry.npmjs.org/bytes/0.1.0
npm http 304 https://registry.npmjs.org/formidable/1.0.11
npm http 304 https://registry.npmjs.org/qs/0.5.1
npm http 304 https://registry.npmjs.org/send/0.0.4
npm http GET https://registry.npmjs.org/xmlhttprequest/1.4.2
npm http GET https://registry.npmjs.org/active-x-obfuscator/0.0.1
npm http GET https://registry.npmjs.org/uglify-js/1.2.5
npm http GET https://registry.npmjs.org/ws
npm http 304 https://registry.npmjs.org/active-x-obfuscator/0.0.1
npm http 304 https://registry.npmjs.org/xmlhttprequest/1.4.2
npm http 304 https://registry.npmjs.org/uglify-js/1.2.5
npm http 304 https://registry.npmjs.org/ws
npm http GET https://registry.npmjs.org/zeparser/0.0.5
npm http GET https://registry.npmjs.org/options
npm http GET https://registry.npmjs.org/tinycolor
npm http GET https://registry.npmjs.org/nan
npm http GET https://registry.npmjs.org/commander
npm http 304 https://registry.npmjs.org/zeparser/0.0.5
npm http 304 https://registry.npmjs.org/options
npm http 304 https://registry.npmjs.org/tinycolor
npm http 304 https://registry.npmjs.org/nan
npm http 304 https://registry.npmjs.org/commander

ws@0.4.31 install /usr/local/lib/node_modules/codebox/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
(node-gyp rebuild 2> builderror.log) || (exit 0)

npm http GET https://registry.npmjs.org/minimatch
npm http GET https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/minimatch
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/lru-cache
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /usr/local/lib/npm-debug.log
npm ERR! not ok code 0
root@server [/usr/local/lib]#

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

seems that this file is not on my system, but don't 'know if that's the root problem...

ll /usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py

/bin/ls: /usr/local/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/init.py: No such file or directory

@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 14, 2014

@bikerd Could you upload this /usr/local/lib/npm-debug.log file to https://gist.github.com/ and share the link of your gist here in the comments.

Thanks !

PS: I'm reopening this, since we still haven't figured out a good install process for CentOS, though the ubuntu one works.

@AaronO AaronO reopened this Jan 14, 2014

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

@AaronO - hope i did this correctly - https://gist.github.com/bikerd/8421246

i'll (obviously) be glad to help out with the CentOS install effort!! ...and i'm sure once we get it installed i'll have plenty of feedback (test results)

thanks!

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

p.s. i tried installing python 2.7.x (was running 2.6.x) to see if that would make a difference, but it did not

@AaronO

This comment has been minimized.

Contributor

AaronO commented Jan 14, 2014

@bikerd It seems like the issue your experiencing isn't really caused by node or codebox.

I think this it: nodejs/node-v0.x-archive#6573, the fix is here http://stackoverflow.com/a/2009505

It turns out CentOS has bad default permissions on /dev/shm which blocks POSIX semaphores thus crashing the python program node-gyp spawns to build the pty.js extension codebox uses.

@bikerd Sorry for the rabbit hole ^^ (that is not an obvious issue)

Give the stackoverflow fix a try and update us. Thanks

@bikerd

This comment has been minimized.

bikerd commented Jan 14, 2014

bingo! it's running!! few initial questions...

i used -e <email_address> in the command line, but it didn't prompt me for it when i connected...should it? or how does this work?

is python not supported, or do i need to install something for "Run" to work with a python src file? I get a "An error occurred when trying to run this project: The project has no supported type" message. (i also just noticed the Documentation option in Help and will look there.)

also, how do i run with a non-priv/non-root account? when i try i get the output below.

thanks a bunch!!! looking forward to checking this out!!!

[log][reporting] events reporting with timeout of 180000 ms
[log][web] disable auth for /static/addons
[log][addons] Adding default addon cb.collaborators
[log][addons] Adding default addon cb.files.editor
[log][addons] Adding default addon cb.files.image
[log][addons] Adding default addon cb.git
[log][addons] Adding default addon cb.help
[log][addons] Adding default addon cb.manager
[log][addons] Adding default addon cb.offline
[log][addons] Adding default addon cb.panel.files
[log][addons] Adding default addon cb.panel.search
[log][addons] Adding default addon cb.run
[log][addons] Adding default addon cb.settings
[log][addons] Adding default addon cb.terminal
[log][addons] Adding default addon cb.theme.dark
Error in the application:
Error: EACCES, unlink '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators'
Error initializing CodeBox
{ [Error: EACCES, unlink '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators']
errno: 3,
code: 'EACCES',
path: '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators' }
Error: EACCES, unlink '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators'
$

@bikerd

This comment has been minimized.

bikerd commented Jan 15, 2014

Hi,

Any thoughts on this error received when starting from a non-priv account?

I've tried adding access to sudo for different things that might be related to this (e.g., /bin/unlink), but haven't been able to get it working.

does anyone know if there's something specific that needs to be added to the sudoers file to make this work?

here is the link to the file referenced by the error at startup:

ll /usr/local/lib/node_modules/codebox/.addons/cb.collaborators

lrwxrwxrwx 1 root root 59 Jan 14 19:00 /usr/local/lib/node_modules/codebox/.addons/cb.collaborators -> /usr/local/lib/node_modules/codebox/addons/cb.collaborators/

[log][addons] Adding default addon cb.settings [log][addons] Adding default addon cb.terminal [log][addons] Adding default addon cb.theme.dark Error in the application: Error: EACCES, unlink '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators' Error initializing CodeBox { [Error: EACCES, unlink '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators'] errno: 3, code: 'EACCES', path: '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators' } Error: EACCES, unlink '/usr/local/lib/node_modules/codebox/.addons/cb.collaborators' $
@bikerd

This comment has been minimized.

bikerd commented Jan 15, 2014

update:

changing the file permissions on /usr/local/lib/node_modules/codebox/.addons/

from

drwxr-xr-x 2 root root 2048 Jan 14 19:00 .addons/

to:

drwxrwxrwx 2 root root 2048 Jan 15 07:38 .addons/

allows codebox to start with non-priv account.

Is this an okay thing to do, or is there a better way?

@SamyPesse

This comment has been minimized.

Member

SamyPesse commented Jan 15, 2014

We are going to make a better fix that will move these files (.addons and settings.json) in ~/.codebox so no need to sudo or root files permissions

@bikerd

This comment has been minimized.

bikerd commented Jan 15, 2014

thanks...i'm onto the next item...how to run Python code

when I run a python file in the editor, I get:

"An error occurred when trying to run this project: The project has no supported type"

is there an addon that needs to be installed to support python code?

i'm digging also...

@bikerd

This comment has been minimized.

bikerd commented Jan 15, 2014

hi,

is there something special that needs to be done for codebox/run to recognize python source files (.py)?

thanks!!

@bikerd

This comment has been minimized.

bikerd commented Jan 15, 2014

okay, i see that right-clicking on an individual file in the sidebar has a "Run" option that will only run the file (vs a project)

@bikerd

This comment has been minimized.

bikerd commented Jan 16, 2014

hi,

is there a way to make codebox use the loopback ip address - 127.0.0.1 - instead of the server's public facing ip address?

thanks!

@SamyPesse

This comment has been minimized.

Member

SamyPesse commented Jan 16, 2014

@bikerd can you add a new issue for this please.

@AaronO AaronO closed this Jan 18, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment