seeInField doesn't see value of disabled form fields #2378

Closed
lowerends opened this Issue Sep 18, 2015 · 3 comments

Comments

Projects
None yet
3 participants
@lowerends

Using the seeInField function on a disabled form field or a form field within a disabled field set always leads to an empty value for that form field. This makes it impossible to test for a given value in a disabled field. This did work in version 2.0.12 but is not working anymore in the latest version 2.1.2.

@lowerends lowerends changed the title from seeInField doesn't see disabled form fields to seeInField doesn't see value of disabled form fields Sep 18, 2015

@Naktibalda

This comment has been minimized.

Show comment
Hide comment
@Naktibalda

Naktibalda Sep 18, 2015

Member

Related PR #2252

Member

Naktibalda commented Sep 18, 2015

Related PR #2252

@Naktibalda

This comment has been minimized.

Show comment
Hide comment
@Naktibalda

Naktibalda Sep 18, 2015

Member

Actually my change doesn't look related, seeInField doesn't call getFormValuesFor directly or indirectly.

I found a major refactoring of proceedSeeInField which was made in 2.0.13 version c048980#diff-fde80abc0dc33fc4bca3b43f571f8934L321 by @zbateson

Member

Naktibalda commented Sep 18, 2015

Actually my change doesn't look related, seeInField doesn't call getFormValuesFor directly or indirectly.

I found a major refactoring of proceedSeeInField which was made in 2.0.13 version c048980#diff-fde80abc0dc33fc4bca3b43f571f8934L321 by @zbateson

@lowerends

This comment has been minimized.

Show comment
Hide comment
@lowerends

lowerends Sep 18, 2015

Indeed, I first thought your PR was related but then I noticed the problem remained after reverting this PR. After some more testing, I can indeed confirm that the problem originates in version 2.0.13.

Indeed, I first thought your PR was related but then I noticed the problem remained after reverting this PR. After some more testing, I can indeed confirm that the problem originates in version 2.0.13.

@DavertMik DavertMik added the BUG label Sep 23, 2015

DavertMik added a commit that referenced this issue Sep 29, 2015

@DavertMik DavertMik closed this in #2414 Sep 29, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment