New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[WebDriver] Add deleteAllCookies before loadSessionSnapshot #4487

Merged
merged 2 commits into from Sep 11, 2017

Conversation

Projects
None yet
2 participants
@eXorus
Contributor

eXorus commented Sep 6, 2017

Hello,

Sometimes when I load session snapshot it seems not working (user is log in but with very strange behaviour). I can't reproduce this every times but in my project I found this fix that work better.

I think when we need to load the cookies we need to delete all cookies before to be sure to not have a mix of different cookie in the same browser.

First browser

cookieA
cookieB
=> saveSessionSnapshot

Second browser

cookie1
cookie2
=> loadSessionSnapshot

Actual result:
cookie1, cookie2, cookieA, cookieB

Expected result:
cookieA, cookieB

@DavertMik DavertMik merged commit 82b61a7 into Codeception:2.3 Sep 11, 2017

4 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
semaphoreci The build passed on Semaphore.
Details
wercker/build Wercker pipeline passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment