Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Instructions should mention that you need "sass-rails" #8

Closed
tysontate opened this Issue · 3 comments

5 participants

@tysontate

With:

group :assets do
  gem 'compass-rails'
end

I get:

> bundle exec compass init
NoMethodError on line ["15"] of /Users/tyson/.rbenv/versions/1.9.3-p0/lib/ruby/gems/1.9.1/gems/compass-rails-1.0.0.rc.1/lib/compass-rails.rb: undefined method `application' for Rails:Module
Run with --trace to see the full backtrace

But with:

group :assets do
  gem 'sass-rails',    :git => 'git://github.com/rails/sass-rails.git'
  gem 'compass-rails'
end

it works

This is on the latest rails HEAD.

@scottdavis
Owner

thanks ill get this documented i really that i couldn't directly depend on sass-rails because of rails 2.3 support

@ericdfields

Doesn't seem you need this for rails 3.0. Just 3.1 I believe.

@colindean

I myself hit this today.

@chriseppstein chriseppstein closed this issue from a commit
@chriseppstein chriseppstein Update docs to show when sass-rails is needed.
In rails 3.1 or greater, the sass-rails gem is required.

Closes GH-8.
972091c
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.