Permalink
Browse files

haml 2.2 dependency

  • Loading branch information...
filiptepper committed Jul 8, 2009
1 parent 8d938f3 commit 85bb337f50a3a3dfaafa2820d5463f7296140c9e
View
@@ -1,6 +1,11 @@
COMPASS CHANGELOG
=================
0.8.6 (July 08, 2009)
---------------------
Haml 2.2 dependency.
0.8.5 (July 06, 2009)
---------------------
@@ -159,7 +164,7 @@ Fixed some build issues and a bug in the rewritten --watch mode that caused chan
### Configuration
* **Asset Hosts**. You can now configure the asset host(s) used for images via the image_url() function.
Asset hosts are off unless configured and also off when relative urls are enabled.
Asset hosts are off unless configured and also off when relative urls are enabled.
[Commit](http://github.com/chriseppstein/compass/commit/ef47f3dd9dbfc087de8b12a90f9a82993bbb592e).
In your compass configuration file, you must define an asset_host algorithm to be used like so:
# Return the same host for all images:
View
@@ -2,7 +2,7 @@
Gem::Specification.new do |s|
s.name = %q{compass}
s.version = "0.8.5"
s.version = "0.8.6"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Chris Eppstein"]
@@ -2,11 +2,11 @@
# Compass Ruby on Rails Installer (template) v.1.0
# written by Derek Perez (derek@derekperez.com)
# -----------------------------------------------------------------
# NOTE: This installer is designed to work as a Rails template,
# NOTE: This installer is designed to work as a Rails template,
# and can only be used with Rails 2.3+.
# -----------------------------------------------------------------
# Copyright (c) 2009 Derek Perez
#
#
# Permission is hereby granted, free of charge, to any person
# obtaining a copy of this software and associated documentation
# files (the "Software"), to deal in the Software without
@@ -15,10 +15,10 @@
# copies of the Software, and to permit persons to whom the
# Software is furnished to do so, subject to the following
# conditions:
#
#
# The above copyright notice and this permission notice shall be
# included in all copies or substantial portions of the Software.
#
#
# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
# OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
@@ -46,11 +46,11 @@
css_dir = "public/stylesheets/compiled" if css_dir.blank?
# define dependencies
gem "haml-edge", :lib => "haml"
gem "haml", :lib => "haml", :version => ">=2.2.0"
gem "chriseppstein-compass", :source => "http://gems.github.com/", :lib => "compass"
# install and unpack
rake "gems:install GEM=haml-edge", :sudo => true
rake "gems:install GEM=haml", :sudo => true
rake "gems:install GEM=chriseppstein-compass", :sudo => true
rake "gems:unpack GEM=chriseppstein-compass"
@@ -69,7 +69,7 @@
# Require compass during plugin loading
file 'vendor/plugins/compass/init.rb', <<-CODE
# This is here to make sure that the right version of sass gets loaded (haml-edge) by the compass requires.
# This is here to make sure that the right version of sass gets loaded (haml 2.2) by the compass requires.
require 'compass'
CODE
@@ -1,9 +1,9 @@
unless defined?(Sass)
require 'rubygems'
begin
gem 'haml-edge','>= 2.1'
gem 'haml','>= 2.2.0'
rescue Exception
$stderr.puts "WARNING: haml-edge gem not found. Trying to find haml on the load path."
$stderr.puts "WARNING: haml 2.2 gem not found. Trying to find haml on the load path."
end
require 'sass'
end

0 comments on commit 85bb337

Please sign in to comment.