Join GitHub today
GitHub is home to over 28 million developers working together to host and review code, manage projects, and build software together.Sign up
Compass 1.0.0 depends on Listen 1.1 #1634
I've been successfully using Sass 3.2 and Compass 0.12.x with rake-pipeline for several projects for a while now; the setup I have uses listen and rerun to rebuild all assets whenever they change on-disk, but recently I decided I'd like to try out Sass 3.3. Unfortunately Compass 0.12.x is incompatible with Sass 3.3, and Compass 1.0.0 now depends on a pretty old version of listen, which results in an unresolvable dependency problem:
rerun 0.8.2 depends on listen ~> 1.0.3
Could Compass 1.0.0 be updated to use listen ~> 2.7 instead? Alternatively (and perhaps preferably) could the part of Compass that requires on listen be made modular (it seems out of scope for Compass to be responsible for this functionality, given how most people will be using something like e.g. Sprockets to compile SCSS, so perhaps it ought to be a separate gem?).
I'm experiencing a similar dependency spaghetti problem to @kapowaz while experimenting with "compass", "~> 1.0.0.alpha.19".
Would it be possible to have the
Note that we previously didn't rely on listen:
Sass doesn't even include it in their gemspec, they just require from the local gems and fall back to a vendored version for old versions of ruby (from what I can tell)...
Edit: After some more research I think just upgrading Listen to 2.x.x is the way to go, then those who want to let Sass handle it can use the new compass-core gem.
Same problem here using Compass 1.x with Jekyll 2.0.3, like @jonathansick. For the sake of those searching for the text of an error message and wondering what the problem is, here’s the text of the error message I received:
referenced this issue
Jul 1, 2014
Gems and bundles using sass or compass should now explicitly mention listen v2.