Span mixin deprecation warnings for Blueprint grid #796

Closed
billsaysthis opened this Issue Mar 15, 2012 · 2 comments

Projects

None yet

2 participants

@billsaysthis

Using @import "blueprint/grid" should not generate deprecation warnings as I see (in 0.12 and 0.12.1), as shown below. This may only be a warning but its annoying to see on every compile and makes it harder to see errors or warnings coming from my code.

WARNING: The span mixin is deprecated. Please use the span function instead. E.g. width: span(6)
         on line 123 of /Users/billlazar/.rvm/gems/ruby-1.9.3-p125/gems/compass-0.12.1/frameworks/blueprint/stylesheets/blueprint/_grid.scss, in `span'
@chriseppstein
Member

It was deprecated in 0.11 actually. 1369545

@billsaysthis

I see, thought this was coming from the gem but now I see better. Sorry for the interruption.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment