Show warning/error on unknown function #946

Closed
tholewebgods opened this Issue Jun 28, 2012 · 1 comment

Comments

Projects
None yet
2 participants
@tholewebgods

Compass should show warning/error on unknown functions.

Recently I've checked out styles that has been modified by a colleague which was using compass-0.12.2 while I was using compass-0.11.5 which was not ware of the new image-height() functions. Compile/watch run perfectly without errors but some styles were broken. Nothing showed that there was an error.

Not sure which sass version I was using that time.

This .scss code has been written to the .css file:

height: image-height(sprite-file($btnsprite, diashownavi-download));
@chriseppstein

This comment has been minimized.

Show comment Hide comment
@chriseppstein

chriseppstein Jun 28, 2012

Owner

This is how sass works in order to be future friendly. There are too many CSS functions for us to try to know which functions should be passed thru to CSS and which are typos of sass functions.

Hunt & pecked on my iPhone... Sorry if it's brief!

On Jun 28, 2012, at 2:29 AM, Thomas Lehmannreply@reply.github.com wrote:

Compass should show warning/error on unknown functions.

Recently I've checked out styles that has been modified by a colleague which was using compass-0.12.2 while I was using compass-0.11.5 which was not ware of the new image-height() functions. Compile/watch run perfectly without errors but some styles were broken. Nothing showed that there was an error.

Not sure which sass version I was using that time.

This SCSS code has been written to the .scss file:

height: image-height(sprite-file($btnsprite, diashownavi-download));

Reply to this email directly or view it on GitHub:
chriseppstein#946

Owner

chriseppstein commented Jun 28, 2012

This is how sass works in order to be future friendly. There are too many CSS functions for us to try to know which functions should be passed thru to CSS and which are typos of sass functions.

Hunt & pecked on my iPhone... Sorry if it's brief!

On Jun 28, 2012, at 2:29 AM, Thomas Lehmannreply@reply.github.com wrote:

Compass should show warning/error on unknown functions.

Recently I've checked out styles that has been modified by a colleague which was using compass-0.12.2 while I was using compass-0.11.5 which was not ware of the new image-height() functions. Compile/watch run perfectly without errors but some styles were broken. Nothing showed that there was an error.

Not sure which sass version I was using that time.

This SCSS code has been written to the .scss file:

height: image-height(sprite-file($btnsprite, diashownavi-download));

Reply to this email directly or view it on GitHub:
chriseppstein#946

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment