Skip to content
Permalink
Browse files

Enforce Node 10 for API

ipfs-http-client requires Node >= 10.0.0. Make sure API Docker image
uses Node 10 and add engine constraint to package.json.
  • Loading branch information...
akuanti committed Apr 19, 2019
1 parent 1ecd43e commit 9a2546c1b3ea56942f3299300c21d72aee3a60c1
Showing with 6 additions and 0 deletions.
  1. +4 −0 api/package.json
  2. +2 −0 docker/api/Dockerfile
@@ -1,6 +1,10 @@
{
"name": "panvala-api",
"version": "0.0.1",
"engines": {
"node": ">= 10.0.0",
"npm": ">= 6.0.0"
},
"description": "Panvala API service",
"main": "index.js",
"scripts": {
@@ -11,6 +11,8 @@ RUN apt-get update && apt-get install -y curl gnupg
RUN curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | apt-key add -
RUN echo "deb https://dl.yarnpkg.com/debian/ stable main" | tee /etc/apt/sources.list.d/yarn.list

# Set up for node 10 install
RUN curl -sL https://deb.nodesource.com/setup_10.x | bash -

# RUN apt-get update && apt remove -y cmdtest && apt-get install -y \
RUN apt-get update && apt-get install -y \

0 comments on commit 9a2546c

Please sign in to comment.
You can’t perform that action at this time.