Permalink
Browse files

Depend on rubyzip, not zip

The 'zip' gem is unmaintained and obsolete. 'rubzip' is
the most popular and best supported zip gem for ruby.
It supports Ruby 1.9 and Windows.
  • Loading branch information...
1 parent e859100 commit d117d24989f4b13571483bed98f9de288dd4e359 @jfirebaugh jfirebaugh committed Oct 23, 2012
Showing with 3 additions and 15 deletions.
  1. +1 −3 README.rdoc
  2. +1 −11 crxmake.gemspec
  3. +1 −1 lib/crxmake.rb
View
@@ -6,8 +6,6 @@
make chromium extensions
-** Using 'zip' gem instead of 'zipruby' to support RubyInstaller for Windows.
-
== SYNOPSIS:
ruby code
require 'crxmake'
@@ -64,7 +62,7 @@ command line
== REQUIREMENTS:
* openssl
-* zip
+* rubyzip
== INSTALL:
View
@@ -21,15 +21,5 @@ Gem::Specification.new do |s|
s.summary = %q{make chromium extension}
s.test_files = ["test/crxmake_test.rb"]
- if s.respond_to? :specification_version then
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<zip>, ["~> 2.0.2"])
- else
- s.add_dependency(%q<zip>, ["~> 2.0.2"])
- end
- else
- s.add_dependency(%q<zip>, ["~> 2.0.2"])
- end
+ s.add_runtime_dependency "rubyzip"
end
View
@@ -1,7 +1,7 @@
#!/usr/bin/ruby
# vim: fileencoding=utf-8
require 'rubygems'
-require 'zip'
+require 'zip/zip'
require 'openssl'
require 'digest/sha1'
require 'fileutils'

0 comments on commit d117d24

Please sign in to comment.