Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

libgfortran broken? #686

Closed
swryan opened this issue Mar 7, 2016 · 37 comments

Comments

Projects
None yet
@swryan
Copy link

commented Mar 7, 2016

Started getting this error a couple days ago:
ImportError: /home/travis/miniconda/lib/python2.7/site-packages/scipy/special/../../../../libgfortran.so.3: version GFORTRAN_1.4' not found (required by /usr/lib/liblapack.so.3gf)`

It seems coincident with the latest update to libgfortran:
https://anaconda.org/anaconda/libgfortran/files

Would appreciate any insight into what the issue is and more importantly, what the fix is:
https://travis-ci.org/OpenMDAO/OpenMDAO/jobs/114269055

Thanks!

@swryan swryan changed the title libgfortran has broken petsc? libgfortran broken on ubuntu? Mar 7, 2016

@swryan swryan changed the title libgfortran broken on ubuntu? libgfortran broken? Mar 7, 2016

@swryan

This comment has been minimized.

Copy link
Author

commented Mar 8, 2016

Am able to work around this on my local machine by pre-loading the system level libgfortran, bypassing the anaconda provided one:

export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libgfortran.so.3

Seems like the the anaconda libgfortran just needs rebuilt with the "proper" compiler?

Please advise...

@rowanc1

This comment has been minimized.

Copy link

commented Mar 9, 2016

I just came across this as well. The "fix" that I worked up for now was to revert to scipy to 0.16.0.

I also found that bypassing the libgfortran.so.3 in the conda/lib folder also works. I would love to test my packages against the most recent versions of scipy however. A better solution would be ideal!

Broken:
https://travis-ci.org/rowanc1/pymatsolver/builds/107373331
'Fixed':
https://travis-ci.org/rowanc1/pymatsolver/builds/114681631

@jakirkham

This comment has been minimized.

Copy link

commented Mar 10, 2016

@basnijholt, you may be interested in following this issue.

@basnijholt

This comment has been minimized.

Copy link

commented Mar 10, 2016

@jakirkham thank you! 👍

I build a package that also depends on libgfortan, however after the update of libgfortran it didn't work anymore.

Then I tried to force the package to depend on libgfortran v1, however in conda < 4 this specification is not respected.

This is a problem on Binder for example, where a Docker image is generated from an environment.yml file. Here I could specify conda v4, however it will then install conda with the old version and simultaneously install incorrect versions of other packages.

@jakirkham

This comment has been minimized.

Copy link

commented Mar 10, 2016

So, maybe you could suggest to the Binder maintainers that they update to a newer version of conda. Though I don't know how many bug fix releases we are going to go through with 4.x.

In the interim, you could add some hacky steps in your notebook in the beginning to fix conda by running conda update and such.

Alternatively, Binder let's you use Docker. So, you could write a Dockerfile that provides you with a working conda environment of your choosing.

Of the two options, adding hacky steps with conda is probably the easiest, but also the most error prone. Using Docker requires a bit more work (depending on your familiarity), but is probably the most reliable solution.

@basnijholt

This comment has been minimized.

Copy link

commented Mar 10, 2016

I already asked the Binder guys to update conda, and they will do it :)

@tritemio

This comment has been minimized.

Copy link

commented Mar 16, 2016

Cross-posting from conda/conda#2177

This (or a similar) issue is causing ReadTheDocs and Binder to fail in importing scipy when using conda envs: rtfd/readthedocs.org#2074

The error is triggered when importing scipy.stats:

ImportError: libgfortran.so.1: cannot open shared object file: No such file or directory

For the full RTD logs see http://readthedocs.org/projects/fretbursts/builds/3813468/

Binder images containing scipy are created correctly but then importing scipy.stats fails with the above message. An example image with the issue is here:

Binder

@insertinterestingnamehere

This comment has been minimized.

Copy link

commented Mar 16, 2016

@tritemio You're fixing the bugfix releases and even the build numbers for the packages. You can either specify libgfortran=1.0 as well, or you can use the latest builds. Either one will work.

@basnijholt

This comment has been minimized.

Copy link

commented Mar 16, 2016

Rebuilding with libgfortran 3 doesn't work. The linking with other packages that I depend on gcc , libgcc, and openblas, fails.

EDIT: there also is a dependency on zlib.

@jakirkham

This comment has been minimized.

Copy link

commented Mar 16, 2016

I wonder if the libgfortran dependency can be done away with and libgcc used instead. There are enough other things that use libgcc that this might just be the right way to go.

@basnijholt

This comment has been minimized.

Copy link

commented Mar 16, 2016

I don't know if it is of help for anyone, but the build of kwant that works fine with libgfortran 1, but not with 3 (the package MUMPS is not correctly linked), appears to work fine when I give gcc as a runtime lib and having libgfortran v3.

Maybe this gives a clue to someone with more knowledge in this area.

@tritemio

This comment has been minimized.

Copy link

commented Mar 16, 2016

@insertinterestingnamehere, thanks. Yes the problem was that I generated the environment file on os x and used it on linux. A given combination of anaconda packages may have different bugs on different platforms and the build number are increased independently in order to fix build issued such as the one here. Note to self: it is a good idea to remove the build number from the environment files in order to avoid this kind of issues.

@msarahan

This comment has been minimized.

Copy link
Member

commented Mar 16, 2016

@MoritzImendoerffer

This comment has been minimized.

Copy link

commented Mar 16, 2016

I have a similar issue with the asssimulo package and scipy 0.17 on python 3.4.
anaconda3/envs/scipy0.17/lib/python3.4/site-packages/scipy/linalg/../../../../libgfortran.so.3: versionGFORTRAN_1.4' not found (required by /home/moritz/anaconda3/envs/scipy0.17/lib/python3.4/site-packages/assimulo/lib/radau5.cpython-34m.so`

The tip from swryan helped.

@dprada

This comment has been minimized.

Copy link

commented Mar 22, 2016

I had a similar problem. And also the annoying message saying that the license of mkl was about to expire. In my case this was solved updating conda to 4.0. After that numpy and scypi were also updated to:

    numexpr:      2.4.4-np110py27_p0  [mkl] --> 2.5-np110py27_0   
    numpy:        1.10.2-py27_p0      [mkl] --> 1.10.4-py27_1     
    pytables:     3.2.2-np110py27_0   --> 3.2.2-np110py27_1 
    scikit-learn: 0.17-np110py27_p1   [mkl] --> 0.17.1-np110py27_0
    scipy:        0.16.1-np110py27_p0 [mkl] --> 0.17.0-np110py27_2
@Zaharid

This comment has been minimized.

Copy link

commented Mar 28, 2016

It so happens that the conda libgcc package contains a good libgfortran.so.3 file, with the 1.4 symbols defined:

So if I only have libgcc,

(_test) $ conda list
# packages in environment at /home/zah/anaconda3/envs/_test:
#
apfel                     2.7.1.102                     3    file:///home/zah/anaconda3/conda-bld/linux-64/apfel-2.7.1.102-3.tar.bz2
boost                     1.60.0                   py35_0    defaults
icu                       54.1                          0    defaults
lhapdf                    6.1.6                         6    https://zigzah.com/static/conda-pkgs/linux-64/lhapdf-6.1.6-6.tar.bz2
libgcc                    4.8.5                         1    defaults
openssl                   1.0.2g                        0    defaults
pip                       8.1.1                    py35_0    defaults
python                    3.5.1                         0    defaults
readline                  6.2                           2    <unknown>
setuptools                20.3                     py35_0    defaults
sqlite                    3.9.2                         0    defaults
tabulate                  0.7.5                     <pip>
tk                        8.5.18                        0    defaults
wheel                     0.29.0                   py35_0    defaults
xz                        5.0.5                         1    defaults
zlib                      1.2.8                         0    http://repo.continuum.io/pkgs/free/linux-64/zlib-1.2.8-0.tar.bz2

I can

(_test)$ readelf -Ws /home/zah/anaconda3/envs/_test/bin/../lib/libgfortran.so.3 | grep GFORTRAN_1.4
     9: 00000000000e91f0    53 FUNC    GLOBAL DEFAULT   11 _gfortran_cshift0_16_char4@@GFORTRAN_1.4
    48: 0000000000088a40   973 FUNC    GLOBAL DEFAULT   11 _gfortran_miall_i2@@GFORTRAN_1.4
    72: 00000000000df120     5 FUNC    GLOBAL DEFAULT   11 _gfortran_transfer_complex128_write@@GFORTRAN_1.4
    93: 000000000008ec10   893 FUNC    GLOBAL DEFAULT   11 _gfortran_iparity_i1@@GFORTRAN_1.4

However after installing lingfortran, I get an older version without those symbols:

$ conda install libgfortran --yes
Using Anaconda Cloud api site https://api.anaconda.org
Fetching package metadata: ..........
Solving package specifications: .........

Package plan for installation in environment /home/zah/anaconda3/envs/_test:

The following NEW packages will be INSTALLED:

    libgfortran: 3.0-0

Linking packages ...
[      COMPLETE      ]|########################################################################################| 100%
(_test) $ readelf -Ws /home/zah/anaconda3/envs/_test/bin/../lib/libgfortran.so.3 | grep GFORTRAN_1.4

This is behaviour breaks packages that build well with libgcc, because the libffortran overwrites the more modern version of the .so, such as this:

https://github.com/Zaharid/conda-recipes/tree/master/apfel

Would be grateful if this could be fixed soon.

@Zaharid

This comment has been minimized.

Copy link

commented Mar 28, 2016

A workaround seems to be simply:

conda remove libgfortran
conda install libgcc --force
@nickvandewiele

This comment has been minimized.

Copy link

commented Mar 29, 2016

+1

@mikaem

This comment has been minimized.

Copy link

commented Mar 30, 2016

This may be related. I just downloaded and installed Anaconda 4.0.0. Then did conda install gcc. The gcc and g++ versions are as expected the conda version 4.8.5. However, gfortran is now using version 4.9.2, which is my native gfortran compiler on my ubuntu 15.04. If I'm doing which gfortran, the answer is still ~/anaconda2/bin/gfortran though. With Anaconda 2.5.0 the conda install gcc gives me as expected gfortran version 4.8.5.
Removing libgfortran as @Zaharid says fixes my problem.

@bjodah

This comment has been minimized.

Copy link

commented Apr 3, 2016

I just encountered this and @Zaharid's work-around solved my problem.

@basnijholt

This comment has been minimized.

Copy link

commented Apr 30, 2016

Great! But, where can I find it, I don't see it on the anaconda channel, nor on your channel.

@msarahan

This comment has been minimized.

Copy link
Member

commented Apr 30, 2016

Also, I should add that my update is a short-term band-aid. We are trying to figure out how to capture build requirements better at build time - so things like the GFORTRAN_1.x as well as package version numbers. That will be necessary to fix these kinds of issues long-term.

@msarahan

This comment has been minimized.

Copy link
Member

commented Apr 30, 2016

Should be in the default channel, let me make sure...

I see it as:

libgfortran                  1.0                           0  defaults
                             3.0                           0  defaults
                             3.0.0                         1  defaults

The last one is the "good" one

@fivejjs

This comment has been minimized.

Copy link

commented May 15, 2016

export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libgfortran.so.3

works for me.

@MoritzImendoerffer

This comment has been minimized.

Copy link

commented May 23, 2016

Just did a fresh install. Unfortunately conda update libgfortran (conda update --all did not update libgfortran) results in a downgrade of scipy to version 0.16 and scipy.optimize.least_squares is not longer available. I did conda update scipy --force afterwards and it works now. Easier: conda update libgfortran --force

@kayhan-batmanghelich

This comment has been minimized.

Copy link

commented May 26, 2016

Any update on this? I tried removing and installing libgfortran as suggested by @MoritzImendoerffer and @Zaharid . None of those worked for me. This is the error message I get:

In [1]: import numpy as np
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-4ee716103900> in <module>()
----> 1 import numpy as np

/home/batmanghelich/anaconda/lib/python2.7/site-packages/numpy/__init__.py in <module>()
    178         return loader(*packages, **options)
    179
--> 180     from . import add_newdocs
    181     __all__ = ['add_newdocs',
    182                'ModuleDeprecationWarning',

/home/batmanghelich/anaconda/lib/python2.7/site-packages/numpy/add_newdocs.py in <module>()
     11 from __future__ import division, absolute_import, print_function
     12
---> 13 from numpy.lib import add_newdoc
     14
     15 ###############################################################################

/home/batmanghelich/anaconda/lib/python2.7/site-packages/numpy/lib/__init__.py in <module>()
      6 from numpy.version import version as __version__
      7
----> 8 from .type_check import *
      9 from .index_tricks import *
     10 from .function_base import *

/home/batmanghelich/anaconda/lib/python2.7/site-packages/numpy/lib/type_check.py in <module>()
      9            'common_type']
     10
---> 11 import numpy.core.numeric as _nx
     12 from numpy.core.numeric import asarray, asanyarray, array, isnan, \
     13                 obj2sctype, zeros

/home/batmanghelich/anaconda/lib/python2.7/site-packages/numpy/core/__init__.py in <module>()
     12         os.environ[envkey] = '1'
     13         env_added.append(envkey)
---> 14 from . import multiarray
     15 for envkey in env_added:
     16     del os.environ[envkey]

ImportError: libgfortran.so.1: cannot open shared object file: No such file or directory

This is my package info:

[batmanghelich@login001 ~]$ conda list
# packages in environment at /home/batmanghelich/anaconda:
#
_license                  1.1                      py27_0    <unknown>
abstract-rendering        0.5.1                np19py27_0    <unknown>
accelerate                1.10.0              np19py27_p0    http://repo.continuum.io/pkgs/pro/linux-64/accelerate-1.10.0-np19py27_p0.tar.bz2
alabaster                 0.7.3                    py27_0    defaults
anaconda                  2.3.0                np19py27_0    defaults
anaconda-client           1.2.1                    py27_0    defaults
apache-maven              3.2.1                         0    mutirri
argcomplete               0.8.9                    py27_0    defaults
astropy                   1.0.3                np19py27_0    defaults
atom                      0.3.9                    py27_0    <unknown>
autograd                  1.1.4                     <pip>
babel                     1.3                      py27_0    defaults
backports-abc             0.4                       <pip>
backports.ssl-match-hostname 3.4.0.2                   <pip>
backports_abc             0.4                      py27_0    defaults
bcolz                     0.9.0                np19py27_0    defaults
beautiful-soup            4.3.2                    py27_0    <unknown>
beautifulsoup4            4.4.1                    py27_0    defaults
binstar                   0.11.0                   py27_0    defaults
bitarray                  0.8.1                    py27_0    <unknown>
blaze                     0.7.0.post112.g28557e4     np19py27_98    https://conda.binstar.org/blaze/linux-64/blaze-0.7.0.post112.g28557e4-np19py27_98.tar.bz2
blaze-core                0.8.0                np19py27_0    defaults
blz                       0.6.2                np19py27_1    defaults
bokeh                     0.9.0                np19py27_0    defaults
boto                      2.38.0                   py27_0    defaults
bottleneck                1.0.0                np19py27_0    defaults
brewer2mpl                1.4                      py27_0    salford_systems
cairo                     1.12.18                       4    defaults
casuarius                 1.1                      py27_0    <unknown>
cdecimal                  2.3                      py27_0    <unknown>
certifi                   14.05.14                 py27_0    defaults
cffi                      1.1.0                    py27_0    defaults
chaco                     4.4.1                np19py27_0    <unknown>
chest                     0.2.3                    py27_0    defaults
click                     6.2                       <pip>
cloudpickle               0.1.1                     <pip>
clyent                    0.3.4                    py27_0    defaults
cmake                     3.3.1                         0    defaults
colorama                  0.3.3                    py27_0    defaults
conda                     4.0.7                    py27_0    defaults
conda-build               1.8.2                    py27_0    <unknown>
conda-env                 2.4.5                    py27_0    defaults
configobj                 5.0.6                    py27_0    <unknown>
cryptography              0.9.1                    py27_0    defaults
cudamat                   0.3                       <pip>
cudatoolkit               6.0                          p0    http://repo.continuum.io/pkgs/pro/linux-64/cudatoolkit-6.0-p0.tar.bz2
curl                      7.43.0                        0    defaults
cycler                    0.9.0                    py27_0    defaults
cyflann                   0.1.23               np19py27_2    dougal
cython                    0.22.1                   py27_0    defaults
cytoolz                   0.7.3                    py27_0    defaults
dask                      0.7.5                    py27_0    defaults
datashape                 0.4.5                np19py27_0    defaults
dateutil                  2.1                      py27_2    <unknown>
decorator                 3.4.2                    py27_0    defaults
dill                      0.2.4                    py27_0    defaults
distributed               1.6.1                     <pip>
docutils                  0.12                     py27_0    <unknown>
dynd-python               0.6.5                np19py27_0    <unknown>
ecdsa                     0.13                      <pip>
enable                    4.3.0                np19py27_2    <unknown>
enaml                     0.9.8                    py27_1    defaults
enum34                    1.0.4                    py27_0    http://repo.continuum.io/pkgs/free/linux-64/enum34-1.0.4-py27_0.tar.bz2
fastcache                 1.0.2                    py27_0    defaults
flann                     1.8.5dev                      8    dougal
flask                     0.10.1                   py27_1    <unknown>
fontconfig                2.11.1                        4    defaults
freetype                  2.5.2                         2    defaults
funcsigs                  0.4                      py27_0    http://repo.continuum.io/pkgs/free/linux-64/funcsigs-0.4-py27_0.tar.bz2
future                    0.13.1                   py27_0    <unknown>
futures                   2.1.6                    py27_0    <unknown>
gevent                    1.0.1                    py27_0    <unknown>
gevent-websocket          0.9.3                    py27_0    <unknown>
glib                      2.43.0                        2    r
gpy                       1.0.9                     <pip>
greenlet                  0.4.7                    py27_0    defaults
grin                      1.2.1                    py27_1    <unknown>
gslrandom                 0.1.1                     <pip>
h5py                      2.5.0                np19py27_3    defaults
harfbuzz                  0.9.39                        0    defaults
hdf5                      1.8.15.1                      1    defaults
heapdict                  1.0.0                    py27_0    defaults
idna                      2.0                      py27_0    defaults
into                      0.1.3                np19py27_0    http://repo.continuum.io/pkgs/free/linux-64/into-0.1.3-np19py27_0.tar.bz2
iopro                     1.6.11              np19py27_p0    http://repo.continuum.io/pkgs/pro/linux-64/iopro-1.6.11-np19py27_p0.tar.bz2
ipaddress                 1.0.7                    py27_0    defaults
ipykernel                 4.0.3                    py27_0    defaults
ipyparallel               4.1.0                    py27_0    defaults
ipython                   3.2.0                    py27_0    defaults
ipython-cluster-helper    0.5.0                    py27_0    bioconda
ipython-genutils          0.1.0                     <pip>
ipython-notebook          3.2.0                    py27_0    defaults
ipython-qtconsole         3.2.0                    py27_0    defaults
ipython_genutils          0.1.0                    py27_0    defaults
ipywidgets                4.1.0                    py27_0    defaults
itsdangerous              0.24                     py27_0    <unknown>
jbig                      2.1                           0    defaults
jdcal                     1.0                      py27_0    <unknown>
jedi                      0.8.1                    py27_0    defaults
jinja2                    2.7.3                    py27_1    <unknown>
joblib                    0.8.4                    py27_0    defaults
jpeg                      8d                            0    <unknown>
jsonschema                2.4.0                    py27_0    defaults
jupyter                   1.0.0                    py27_1    defaults
jupyter-client            4.1.1                     <pip>
jupyter-console           4.0.3                     <pip>
jupyter-core              4.0.6                     <pip>
jupyter_client            4.1.1                    py27_0    defaults
jupyter_console           4.0.3                    py27_0    defaults
jupyter_core              4.0.6                    py27_0    defaults
kiwisolver                0.1.3                    py27_0    <unknown>
lcms                      1.19                          0    <unknown>
libdynd                   0.6.5                         0    <unknown>
libffi                    3.0.13                        0    <unknown>
libgcc                    5.2.0                         0    defaults
libpng                    1.6.17                        0    defaults
libsodium                 0.4.5                         0    <unknown>
libtiff                   4.0.2                         1    <unknown>
libxml2                   2.9.2                         0    defaults
libxslt                   1.1.28                        0    <unknown>
llvm                      3.3                           0    <unknown>
llvmlite                  0.5.0                    py27_0    defaults
llvmpy                    0.12.7                   py27_0    <unknown>
locket                    0.2.0                    py27_0    defaults
lxml                      3.4.4                    py27_0    defaults
markupsafe                0.23                     py27_0    <unknown>
matlabengineforpython     R2015a                    <pip>
matplotlib                1.4.3                np19py27_2    defaults
mistune                   0.5.1                    py27_1    defaults
mkl                       11.3.1                        0    defaults
mkl-rt                    11.1                         p0    http://repo.continuum.io/pkgs/pro/linux-64/mkl-rt-11.1-p0.tar.bz2
mkl-service               1.0.0                   py27_p1    http://repo.continuum.io/pkgs/pro/linux-64/mkl-service-1.0.0-py27_p1.tar.bz2
mklfft                    2.0                 np19py27_p0    http://repo.continuum.io/pkgs/pro/linux-64/mklfft-2.0-np19py27_p0.tar.bz2
mock                      1.0.1                    py27_0    <unknown>
mpi4py                    1.3                      py27_0    <unknown>
mpich2                    1.4.1p1                       0    <unknown>
mpld3                     0.2                       <pip>
multipledispatch          0.4.7                    py27_0    <unknown>
nbconvert                 4.1.0                    py27_0    defaults
nbformat                  4.0.1                    py27_0    defaults
ncurses                   5.9                           4    r
netifaces                 0.10.4                   py27_1    bioconda
networkx                  1.9.1                    py27_0    <unknown>
neurosynth                0.3.3                     <pip>
nibabel                   2.0.0                    py27_0    arthurmensch
nlopt                     2.4.2                         1    r
nltk                      3.0.3                np19py27_0    defaults
nose                      1.3.7                    py27_0    defaults
notebook                  4.0.6                    py27_0    defaults
numba                     0.19.1               np19py27_0    defaults
numbapro                  0.17.1              np19py27_p0    http://repo.continuum.io/pkgs/pro/linux-64/numbapro-0.17.1-np19py27_p0.tar.bz2
numbapro_cudalib          0.2                           0    http://repo.continuum.io/pkgs/free/linux-64/numbapro_cudalib-0.2-0.tar.bz2
numexpr                   2.4.3                np19py27_0    defaults
numpy                     1.9.2                    py27_0    defaults
odo                       0.3.2                np19py27_0    defaults
openblas                  0.2.14                        0    defaults
openpyxl                  1.8.5                    py27_0    <unknown>
openssl                   1.0.1k                        1    http://repo.continuum.io/pkgs/free/linux-64/openssl-1.0.1k-1.tar.bz2
pandas                    0.16.2               np19py27_0    defaults
pango                     1.39.0                        0    defaults
paramiko                  1.16.0                    <pip>
paramz                    0.5.5                     <pip>
partd                     0.3.2                    py27_1    defaults
patchelf                  0.6                           0    defaults
path.py                   8.1.2                    py27_1    defaults
patsy                     0.3.0                np19py27_0    <unknown>
pbr                       1.3.0                    py27_0    defaults
pcre                      8.31                          0    defaults
pep8                      1.6.2                    py27_0    defaults
pexpect                   3.3                      py27_0    defaults
pgmult (/home/batmanghelich/gitSandbox/pgmult) 0.1                       <pip>
pickleshare               0.5                      py27_0    defaults
pil                       1.1.7                    py27_2    defaults
pillow                    2.8.2                    py27_0    defaults
pip                       7.0.3                    py27_0    defaults
pixman                    0.26.2                        0    <unknown>
plinkio                   0.9.6                     <pip>
ply                       3.6                      py27_0    defaults
prettyplotlib             0.1.7                    py27_1    salford_systems
progressbar               0.2.3                    py27_1    http://conda.binstar.org/dougal/linux-64/progressbar-0.2.3-py27_1.tar.bz2
protobuf                  3.0.0b2                  py27_1    jjhelmus
psutil                    2.2.1                    py27_0    defaults
psycopg2                  2.6.1                    py27_0    defaults
ptyprocess                0.4                      py27_0    defaults
py                        1.4.27                   py27_0    defaults
py-sdm                    0.1.0dev            np19py27_15    http://conda.binstar.org/dougal/linux-64/py-sdm-0.1.0dev-np19py27_15.tar.bz2
py2cairo                  1.10.0                   py27_2    defaults
pyasn1                    0.1.7                    py27_0    defaults
pybasicbayes              0.2.1                     <pip>
pycairo                   1.10.0                   py27_0    defaults
pycosat                   0.6.1                    py27_0    <unknown>
pycparser                 2.14                     py27_0    defaults
pycrypto                  2.6.1                    py27_0    <unknown>
pycurl                    7.19.5.1                 py27_2    defaults
pyface                    4.4.0                    py27_0    <unknown>
pyflakes                  0.9.2                    py27_0    defaults
pygments                  2.0.2                    py27_0    defaults
pylds                     0.0.1                     <pip>
pymongo                   2.7.2                    py27_0    http://repo.continuum.io/pkgs/free/linux-64/pymongo-2.7.2-py27_0.tar.bz2
pyopenssl                 0.15.1                   py27_1    defaults
pyparsing                 2.0.3                    py27_0    defaults
pypolyagamma              0.2                       <pip>
pyprind                   2.9.1                     <pip>
pyqt                      4.11.3                   py27_1    defaults
pystan                    2.8.0.0                  py27_0    defaults
pytables                  3.2.0                np19py27_0    defaults
pytest                    2.7.1                    py27_0    defaults
python                    2.7.10                        0    defaults
python-dateutil           2.4.2                    py27_0    defaults
pytz                      2015.4                   py27_0    defaults
pyyaml                    3.11                     py27_1    defaults
pyzmq                     14.7.0                   py27_0    defaults
qt                        4.8.6                         3    defaults
qtconsole                 4.0.1                    py27_0    defaults
r                         3.2.2                         0    r
r-assertthat              0.1                   r3.2.2_1a    r
r-base                    3.2.2                         0    r
r-base64enc               0.1_3                 r3.2.2_0a    r
r-bh                      1.58.0_1              r3.2.2_0a    r
r-bitops                  1.0_6                 r3.2.2_1a    r
r-boot                    1.3_17                 r3.2.2_0    r
r-brew                    1.0_6                 r3.2.2_1a    r
r-car                     2.1_0                 r3.2.2_0a    r
r-caret                   6.0_62                r3.2.2_0a    r
r-catools                 1.17.1                r3.2.2_2a    r
r-chron                   2.3_47                r3.2.2_0a    r
r-class                   7.3_14                 r3.2.2_0    r
r-cluster                 2.0.3                  r3.2.2_0    r
r-codetools               0.2_14                 r3.2.2_0    r
r-colorspace              1.2_6                 r3.2.2_0a    r
r-curl                    0.9.4                 r3.2.2_0a    r
r-data.table              1.9.6                 r3.2.2_0a    r
r-dbi                     0.3.1                 r3.2.2_2a    r
r-devtools                1.9.1                 r3.2.2_0a    r
r-dichromat               2.0_0                 r3.2.2_2a    r
r-digest                  0.6.8                 r3.2.2_2a    r
r-dplyr                   0.4.3                 r3.2.2_0a    r
r-essentials              1.1                   r3.2.2_1a    r
r-evaluate                0.8                   r3.2.2_0a    r
r-foreach                 1.4.3                 r3.2.2_0a    r
r-foreign                 0.8_66                 r3.2.2_0    r
r-formatr                 1.2.1                 r3.2.2_0a    r
r-ggplot2                 1.0.1                 r3.2.2_0a    r
r-git2r                   0.11.0                r3.2.2_0a    r
r-glmnet                  2.0_2                 r3.2.2_0a    r
r-gtable                  0.1.2                 r3.2.2_2a    r
r-hexbin                  1.27.1                r3.2.2_0a    r
r-highr                   0.5.1                 r3.2.2_0a    r
r-htmltools               0.2.6                 r3.2.2_2a    r
r-htmlwidgets             0.5                   r3.2.2_0a    r
r-httpuv                  1.3.3                 r3.2.2_0a    r
r-httr                    1.0.0                 r3.2.2_0a    r
r-irdisplay               0.3                   r3.2.2_0a    r
r-irkernel                0.5                    r3.2.2_2    r
r-iterators               1.0.8                 r3.2.2_0a    r
r-jsonlite                0.9.17                r3.2.2_0a    r
r-kernsmooth              2.23_15                r3.2.2_0    r
r-knitr                   1.11                  r3.2.2_0a    r
r-labeling                0.3                   r3.2.2_1a    r
r-lattice                 0.20_33                r3.2.2_0    r
r-lazyeval                0.1.10                r3.2.2_2a    r
r-lme4                    1.1_10                r3.2.2_0a    r
r-magrittr                1.5                   r3.2.2_1a    r
r-maps                    3.0.0_2               r3.2.2_0a    r
r-markdown                0.7.7                 r3.2.2_1a    r
r-mass                    7.3_45                 r3.2.2_0    r
r-matrix                  1.2_2                  r3.2.2_0    r
r-matrixmodels            0.4_1                 r3.2.2_0a    r
r-memoise                 0.2.1                 r3.2.2_1a    r
r-mgcv                    1.8_9                  r3.2.2_0    r
r-mime                    0.4                   r3.2.2_0a    r
r-minqa                   1.2.4                 r3.2.2_1a    r
r-munsell                 0.4.2                 r3.2.2_1a    r
r-nlme                    3.1_122                r3.2.2_0    r
r-nloptr                  1.0.4                 r3.2.2_1a    r
r-nnet                    7.3_11                 r3.2.2_0    r
r-pbkrtest                0.4_2                 r3.2.2_2a    r
r-plyr                    1.8.3                 r3.2.2_0a    r
r-proto                   0.3_10                r3.2.2_1a    r
r-quantmod                0.4_5                 r3.2.2_0a    r
r-quantreg                5.19                  r3.2.2_0a    r
r-r6                      2.1.1                 r3.2.2_0a    r
r-randomforest            4.6_12                r3.2.2_0a    r
r-rbokeh                  0.2.2                 r3.2.2_0a    r
r-rcolorbrewer            1.1_2                 r3.2.2_2a    r
r-rcpp                    0.12.2                r3.2.2_0a    r
r-rcppeigen               0.3.2.5.1             r3.2.2_0a    r
r-recommended             3.2.2                  r3.2.2_0    r
r-repr                    0.3                   r3.2.2_0a    r
r-reshape2                1.4.1                 r3.2.2_1a    r
r-rjsonio                 1.3_0                 r3.2.2_1a    r
r-rmarkdown               0.8.1                 r3.2.2_0a    r
r-roxygen2                5.0.1                 r3.2.2_0a    r
r-rpart                   4.1_10                 r3.2.2_0    r
r-rstudioapi              0.3.1                 r3.2.2_0a    r
r-rversions               1.0.2                 r3.2.2_0a    r
r-rzmq                    0.7.7                 r3.2.2_3a    r
r-scales                  0.3.0                 r3.2.2_0a    r
r-shiny                   0.12.2                r3.2.2_0a    r
r-sparsem                 1.7                   r3.2.2_0a    r
r-spatial                 7.3_11                 r3.2.2_0    r
r-stringi                 1.0_1                 r3.2.2_0a    r
r-stringr                 1.0.0                 r3.2.2_0a    r
r-survival                2.38_3                 r3.2.2_0    r
r-tidyr                   0.3.1                 r3.2.2_0a    r
r-ttr                     0.23_0                r3.2.2_0a    r
r-uuid                    0.1_2                 r3.2.2_0a    r
r-whisker                 0.3_2                 r3.2.2_1a    r
r-xml2                    0.1.2                 r3.2.2_0a    r
r-xtable                  1.8_0                 r3.2.2_0a    r
r-xts                     0.9_7                 r3.2.2_0a    r
r-yaml                    2.1.13                r3.2.2_1a    r
r-zoo                     1.7_12                r3.2.2_1a    r
readline                  6.2                           2    <unknown>
redis                     2.6.9                         0    <unknown>
redis-py                  2.10.3                   py27_0    defaults
requests                  2.7.0                    py27_0    defaults
rope                      0.9.4                    py27_1    <unknown>
rpy2                      2.7.0              py27r3.2.2_0    r
runipy                    0.1.3                    py27_0    defaults
scikit-image              0.11.3               np19py27_0    defaults
scikit-learn              0.16.1               np19py27_0    defaults
scikits.bootstrap         0.3.2                np18py27_0    rgrout
scipy                     0.15.1               np19py27_0    defaults
seaborn                   0.6.0               np110py27_0    defaults
setuptools                17.1.1                   py27_0    defaults
simplegeneric             0.8.1                    py27_0    defaults
simpleitk                 0.8.0                     <pip>
singledispatch            3.4.0.3                  py27_1    r
sip                       4.16.5                   py27_0    defaults
six                       1.9.0                    py27_0    http://repo.continuum.io/pkgs/free/linux-64/six-1.9.0-py27_0.tar.bz2
skl-groups                0.1.5                np19py27_0    dougal
skl-groups-accel          0.1.5                     <pip>
snowballstemmer           1.2.0                    py27_0    defaults
sockjs-tornado            1.0.1                    py27_0    <unknown>
sphinx                    1.3.1                    py27_0    defaults
sphinx-rtd-theme          0.1.7                     <pip>
sphinx_rtd_theme          0.1.7                    py27_0    defaults
spyder                    2.3.5.2                  py27_0    defaults
spyder-app                2.3.5.2                  py27_0    defaults
sqlalchemy                1.0.5                    py27_0    defaults
sqlite                    3.8.4.1                       1    http://repo.continuum.io/pkgs/free/linux-64/sqlite-3.8.4.1-1.tar.bz2
ssl_match_hostname        3.4.0.2                  py27_0    <unknown>
statsmodels               0.6.1                np19py27_0    defaults
sympy                     0.7.6                    py27_0    defaults
system                    5.8                           2    defaults
tables                    3.2.0                     <pip>
tabulate                  0.7.2                    py27_0    https://conda.binstar.org/auto/linux-64/tabulate-0.7.2-py27_0.tar.bz2
tensorflow                0.7.1                    py27_1    jjhelmus
terminado                 0.5                      py27_0    defaults
theano                    0.7.0                np19py27_0    defaults
tk                        8.5.18                        0    http://repo.continuum.io/pkgs/free/linux-64/tk-8.5.18-0.tar.bz2
toolz                     0.7.2                    py27_0    defaults
tornado                   4.2                      py27_0    defaults
traitlets                 4.0.0                    py27_0    defaults
traits                    4.4.0                    py27_0    <unknown>
traitsui                  4.4.0                    py27_0    <unknown>
ujson                     1.33                     py27_0    <unknown>
unicodecsv                0.9.4                    py27_0    <unknown>
unixodbc                  2.3.1                         1    http://repo.continuum.io/pkgs/free/linux-64/unixodbc-2.3.1-1.tar.bz2
util-linux                2.21                          0    <unknown>
vlfeat-ctypes             0.1.4                    py27_0    http://conda.binstar.org/dougal/linux-64/vlfeat-ctypes-0.1.4-py27_0.tar.bz2
werkzeug                  0.10.4                   py27_0    defaults
wheel                     0.29.0                   py27_0    defaults
xlrd                      0.9.3                    py27_0    <unknown>
xlsxwriter                0.7.3                    py27_0    defaults
xlwt                      1.0.0                    py27_0    defaults
xz                        5.0.5                         1    defaults
yaml                      0.1.6                         0    defaults
zeromq                    4.0.5                         0    defaults
zlib                      1.2.8                         0    http://repo.continuu
@msarahan

This comment has been minimized.

Copy link
Member

commented May 26, 2016

Numpy 1.9 was not correctly pinned to libgfortran version 1.

conda install -f libgfortran==1

should make things work again.

@ilanschnell, can you alter numpy 1.9's metadata to reflect this dependency/pinning?

@kayhan-batmanghelich

This comment has been minimized.

Copy link

commented May 27, 2016

@msarahan I ended up re-installing conda, I read this message after re-installation :( Thank you for your reply.

I have to say, I did try conda update libgfortran --force but that didn't help. The command didn't have -f libgfortran==1. I don't know it makes a difference.

Thanks again,

@msarahan

This comment has been minimized.

Copy link
Member

commented May 27, 2016

The critically important part is not the --force, but the ==1 part. The latest libgfortran package is version 3, which is not compatible with numpy 1.9. Thus, you must manually tell it to install the older version.

@ketch

This comment has been minimized.

Copy link

commented Jul 12, 2016

I ran into this today too. Any idea when it will be fixed? The workaround is nice but users still get tripped up.

@olaurino

This comment has been minimized.

Copy link

commented Sep 19, 2016

I was about to release new binaries for our package (Sherpa, the modeling package of the Chandra X-Ray telescope software) when I realized the binaries I had been testing were broken by an update in libgcc at the build number level.

libgcc 4.8.5-1 contained libgfortran, while 4.8.5-2 does not. This is a big change for a build number increase, and I am not sure how to proceed. Should I pin libgcc 4.8.5 to build number 1 hoping this doesn't collide with other packages user may have? Or should I assume that libgfortran has been fixed (which doesn't seem to be the case as libgfortran hasn't been updated)?

@insertinterestingnamehere

This comment has been minimized.

Copy link

commented Sep 24, 2016

libgcc 5.2 is backwards compatible with binaries built with gcc 4.8. Using the newer version should work. That aside, pulling libgfortran out in a new build seems wrong to me. I'm not sure on what the rationale could have been for that.

@olaurino

This comment has been minimized.

Copy link

commented Sep 24, 2016

Thanks @insertinterestingnamehere.

Whatever the rationale, I was rather surprised by the fact that such a big change was introduced in a build number increase. Should I start pinning down dependencies at the build number level?

@rmathar

This comment has been minimized.

Copy link

commented Sep 6, 2017

A bug in the libgfortran package for at least a decade, see https://bugzilla.redhat.com/show_bug.cgi?id=191497 .I usually patch this by creating the symbolic link (as root)
`
cd /usr/lib64

if [ -a libgfortran.so.3 ] ; then

if [ ! -a libgfortran.so ] ; then

    ln -s libgfortran.so.3 libgfortran.so
fi

fi
`

@msarahan

This comment has been minimized.

Copy link
Member

commented Nov 15, 2017

With the Anaconda-5 series of packages, we're building with gcc 7.2, which finally bumps the gfortran version - it's .so.4 now. I think this issue is solved.

Note: the old gcc package (4.8.*) is incompatible with the new packages, and should not be mixed with them. Prefer the new compilers instead. We have docs on doing that at https://www.anaconda.com/blog/developer-blog/utilizing-the-new-compilers-in-anaconda-distribution-5/

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.