Unable to install Anaconda 2 #860

Closed
jakirkham opened this Issue Jun 28, 2016 · 19 comments

Comments

Projects
None yet
8 participants
@jakirkham

jakirkham commented Jun 28, 2016

Was trying to help a user debug an issue ( conda-forge/conda-forge.github.io#180 ) and discovered that I cannot install Anaconda. See the log below.

$ curl -L http://repo.continuum.io/archive/Anaconda2-4.1.0-MacOSX-x86_64.sh > anaconda.sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  295M  100  295M    0     0  53.2M      0  0:00:05  0:00:05 --:--:-- 59.3M
$ openssl sha1 anaconda.sh 
SHA1(anaconda.sh)= 5416062ce553f84ea10d885797e222ab0fa5bc30
$ bash anaconda.sh -b -p miniconda-test
PREFIX=/Users/kirkhamj/miniconda-test
installing: python-2.7.11-5 ...
installing: _nb_ext_conf-0.2.0-py27_0 ...
installing: alabaster-0.7.8-py27_0 ...
installing: anaconda-client-1.4.0-py27_0 ...
installing: anaconda-navigator-1.2.1-py27_0 ...
installing: appnope-0.1.0-py27_0 ...
installing: appscript-1.0.1-py27_0 ...
installing: argcomplete-1.0.0-py27_1 ...
installing: astropy-1.2.1-np111py27_0 ...
installing: babel-2.3.3-py27_0 ...
installing: backports-1.0-py27_0 ...
installing: backports_abc-0.4-py27_0 ...
installing: beautifulsoup4-4.4.1-py27_0 ...
installing: bitarray-0.8.1-py27_0 ...
installing: bokeh-0.11.1-py27_0 ...
installing: boto-2.40.0-py27_0 ...
installing: bottleneck-1.0.0-np111py27_1 ...
installing: cdecimal-2.3-py27_2 ...
installing: cffi-1.6.0-py27_0 ...
installing: chest-0.2.3-py27_0 ...
installing: click-6.6-py27_0 ...
installing: cloudpickle-0.2.1-py27_0 ...
installing: clyent-1.2.2-py27_0 ...
installing: colorama-0.3.7-py27_0 ...
installing: configobj-5.0.6-py27_0 ...
installing: configparser-3.5.0b2-py27_1 ...
installing: contextlib2-0.5.3-py27_0 ...
installing: cryptography-1.4-py27_0 ...
installing: curl-7.49.0-0 ...
installing: cycler-0.10.0-py27_0 ...
installing: cython-0.24-py27_0 ...
installing: cytoolz-0.8.0-py27_0 ...
installing: dask-0.10.0-py27_0 ...
installing: datashape-0.5.2-py27_0 ...
installing: decorator-4.0.10-py27_0 ...
installing: dill-0.2.5-py27_0 ...
installing: docutils-0.12-py27_2 ...
installing: dynd-python-0.7.2-py27_0 ...
installing: entrypoints-0.2.2-py27_0 ...
installing: enum34-1.1.6-py27_0 ...
installing: et_xmlfile-1.0.1-py27_0 ...
installing: fastcache-1.0.2-py27_1 ...
installing: flask-0.11.1-py27_0 ...
installing: flask-cors-2.1.2-py27_0 ...
installing: freetype-2.5.5-1 ...
installing: funcsigs-1.0.2-py27_0 ...
installing: functools32-3.2.3.2-py27_0 ...
installing: futures-3.0.5-py27_0 ...
installing: get_terminal_size-1.0.0-py27_0 ...
installing: gevent-1.1.1-py27_0 ...
installing: greenlet-0.4.10-py27_0 ...
installing: grin-1.2.1-py27_3 ...
installing: h5py-2.6.0-np111py27_1 ...
installing: hdf5-1.8.16-0 ...
installing: heapdict-1.0.0-py27_1 ...
installing: idna-2.1-py27_0 ...
installing: imagesize-0.7.1-py27_0 ...
installing: ipaddress-1.0.16-py27_0 ...
installing: ipykernel-4.3.1-py27_0 ...
installing: ipython-4.2.0-py27_1 ...
installing: ipython_genutils-0.1.0-py27_0 ...
installing: ipywidgets-4.1.1-py27_0 ...
installing: itsdangerous-0.24-py27_0 ...
installing: jbig-2.1-0 ...
installing: jdcal-1.2-py27_1 ...
installing: jedi-0.9.0-py27_1 ...
installing: jinja2-2.8-py27_1 ...
installing: jpeg-8d-1 ...
installing: jsonschema-2.5.1-py27_0 ...
installing: jupyter-1.0.0-py27_3 ...
installing: jupyter_client-4.3.0-py27_0 ...
installing: jupyter_console-4.1.1-py27_0 ...
installing: jupyter_core-4.1.0-py27_0 ...
installing: libdynd-0.7.2-0 ...
installing: libpng-1.6.22-0 ...
installing: libtiff-4.0.6-2 ...
installing: libxml2-2.9.2-0 ...
installing: libxslt-1.1.28-2 ...
installing: llvmlite-0.11.0-py27_0 ...
installing: locket-0.2.0-py27_1 ...
installing: lxml-3.6.0-py27_0 ...
installing: markupsafe-0.23-py27_2 ...
installing: matplotlib-1.5.1-np111py27_0 ...
installing: mistune-0.7.2-py27_1 ...
installing: mkl-11.3.3-0 ...
installing: mkl-service-1.1.2-py27_2 ...
installing: mpmath-0.19-py27_1 ...
installing: multipledispatch-0.4.8-py27_0 ...
installing: nb_anacondacloud-1.1.0-py27_0 ...
installing: nb_conda-1.1.0-py27_0 ...
installing: nb_conda_kernels-1.0.3-py27_0 ...
installing: nbconvert-4.2.0-py27_0 ...
installing: nbformat-4.0.1-py27_0 ...
installing: nbpresent-3.0.2-py27_0 ...
installing: networkx-1.11-py27_0 ...
installing: nltk-3.2.1-py27_0 ...
installing: nose-1.3.7-py27_1 ...
installing: notebook-4.2.1-py27_0 ...
installing: numba-0.26.0-np111py27_0 ...
installing: numexpr-2.6.0-np111py27_0 ...
installing: numpy-1.11.0-py27_2 ...
installing: odo-0.5.0-py27_0 ...
installing: openpyxl-2.3.2-py27_0 ...
installing: openssl-1.0.2h-1 ...
installing: pandas-0.18.1-np111py27_0 ...
installing: partd-0.3.4-py27_0 ...
installing: path.py-8.2.1-py27_0 ...
installing: pathlib2-2.1.0-py27_0 ...
installing: patsy-0.4.1-py27_0 ...
installing: pep8-1.7.0-py27_0 ...
installing: pexpect-4.0.1-py27_0 ...
installing: pickleshare-0.7.2-py27_0 ...
installing: pillow-3.2.0-py27_1 ...
installing: pip-8.1.2-py27_0 ...
installing: ply-3.8-py27_0 ...
installing: psutil-4.3.0-py27_0 ...
installing: ptyprocess-0.5.1-py27_0 ...
installing: py-1.4.31-py27_0 ...
installing: pyasn1-0.1.9-py27_0 ...
installing: pyaudio-0.2.7-py27_0 ...
installing: pycosat-0.6.1-py27_1 ...
installing: pycparser-2.14-py27_1 ...
installing: pycrypto-2.6.1-py27_4 ...
installing: pycurl-7.43.0-py27_0 ...
installing: pyflakes-1.2.3-py27_0 ...
installing: pygments-2.1.3-py27_0 ...
installing: pyopenssl-0.16.0-py27_0 ...
installing: pyparsing-2.1.4-py27_0 ...
installing: pyqt-4.11.4-py27_3 ...
installing: pytables-3.2.2-np111py27_4 ...
installing: pytest-2.9.2-py27_0 ...
installing: python-dateutil-2.5.3-py27_0 ...
installing: python.app-1.2-py27_4 ...
installing: pytz-2016.4-py27_0 ...
installing: pyyaml-3.11-py27_4 ...
installing: pyzmq-15.2.0-py27_1 ...
installing: qt-4.8.7-3 ...
installing: qtconsole-4.2.1-py27_0 ...
installing: qtpy-1.0.2-py27_0 ...
installing: readline-6.2-2 ...
installing: redis-3.2.0-0 ...
installing: redis-py-2.10.5-py27_0 ...
installing: requests-2.10.0-py27_0 ...
installing: rope-0.9.4-py27_1 ...
installing: ruamel_yaml-0.11.7-py27_0 ...
installing: scikit-image-0.12.3-np111py27_1 ...
installing: scikit-learn-0.17.1-np111py27_2 ...
installing: scipy-0.17.1-np111py27_1 ...
installing: setuptools-23.0.0-py27_0 ...
installing: simplegeneric-0.8.1-py27_1 ...
installing: singledispatch-3.4.0.3-py27_0 ...
installing: sip-4.16.9-py27_0 ...
installing: six-1.10.0-py27_0 ...
installing: snowballstemmer-1.2.1-py27_0 ...
installing: sockjs-tornado-1.0.3-py27_0 ...
installing: sphinx-1.4.1-py27_0 ...
installing: sphinx_rtd_theme-0.1.9-py27_0 ...
installing: spyder-2.3.9-py27_0 ...
installing: sqlalchemy-1.0.13-py27_0 ...
installing: sqlite-3.13.0-0 ...
installing: ssl_match_hostname-3.4.0.2-py27_1 ...
installing: statsmodels-0.6.1-np111py27_1 ...
installing: sympy-1.0-py27_0 ...
installing: terminado-0.6-py27_0 ...
installing: tk-8.5.18-0 ...
installing: toolz-0.8.0-py27_0 ...
installing: tornado-4.3-py27_1 ...
installing: traitlets-4.2.1-py27_0 ...
installing: unicodecsv-0.14.1-py27_0 ...
installing: werkzeug-0.11.10-py27_0 ...
installing: wheel-0.29.0-py27_0 ...
installing: xlrd-1.0.0-py27_0 ...
installing: xlsxwriter-0.9.2-py27_0 ...
installing: xlwings-0.7.2-py27_0 ...
installing: xlwt-1.1.2-py27_0 ...
installing: xz-5.2.2-0 ...
installing: yaml-0.1.6-0 ...
installing: zlib-1.2.8-3 ...
installing: anaconda-4.1.0-np111py27_0 ...
installing: conda-4.1.4-py27_0 ...
installing: conda-build-1.21.2-py27_0 ...
installing: conda-env-2.5.1-py27_0 ...
Python 2.7.11 :: Continuum Analytics, Inc.
creating default environment...
ERROR:root:code for hash md5 was not found.
Traceback (most recent call last):
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type md5
ERROR:root:code for hash sha1 was not found.
Traceback (most recent call last):
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha1
ERROR:root:code for hash sha224 was not found.
Traceback (most recent call last):
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha224
ERROR:root:code for hash sha256 was not found.
Traceback (most recent call last):
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha256
ERROR:root:code for hash sha384 was not found.
Traceback (most recent call last):
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha384
ERROR:root:code for hash sha512 was not found.
Traceback (most recent call last):
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 147, in <module>
    globals()[__func_name] = __get_hash(__func_name)
  File "/Users/kirkhamj/miniconda-test/pkgs/python-2.7.11-5/lib/python2.7/hashlib.py", line 97, in __get_builtin_constructor
    raise ValueError('unsupported hash type ' + name)
ValueError: unsupported hash type sha512
installation finished.

@jakirkham jakirkham referenced this issue in conda-forge/conda-forge.github.io Jun 28, 2016

Closed

`conda` executable deleted by `conda update --all` #180

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jun 29, 2016

Member

Which version of Mac OS X are you using? What are your environment variables set to? Can you provide the output from:

$ env | sort

Thanks

Member

ilanschnell commented Jun 29, 2016

Which version of Mac OS X are you using? What are your environment variables set to? Can you provide the output from:

$ env | sort

Thanks

@slonik-az

This comment has been minimized.

Show comment
Hide comment
@slonik-az

slonik-az Jun 29, 2016

I have the same problem installing anaconda2-4.1.0 on MacOSX-10.11.5 El Capitan with very similar back-trace. I used Anaconda2-4.1.0-MacOSX-x86_64.sh installer.
BTW, anaconda2-4.0.0 installed without any problems on the same machine in the same environment.
It seems to be anaconda-4.1.0 specific issue.
--Leo

I have the same problem installing anaconda2-4.1.0 on MacOSX-10.11.5 El Capitan with very similar back-trace. I used Anaconda2-4.1.0-MacOSX-x86_64.sh installer.
BTW, anaconda2-4.0.0 installed without any problems on the same machine in the same environment.
It seems to be anaconda-4.1.0 specific issue.
--Leo

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jun 29, 2016

Member

Hmm, it probably has to do with changes in conda.install.

Member

ilanschnell commented Jun 29, 2016

Hmm, it probably has to do with changes in conda.install.

@jehturner

This comment has been minimized.

Show comment
Hide comment
@jehturner

jehturner Jun 30, 2016

Hi Ilan,

I also see the same traceback when installing 4.1.0 (x86_64, Python 2) on CentOS 5.10. Yes -- an old OS but still supported until next year (I'm having trouble spotting any system requirements on your Web page to confirm whether you actually intend it to work). Could this be something like the installer using hashlib before the RPATH / DT_RUNPATH of its binary module gets updated? My OS versions of libssl & libcrypto are older than Anaconda's both on this machine and (like the other posters) on the latest MacOS 10.11.

Anaconda does appear to complete its installation though (whether or not it is fully working), so "unable to install" would be an exaggeration in my case.

BTW, this is James, who discussed our astronomical Python distribution with you at a couple of SciPy meetings (before missing the last few). We are now re-basing/writing our distribution on Anaconda, which meets our needs better than EPD did at the time, and STScI has already released some initial conda packages. It's too bad Travis didn't mention that you were writing Anaconda when we were originally developing Ureka in parallel and discussing our progress, but anyway, things are looking pretty good so far. Thanks!

James.

Hi Ilan,

I also see the same traceback when installing 4.1.0 (x86_64, Python 2) on CentOS 5.10. Yes -- an old OS but still supported until next year (I'm having trouble spotting any system requirements on your Web page to confirm whether you actually intend it to work). Could this be something like the installer using hashlib before the RPATH / DT_RUNPATH of its binary module gets updated? My OS versions of libssl & libcrypto are older than Anaconda's both on this machine and (like the other posters) on the latest MacOS 10.11.

Anaconda does appear to complete its installation though (whether or not it is fully working), so "unable to install" would be an exaggeration in my case.

BTW, this is James, who discussed our astronomical Python distribution with you at a couple of SciPy meetings (before missing the last few). We are now re-basing/writing our distribution on Anaconda, which meets our needs better than EPD did at the time, and STScI has already released some initial conda packages. It's too bad Travis didn't mention that you were writing Anaconda when we were originally developing Ureka in parallel and discussing our progress, but anyway, things are looking pretty good so far. Thanks!

James.

@slonik-az

This comment has been minimized.

Show comment
Hide comment
@slonik-az

slonik-az Jun 30, 2016

I would argue that with errors like these coming from the installer I would not trust the integrity of the resulting installation. I deleted anaconda2-4.1.0 and replaced it with anaconda2-4.0.0. And installation was a breeze (mac os x 10.11.5 El Capitan) with no issues whatsoever.
--Leo

I would argue that with errors like these coming from the installer I would not trust the integrity of the resulting installation. I deleted anaconda2-4.1.0 and replaced it with anaconda2-4.0.0. And installation was a breeze (mac os x 10.11.5 El Capitan) with no issues whatsoever.
--Leo

@jakirkham

This comment has been minimized.

Show comment
Hide comment
@jakirkham

jakirkham Jun 30, 2016

Sorry for the long turnaround, @ilanschnell, responses below.

Which version of Mac OS X are you using?

10.9

What are your environment variables set to? Can you provide the output from:

This is somewhat scrubbed.

$ env
TERM_PROGRAM=Apple_Terminal
TERM=xterm-256color
SHELL=/bin/bash
CLICOLOR=1
TMPDIR=/var/folders/jj/pp1xwt1n4zdgy9zxbxc22t8w66tr7q/T/
Apple_PubSub_Socket_Render=/tmp/launch-IbGiHb/Render
TERM_PROGRAM_VERSION=326
TERM_SESSION_ID=81D34B80-7E77-44B3-9F53-402781451DEB
USER=kirkhamj
LSCOLORS=ExFxBxDxCxegedabagacad
__CHECKFIX1436934=1
PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/local/git/bin:/usr/local/MacGPG2/bin:/Library/TeX/texbin
PWD=/Users/kirkhamj
LANG=en_US.UTF-8
HOME=/Users/kirkhamj
SHLVL=1
LOGNAME=kirkhamj
DISPLAY=/tmp/launch-El9IAA/org.macosforge.xquartz:0
_=/usr/bin/env

Sorry for the long turnaround, @ilanschnell, responses below.

Which version of Mac OS X are you using?

10.9

What are your environment variables set to? Can you provide the output from:

This is somewhat scrubbed.

$ env
TERM_PROGRAM=Apple_Terminal
TERM=xterm-256color
SHELL=/bin/bash
CLICOLOR=1
TMPDIR=/var/folders/jj/pp1xwt1n4zdgy9zxbxc22t8w66tr7q/T/
Apple_PubSub_Socket_Render=/tmp/launch-IbGiHb/Render
TERM_PROGRAM_VERSION=326
TERM_SESSION_ID=81D34B80-7E77-44B3-9F53-402781451DEB
USER=kirkhamj
LSCOLORS=ExFxBxDxCxegedabagacad
__CHECKFIX1436934=1
PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/local/git/bin:/usr/local/MacGPG2/bin:/Library/TeX/texbin
PWD=/Users/kirkhamj
LANG=en_US.UTF-8
HOME=/Users/kirkhamj
SHLVL=1
LOGNAME=kirkhamj
DISPLAY=/tmp/launch-El9IAA/org.macosforge.xquartz:0
_=/usr/bin/env
@jakirkham

This comment has been minimized.

Show comment
Hide comment
@jakirkham

jakirkham Jun 30, 2016

This is likely a Python 2 vs Python 3 issue (as @jjhelmus may have suspected). Everything works with Python 3. Was there a change to constructor that causes this problem. It looks like an issue with checksums.

$ curl -L http://repo.continuum.io/archive/Anaconda3-4.1.0-MacOSX-x86_64.sh > anaconda.sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  297M  100  297M    0     0  17.4M      0  0:00:17  0:00:17 --:--:-- 23.3M
$ openssl sha1 anaconda.sh
SHA1(anaconda.sh)= 4fc5ab549903790672843d0176ed4399b4d2a2d0
$ bash anaconda.sh -b -p miniconda-test
PREFIX=/Users/kirkhamj/miniconda-test
installing: python-3.5.1-5 ...
installing: _nb_ext_conf-0.2.0-py35_0 ...
installing: alabaster-0.7.8-py35_0 ...
installing: anaconda-client-1.4.0-py35_0 ...
installing: anaconda-navigator-1.2.1-py35_0 ...
installing: appnope-0.1.0-py35_0 ...
installing: appscript-1.0.1-py35_0 ...
installing: argcomplete-1.0.0-py35_1 ...
installing: astropy-1.2.1-np111py35_0 ...
installing: babel-2.3.3-py35_0 ...
installing: backports-1.0-py35_0 ...
installing: beautifulsoup4-4.4.1-py35_0 ...
installing: bitarray-0.8.1-py35_0 ...
installing: bokeh-0.11.1-py35_0 ...
installing: boto-2.40.0-py35_0 ...
installing: bottleneck-1.0.0-np111py35_1 ...
installing: cffi-1.6.0-py35_0 ...
installing: chest-0.2.3-py35_0 ...
installing: click-6.6-py35_0 ...
installing: cloudpickle-0.2.1-py35_0 ...
installing: clyent-1.2.2-py35_0 ...
installing: colorama-0.3.7-py35_0 ...
installing: configobj-5.0.6-py35_0 ...
installing: contextlib2-0.5.3-py35_0 ...
installing: cryptography-1.4-py35_0 ...
installing: curl-7.49.0-0 ...
installing: cycler-0.10.0-py35_0 ...
installing: cython-0.24-py35_0 ...
installing: cytoolz-0.8.0-py35_0 ...
installing: dask-0.10.0-py35_0 ...
installing: datashape-0.5.2-py35_0 ...
installing: decorator-4.0.10-py35_0 ...
installing: dill-0.2.5-py35_0 ...
installing: docutils-0.12-py35_2 ...
installing: dynd-python-0.7.2-py35_0 ...
installing: entrypoints-0.2.2-py35_0 ...
installing: et_xmlfile-1.0.1-py35_0 ...
installing: fastcache-1.0.2-py35_1 ...
installing: flask-0.11.1-py35_0 ...
installing: flask-cors-2.1.2-py35_0 ...
installing: freetype-2.5.5-1 ...
installing: get_terminal_size-1.0.0-py35_0 ...
installing: gevent-1.1.1-py35_0 ...
installing: greenlet-0.4.10-py35_0 ...
installing: h5py-2.6.0-np111py35_1 ...
installing: hdf5-1.8.16-0 ...
installing: heapdict-1.0.0-py35_1 ...
installing: idna-2.1-py35_0 ...
installing: imagesize-0.7.1-py35_0 ...
installing: ipykernel-4.3.1-py35_0 ...
installing: ipython-4.2.0-py35_1 ...
installing: ipython_genutils-0.1.0-py35_0 ...
installing: ipywidgets-4.1.1-py35_0 ...
installing: itsdangerous-0.24-py35_0 ...
installing: jbig-2.1-0 ...
installing: jdcal-1.2-py35_1 ...
installing: jedi-0.9.0-py35_1 ...
installing: jinja2-2.8-py35_1 ...
installing: jpeg-8d-1 ...
installing: jsonschema-2.5.1-py35_0 ...
installing: jupyter-1.0.0-py35_3 ...
installing: jupyter_client-4.3.0-py35_0 ...
installing: jupyter_console-4.1.1-py35_0 ...
installing: jupyter_core-4.1.0-py35_0 ...
installing: libdynd-0.7.2-0 ...
installing: libpng-1.6.22-0 ...
installing: libtiff-4.0.6-2 ...
installing: libxml2-2.9.2-0 ...
installing: libxslt-1.1.28-2 ...
installing: llvmlite-0.11.0-py35_0 ...
installing: locket-0.2.0-py35_1 ...
installing: lxml-3.6.0-py35_0 ...
installing: markupsafe-0.23-py35_2 ...
installing: matplotlib-1.5.1-np111py35_0 ...
installing: mistune-0.7.2-py35_1 ...
installing: mkl-11.3.3-0 ...
installing: mkl-service-1.1.2-py35_2 ...
installing: mpmath-0.19-py35_1 ...
installing: multipledispatch-0.4.8-py35_0 ...
installing: nb_anacondacloud-1.1.0-py35_0 ...
installing: nb_conda-1.1.0-py35_0 ...
installing: nb_conda_kernels-1.0.3-py35_0 ...
installing: nbconvert-4.2.0-py35_0 ...
installing: nbformat-4.0.1-py35_0 ...
installing: nbpresent-3.0.2-py35_0 ...
installing: networkx-1.11-py35_0 ...
installing: nltk-3.2.1-py35_0 ...
installing: nose-1.3.7-py35_1 ...
installing: notebook-4.2.1-py35_0 ...
installing: numba-0.26.0-np111py35_0 ...
installing: numexpr-2.6.0-np111py35_0 ...
installing: numpy-1.11.0-py35_2 ...
installing: odo-0.5.0-py35_0 ...
installing: openpyxl-2.3.2-py35_0 ...
installing: openssl-1.0.2h-1 ...
installing: pandas-0.18.1-np111py35_0 ...
installing: partd-0.3.4-py35_0 ...
installing: path.py-8.2.1-py35_0 ...
installing: pathlib2-2.1.0-py35_0 ...
installing: patsy-0.4.1-py35_0 ...
installing: pep8-1.7.0-py35_0 ...
installing: pexpect-4.0.1-py35_0 ...
installing: pickleshare-0.7.2-py35_0 ...
installing: pillow-3.2.0-py35_1 ...
installing: pip-8.1.2-py35_0 ...
installing: ply-3.8-py35_0 ...
installing: psutil-4.3.0-py35_0 ...
installing: ptyprocess-0.5.1-py35_0 ...
installing: py-1.4.31-py35_0 ...
installing: pyasn1-0.1.9-py35_0 ...
installing: pycosat-0.6.1-py35_1 ...
installing: pycparser-2.14-py35_1 ...
installing: pycrypto-2.6.1-py35_4 ...
installing: pycurl-7.43.0-py35_0 ...
installing: pyflakes-1.2.3-py35_0 ...
installing: pygments-2.1.3-py35_0 ...
installing: pyopenssl-0.16.0-py35_0 ...
installing: pyparsing-2.1.4-py35_0 ...
installing: pyqt-4.11.4-py35_3 ...
installing: pytables-3.2.2-np111py35_4 ...
installing: pytest-2.9.2-py35_0 ...
installing: python-dateutil-2.5.3-py35_0 ...
installing: python.app-1.2-py35_4 ...
installing: pytz-2016.4-py35_0 ...
installing: pyyaml-3.11-py35_4 ...
installing: pyzmq-15.2.0-py35_1 ...
installing: qt-4.8.7-3 ...
installing: qtconsole-4.2.1-py35_0 ...
installing: qtpy-1.0.2-py35_0 ...
installing: readline-6.2-2 ...
installing: redis-3.2.0-0 ...
installing: redis-py-2.10.5-py35_0 ...
installing: requests-2.10.0-py35_0 ...
installing: rope-0.9.4-py35_1 ...
installing: ruamel_yaml-0.11.7-py35_0 ...
installing: scikit-image-0.12.3-np111py35_1 ...
installing: scikit-learn-0.17.1-np111py35_2 ...
installing: scipy-0.17.1-np111py35_1 ...
installing: setuptools-23.0.0-py35_0 ...
installing: simplegeneric-0.8.1-py35_1 ...
installing: singledispatch-3.4.0.3-py35_0 ...
installing: sip-4.16.9-py35_0 ...
installing: six-1.10.0-py35_0 ...
installing: snowballstemmer-1.2.1-py35_0 ...
installing: sockjs-tornado-1.0.3-py35_0 ...
installing: sphinx-1.4.1-py35_0 ...
installing: sphinx_rtd_theme-0.1.9-py35_0 ...
installing: spyder-2.3.9-py35_0 ...
installing: sqlalchemy-1.0.13-py35_0 ...
installing: sqlite-3.13.0-0 ...
installing: statsmodels-0.6.1-np111py35_1 ...
installing: sympy-1.0-py35_0 ...
installing: terminado-0.6-py35_0 ...
installing: tk-8.5.18-0 ...
installing: toolz-0.8.0-py35_0 ...
installing: tornado-4.3-py35_1 ...
installing: traitlets-4.2.1-py35_0 ...
installing: unicodecsv-0.14.1-py35_0 ...
installing: werkzeug-0.11.10-py35_0 ...
installing: wheel-0.29.0-py35_0 ...
installing: xlrd-1.0.0-py35_0 ...
installing: xlsxwriter-0.9.2-py35_0 ...
installing: xlwings-0.7.2-py35_0 ...
installing: xlwt-1.1.2-py35_0 ...
installing: xz-5.2.2-0 ...
installing: yaml-0.1.6-0 ...
installing: zlib-1.2.8-3 ...
installing: anaconda-4.1.0-np111py35_0 ...
installing: conda-4.1.4-py35_0 ...
installing: conda-build-1.21.2-py35_0 ...
installing: conda-env-2.5.1-py35_0 ...
Python 3.5.1 :: Continuum Analytics, Inc.
creating default environment...
installation finished.

This is likely a Python 2 vs Python 3 issue (as @jjhelmus may have suspected). Everything works with Python 3. Was there a change to constructor that causes this problem. It looks like an issue with checksums.

$ curl -L http://repo.continuum.io/archive/Anaconda3-4.1.0-MacOSX-x86_64.sh > anaconda.sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  297M  100  297M    0     0  17.4M      0  0:00:17  0:00:17 --:--:-- 23.3M
$ openssl sha1 anaconda.sh
SHA1(anaconda.sh)= 4fc5ab549903790672843d0176ed4399b4d2a2d0
$ bash anaconda.sh -b -p miniconda-test
PREFIX=/Users/kirkhamj/miniconda-test
installing: python-3.5.1-5 ...
installing: _nb_ext_conf-0.2.0-py35_0 ...
installing: alabaster-0.7.8-py35_0 ...
installing: anaconda-client-1.4.0-py35_0 ...
installing: anaconda-navigator-1.2.1-py35_0 ...
installing: appnope-0.1.0-py35_0 ...
installing: appscript-1.0.1-py35_0 ...
installing: argcomplete-1.0.0-py35_1 ...
installing: astropy-1.2.1-np111py35_0 ...
installing: babel-2.3.3-py35_0 ...
installing: backports-1.0-py35_0 ...
installing: beautifulsoup4-4.4.1-py35_0 ...
installing: bitarray-0.8.1-py35_0 ...
installing: bokeh-0.11.1-py35_0 ...
installing: boto-2.40.0-py35_0 ...
installing: bottleneck-1.0.0-np111py35_1 ...
installing: cffi-1.6.0-py35_0 ...
installing: chest-0.2.3-py35_0 ...
installing: click-6.6-py35_0 ...
installing: cloudpickle-0.2.1-py35_0 ...
installing: clyent-1.2.2-py35_0 ...
installing: colorama-0.3.7-py35_0 ...
installing: configobj-5.0.6-py35_0 ...
installing: contextlib2-0.5.3-py35_0 ...
installing: cryptography-1.4-py35_0 ...
installing: curl-7.49.0-0 ...
installing: cycler-0.10.0-py35_0 ...
installing: cython-0.24-py35_0 ...
installing: cytoolz-0.8.0-py35_0 ...
installing: dask-0.10.0-py35_0 ...
installing: datashape-0.5.2-py35_0 ...
installing: decorator-4.0.10-py35_0 ...
installing: dill-0.2.5-py35_0 ...
installing: docutils-0.12-py35_2 ...
installing: dynd-python-0.7.2-py35_0 ...
installing: entrypoints-0.2.2-py35_0 ...
installing: et_xmlfile-1.0.1-py35_0 ...
installing: fastcache-1.0.2-py35_1 ...
installing: flask-0.11.1-py35_0 ...
installing: flask-cors-2.1.2-py35_0 ...
installing: freetype-2.5.5-1 ...
installing: get_terminal_size-1.0.0-py35_0 ...
installing: gevent-1.1.1-py35_0 ...
installing: greenlet-0.4.10-py35_0 ...
installing: h5py-2.6.0-np111py35_1 ...
installing: hdf5-1.8.16-0 ...
installing: heapdict-1.0.0-py35_1 ...
installing: idna-2.1-py35_0 ...
installing: imagesize-0.7.1-py35_0 ...
installing: ipykernel-4.3.1-py35_0 ...
installing: ipython-4.2.0-py35_1 ...
installing: ipython_genutils-0.1.0-py35_0 ...
installing: ipywidgets-4.1.1-py35_0 ...
installing: itsdangerous-0.24-py35_0 ...
installing: jbig-2.1-0 ...
installing: jdcal-1.2-py35_1 ...
installing: jedi-0.9.0-py35_1 ...
installing: jinja2-2.8-py35_1 ...
installing: jpeg-8d-1 ...
installing: jsonschema-2.5.1-py35_0 ...
installing: jupyter-1.0.0-py35_3 ...
installing: jupyter_client-4.3.0-py35_0 ...
installing: jupyter_console-4.1.1-py35_0 ...
installing: jupyter_core-4.1.0-py35_0 ...
installing: libdynd-0.7.2-0 ...
installing: libpng-1.6.22-0 ...
installing: libtiff-4.0.6-2 ...
installing: libxml2-2.9.2-0 ...
installing: libxslt-1.1.28-2 ...
installing: llvmlite-0.11.0-py35_0 ...
installing: locket-0.2.0-py35_1 ...
installing: lxml-3.6.0-py35_0 ...
installing: markupsafe-0.23-py35_2 ...
installing: matplotlib-1.5.1-np111py35_0 ...
installing: mistune-0.7.2-py35_1 ...
installing: mkl-11.3.3-0 ...
installing: mkl-service-1.1.2-py35_2 ...
installing: mpmath-0.19-py35_1 ...
installing: multipledispatch-0.4.8-py35_0 ...
installing: nb_anacondacloud-1.1.0-py35_0 ...
installing: nb_conda-1.1.0-py35_0 ...
installing: nb_conda_kernels-1.0.3-py35_0 ...
installing: nbconvert-4.2.0-py35_0 ...
installing: nbformat-4.0.1-py35_0 ...
installing: nbpresent-3.0.2-py35_0 ...
installing: networkx-1.11-py35_0 ...
installing: nltk-3.2.1-py35_0 ...
installing: nose-1.3.7-py35_1 ...
installing: notebook-4.2.1-py35_0 ...
installing: numba-0.26.0-np111py35_0 ...
installing: numexpr-2.6.0-np111py35_0 ...
installing: numpy-1.11.0-py35_2 ...
installing: odo-0.5.0-py35_0 ...
installing: openpyxl-2.3.2-py35_0 ...
installing: openssl-1.0.2h-1 ...
installing: pandas-0.18.1-np111py35_0 ...
installing: partd-0.3.4-py35_0 ...
installing: path.py-8.2.1-py35_0 ...
installing: pathlib2-2.1.0-py35_0 ...
installing: patsy-0.4.1-py35_0 ...
installing: pep8-1.7.0-py35_0 ...
installing: pexpect-4.0.1-py35_0 ...
installing: pickleshare-0.7.2-py35_0 ...
installing: pillow-3.2.0-py35_1 ...
installing: pip-8.1.2-py35_0 ...
installing: ply-3.8-py35_0 ...
installing: psutil-4.3.0-py35_0 ...
installing: ptyprocess-0.5.1-py35_0 ...
installing: py-1.4.31-py35_0 ...
installing: pyasn1-0.1.9-py35_0 ...
installing: pycosat-0.6.1-py35_1 ...
installing: pycparser-2.14-py35_1 ...
installing: pycrypto-2.6.1-py35_4 ...
installing: pycurl-7.43.0-py35_0 ...
installing: pyflakes-1.2.3-py35_0 ...
installing: pygments-2.1.3-py35_0 ...
installing: pyopenssl-0.16.0-py35_0 ...
installing: pyparsing-2.1.4-py35_0 ...
installing: pyqt-4.11.4-py35_3 ...
installing: pytables-3.2.2-np111py35_4 ...
installing: pytest-2.9.2-py35_0 ...
installing: python-dateutil-2.5.3-py35_0 ...
installing: python.app-1.2-py35_4 ...
installing: pytz-2016.4-py35_0 ...
installing: pyyaml-3.11-py35_4 ...
installing: pyzmq-15.2.0-py35_1 ...
installing: qt-4.8.7-3 ...
installing: qtconsole-4.2.1-py35_0 ...
installing: qtpy-1.0.2-py35_0 ...
installing: readline-6.2-2 ...
installing: redis-3.2.0-0 ...
installing: redis-py-2.10.5-py35_0 ...
installing: requests-2.10.0-py35_0 ...
installing: rope-0.9.4-py35_1 ...
installing: ruamel_yaml-0.11.7-py35_0 ...
installing: scikit-image-0.12.3-np111py35_1 ...
installing: scikit-learn-0.17.1-np111py35_2 ...
installing: scipy-0.17.1-np111py35_1 ...
installing: setuptools-23.0.0-py35_0 ...
installing: simplegeneric-0.8.1-py35_1 ...
installing: singledispatch-3.4.0.3-py35_0 ...
installing: sip-4.16.9-py35_0 ...
installing: six-1.10.0-py35_0 ...
installing: snowballstemmer-1.2.1-py35_0 ...
installing: sockjs-tornado-1.0.3-py35_0 ...
installing: sphinx-1.4.1-py35_0 ...
installing: sphinx_rtd_theme-0.1.9-py35_0 ...
installing: spyder-2.3.9-py35_0 ...
installing: sqlalchemy-1.0.13-py35_0 ...
installing: sqlite-3.13.0-0 ...
installing: statsmodels-0.6.1-np111py35_1 ...
installing: sympy-1.0-py35_0 ...
installing: terminado-0.6-py35_0 ...
installing: tk-8.5.18-0 ...
installing: toolz-0.8.0-py35_0 ...
installing: tornado-4.3-py35_1 ...
installing: traitlets-4.2.1-py35_0 ...
installing: unicodecsv-0.14.1-py35_0 ...
installing: werkzeug-0.11.10-py35_0 ...
installing: wheel-0.29.0-py35_0 ...
installing: xlrd-1.0.0-py35_0 ...
installing: xlsxwriter-0.9.2-py35_0 ...
installing: xlwings-0.7.2-py35_0 ...
installing: xlwt-1.1.2-py35_0 ...
installing: xz-5.2.2-0 ...
installing: yaml-0.1.6-0 ...
installing: zlib-1.2.8-3 ...
installing: anaconda-4.1.0-np111py35_0 ...
installing: conda-4.1.4-py35_0 ...
installing: conda-build-1.21.2-py35_0 ...
installing: conda-env-2.5.1-py35_0 ...
Python 3.5.1 :: Continuum Analytics, Inc.
creating default environment...
installation finished.

@jakirkham jakirkham changed the title from Unable to install Anaconda to Unable to install Anaconda 2 Jun 30, 2016

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jul 1, 2016

Member

@jakirkham Thanks your your feedback. The checksum that you posted is correct:

$ sha1sum Anaconda3-4.1.0-MacOSX-x86_64.sh 
4fc5ab549903790672843d0176ed4399b4d2a2d0  Anaconda3-4.1.0-MacOSX-x86_64.sh

The Anaconda installers (as well as Miniconda) are not created using constructor.
I'm looking into the cause for this problem. However, then the installer at the end prints

installation finished.

this means just that, and the install should be fine. Although I agree that the long traceback is quite disturbing.

Member

ilanschnell commented Jul 1, 2016

@jakirkham Thanks your your feedback. The checksum that you posted is correct:

$ sha1sum Anaconda3-4.1.0-MacOSX-x86_64.sh 
4fc5ab549903790672843d0176ed4399b4d2a2d0  Anaconda3-4.1.0-MacOSX-x86_64.sh

The Anaconda installers (as well as Miniconda) are not created using constructor.
I'm looking into the cause for this problem. However, then the installer at the end prints

installation finished.

this means just that, and the install should be fine. Although I agree that the long traceback is quite disturbing.

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jul 1, 2016

Member

Here are my findings so far:

  1. The issue is reproducible (on Mac OS X 10.7, and CentOS 5). I guess the test team doesn't use these older OSes. I don't know to what extend OS X 10.8 or other versions are affected. The good news is that the graphical installer (even on OS X 10.7) is unaffected!
  2. The issue was caused by changes in conda, but the problem only shows up when building and testing installer.
  3. My fix (for which I have a working prototype by now), is to use conda independent code during the install process.
  4. As far as I can tell, the Tracebacks during the install process are harmless, i.e. the install process actually finishes (and the installed Anaconda is OK). However, having these long tracebacks during the install process is very disturbing.

We are going to release Anaconda 4.1.1 which will address this, and possibly other issues.

Member

ilanschnell commented Jul 1, 2016

Here are my findings so far:

  1. The issue is reproducible (on Mac OS X 10.7, and CentOS 5). I guess the test team doesn't use these older OSes. I don't know to what extend OS X 10.8 or other versions are affected. The good news is that the graphical installer (even on OS X 10.7) is unaffected!
  2. The issue was caused by changes in conda, but the problem only shows up when building and testing installer.
  3. My fix (for which I have a working prototype by now), is to use conda independent code during the install process.
  4. As far as I can tell, the Tracebacks during the install process are harmless, i.e. the install process actually finishes (and the installed Anaconda is OK). However, having these long tracebacks during the install process is very disturbing.

We are going to release Anaconda 4.1.1 which will address this, and possibly other issues.

@slonik-az

This comment has been minimized.

Show comment
Hide comment
@slonik-az

slonik-az Jul 1, 2016

@ilanschnell : I can reproduce the problem on the latest MacOSX 10.11.5 (El Capitan) trying to install anaconda2-4.1.0. The same error backtrace. Anaconda2-4.0.0 installs fine.
--Leo

@ilanschnell : I can reproduce the problem on the latest MacOSX 10.11.5 (El Capitan) trying to install anaconda2-4.1.0. The same error backtrace. Anaconda2-4.0.0 installs fine.
--Leo

@michaelbrooks

This comment has been minimized.

Show comment
Hide comment
@michaelbrooks

michaelbrooks Jul 1, 2016

@ilanschnell I also see this issue running the sh installer on OSX 10.11.4, however my anaconda installation after this problem is NOT functional, as it doesn't seem to have placed the activate script. Anaconda 4.0 works fine. The graphical installer also works fine.

michaelbrooks commented Jul 1, 2016

@ilanschnell I also see this issue running the sh installer on OSX 10.11.4, however my anaconda installation after this problem is NOT functional, as it doesn't seem to have placed the activate script. Anaconda 4.0 works fine. The graphical installer also works fine.

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jul 5, 2016

Member

The activate script not working is certainly unrelated to this problem. CC @msarahan

Member

ilanschnell commented Jul 5, 2016

The activate script not working is certainly unrelated to this problem. CC @msarahan

@msarahan

This comment has been minimized.

Show comment
Hide comment
@msarahan

msarahan Jul 5, 2016

Member

@michaelbrooks - just so I'm clear, the installer fails, and you're left with an incomplete install? Or, you're trying to update an old installation, and the activate scripts disappear?

Member

msarahan commented Jul 5, 2016

@michaelbrooks - just so I'm clear, the installer fails, and you're left with an incomplete install? Or, you're trying to update an old installation, and the activate scripts disappear?

@michaelbrooks

This comment has been minimized.

Show comment
Hide comment
@michaelbrooks

michaelbrooks Jul 5, 2016

Hmm. I'll run it again to confirm that this happened, but it was a case of "the installer failed, leaving an incomplete install".

Hmm. I'll run it again to confirm that this happened, but it was a case of "the installer failed, leaving an incomplete install".

@slonik-az

This comment has been minimized.

Show comment
Hide comment
@slonik-az

slonik-az Jul 6, 2016

@ilanschnell : Any update on when anaconda2-4.1.1 will appear?
It is a shame to be stuck with 4.0.0 while 4.1.x is out there :-)

@ilanschnell : Any update on when anaconda2-4.1.1 will appear?
It is a shame to be stuck with 4.0.0 while 4.1.x is out there :-)

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jul 6, 2016

Member

Most likely tomorrow.
However, your not stuck. The messages are harmless as far as I can tell, and you can also conda install anaconda=4.1.0.

Member

ilanschnell commented Jul 6, 2016

Most likely tomorrow.
However, your not stuck. The messages are harmless as far as I can tell, and you can also conda install anaconda=4.1.0.

@ilanschnell

This comment has been minimized.

Show comment
Hide comment
@ilanschnell

ilanschnell Jul 8, 2016

Member

Anaconda 4.1.1 is now available (http://repo.continuum.io/archive/), which includes a fix for this issue.

Member

ilanschnell commented Jul 8, 2016

Anaconda 4.1.1 is now available (http://repo.continuum.io/archive/), which includes a fix for this issue.

@jakirkham

This comment has been minimized.

Show comment
Hide comment
@jakirkham

jakirkham Jul 8, 2016

Can confirm that this solved the original problem. Posting my log here and closing the issue. Though feel free to discuss further.

$ curl -L http://repo.continuum.io/archive/Anaconda2-4.1.1-MacOSX-x86_64.sh > anaconda.sh
$ openssl sha1 anaconda.sh
SHA1(anaconda.sh)= e9bc41c49993fbc1518f05f787e081f53b591e84
$ bash anaconda.sh -b -p anaconda-test
PREFIX=/Users/kirkhamj/anaconda-test
installing: python-2.7.12-1 ...
installing: _nb_ext_conf-0.2.0-py27_0 ...
installing: alabaster-0.7.8-py27_0 ...
installing: anaconda-client-1.4.0-py27_0 ...
installing: anaconda-navigator-1.2.1-py27_0 ...
installing: appnope-0.1.0-py27_0 ...
installing: appscript-1.0.1-py27_0 ...
installing: argcomplete-1.0.0-py27_1 ...
installing: astropy-1.2.1-np111py27_0 ...
installing: babel-2.3.3-py27_0 ...
installing: backports-1.0-py27_0 ...
installing: backports_abc-0.4-py27_0 ...
installing: beautifulsoup4-4.4.1-py27_0 ...
installing: bitarray-0.8.1-py27_0 ...
installing: blaze-0.10.1-py27_0 ...
installing: bokeh-0.12.0-py27_0 ...
installing: boto-2.40.0-py27_0 ...
installing: bottleneck-1.1.0-np111py27_0 ...
installing: cdecimal-2.3-py27_2 ...
installing: cffi-1.6.0-py27_0 ...
installing: chest-0.2.3-py27_0 ...
installing: click-6.6-py27_0 ...
installing: cloudpickle-0.2.1-py27_0 ...
installing: clyent-1.2.2-py27_0 ...
installing: colorama-0.3.7-py27_0 ...
installing: configobj-5.0.6-py27_0 ...
installing: configparser-3.5.0b2-py27_1 ...
installing: contextlib2-0.5.3-py27_0 ...
installing: cryptography-1.4-py27_0 ...
installing: curl-7.49.0-0 ...
installing: cycler-0.10.0-py27_0 ...
installing: cython-0.24-py27_0 ...
installing: cytoolz-0.8.0-py27_0 ...
installing: dask-0.10.0-py27_0 ...
installing: datashape-0.5.2-py27_0 ...
installing: decorator-4.0.10-py27_0 ...
installing: dill-0.2.5-py27_0 ...
installing: docutils-0.12-py27_2 ...
installing: dynd-python-0.7.2-py27_0 ...
installing: entrypoints-0.2.2-py27_0 ...
installing: enum34-1.1.6-py27_0 ...
installing: et_xmlfile-1.0.1-py27_0 ...
installing: fastcache-1.0.2-py27_1 ...
installing: flask-0.11.1-py27_0 ...
installing: flask-cors-2.1.2-py27_0 ...
installing: freetype-2.5.5-1 ...
installing: funcsigs-1.0.2-py27_0 ...
installing: functools32-3.2.3.2-py27_0 ...
installing: futures-3.0.5-py27_0 ...
installing: get_terminal_size-1.0.0-py27_0 ...
installing: gevent-1.1.1-py27_0 ...
installing: greenlet-0.4.10-py27_0 ...
installing: grin-1.2.1-py27_3 ...
installing: h5py-2.6.0-np111py27_1 ...
installing: hdf5-1.8.16-0 ...
installing: heapdict-1.0.0-py27_1 ...
installing: idna-2.1-py27_0 ...
installing: imagesize-0.7.1-py27_0 ...
installing: ipaddress-1.0.16-py27_0 ...
installing: ipykernel-4.3.1-py27_0 ...
installing: ipython-4.2.0-py27_1 ...
installing: ipython_genutils-0.1.0-py27_0 ...
installing: ipywidgets-4.1.1-py27_0 ...
installing: itsdangerous-0.24-py27_0 ...
installing: jbig-2.1-0 ...
installing: jdcal-1.2-py27_1 ...
installing: jedi-0.9.0-py27_1 ...
installing: jinja2-2.8-py27_1 ...
installing: jpeg-8d-1 ...
installing: jsonschema-2.5.1-py27_0 ...
installing: jupyter-1.0.0-py27_3 ...
installing: jupyter_client-4.3.0-py27_0 ...
installing: jupyter_console-4.1.1-py27_0 ...
installing: jupyter_core-4.1.0-py27_0 ...
installing: libdynd-0.7.2-0 ...
installing: libpng-1.6.22-0 ...
installing: libtiff-4.0.6-2 ...
installing: libxml2-2.9.2-0 ...
installing: libxslt-1.1.28-2 ...
installing: llvmlite-0.11.0-py27_0 ...
installing: locket-0.2.0-py27_1 ...
installing: lxml-3.6.0-py27_0 ...
installing: markupsafe-0.23-py27_2 ...
installing: matplotlib-1.5.1-np111py27_0 ...
installing: mistune-0.7.2-py27_1 ...
installing: mkl-11.3.3-0 ...
installing: mkl-service-1.1.2-py27_2 ...
installing: mpmath-0.19-py27_1 ...
installing: multipledispatch-0.4.8-py27_0 ...
installing: nb_anacondacloud-1.1.0-py27_0 ...
installing: nb_conda-1.1.0-py27_0 ...
installing: nb_conda_kernels-1.0.3-py27_0 ...
installing: nbconvert-4.2.0-py27_0 ...
installing: nbformat-4.0.1-py27_0 ...
installing: nbpresent-3.0.2-py27_0 ...
installing: networkx-1.11-py27_0 ...
installing: nltk-3.2.1-py27_0 ...
installing: nose-1.3.7-py27_1 ...
installing: notebook-4.2.1-py27_0 ...
installing: numba-0.26.0-np111py27_0 ...
installing: numexpr-2.6.0-np111py27_0 ...
installing: numpy-1.11.1-py27_0 ...
installing: odo-0.5.0-py27_1 ...
installing: openpyxl-2.3.2-py27_0 ...
installing: openssl-1.0.2h-1 ...
installing: pandas-0.18.1-np111py27_0 ...
installing: partd-0.3.4-py27_0 ...
installing: path.py-8.2.1-py27_0 ...
installing: pathlib2-2.1.0-py27_0 ...
installing: patsy-0.4.1-py27_0 ...
installing: pep8-1.7.0-py27_0 ...
installing: pexpect-4.0.1-py27_0 ...
installing: pickleshare-0.7.2-py27_0 ...
installing: pillow-3.2.0-py27_1 ...
installing: pip-8.1.2-py27_0 ...
installing: ply-3.8-py27_0 ...
installing: psutil-4.3.0-py27_0 ...
installing: ptyprocess-0.5.1-py27_0 ...
installing: py-1.4.31-py27_0 ...
installing: pyasn1-0.1.9-py27_0 ...
installing: pyaudio-0.2.7-py27_0 ...
installing: pycosat-0.6.1-py27_1 ...
installing: pycparser-2.14-py27_1 ...
installing: pycrypto-2.6.1-py27_4 ...
installing: pycurl-7.43.0-py27_0 ...
installing: pyflakes-1.2.3-py27_0 ...
installing: pygments-2.1.3-py27_0 ...
installing: pyopenssl-0.16.0-py27_0 ...
installing: pyparsing-2.1.4-py27_0 ...
installing: pyqt-4.11.4-py27_3 ...
installing: pytables-3.2.2-np111py27_4 ...
installing: pytest-2.9.2-py27_0 ...
installing: python-dateutil-2.5.3-py27_0 ...
installing: python.app-1.2-py27_4 ...
installing: pytz-2016.4-py27_0 ...
installing: pyyaml-3.11-py27_4 ...
installing: pyzmq-15.2.0-py27_1 ...
installing: qt-4.8.7-3 ...
installing: qtconsole-4.2.1-py27_0 ...
installing: qtpy-1.0.2-py27_0 ...
installing: readline-6.2-2 ...
installing: redis-3.2.0-0 ...
installing: redis-py-2.10.5-py27_0 ...
installing: requests-2.10.0-py27_0 ...
installing: rope-0.9.4-py27_1 ...
installing: ruamel_yaml-0.11.7-py27_0 ...
installing: scikit-image-0.12.3-np111py27_1 ...
installing: scikit-learn-0.17.1-np111py27_2 ...
installing: scipy-0.17.1-np111py27_1 ...
installing: setuptools-23.0.0-py27_0 ...
installing: simplegeneric-0.8.1-py27_1 ...
installing: singledispatch-3.4.0.3-py27_0 ...
installing: sip-4.16.9-py27_0 ...
installing: six-1.10.0-py27_0 ...
installing: snowballstemmer-1.2.1-py27_0 ...
installing: sockjs-tornado-1.0.3-py27_0 ...
installing: sphinx-1.4.1-py27_0 ...
installing: sphinx_rtd_theme-0.1.9-py27_0 ...
installing: spyder-2.3.9-py27_0 ...
installing: sqlalchemy-1.0.13-py27_0 ...
installing: sqlite-3.13.0-0 ...
installing: ssl_match_hostname-3.4.0.2-py27_1 ...
installing: statsmodels-0.6.1-np111py27_1 ...
installing: sympy-1.0-py27_0 ...
installing: terminado-0.6-py27_0 ...
installing: tk-8.5.18-0 ...
installing: toolz-0.8.0-py27_0 ...
installing: tornado-4.3-py27_1 ...
installing: traitlets-4.2.1-py27_0 ...
installing: unicodecsv-0.14.1-py27_0 ...
installing: werkzeug-0.11.10-py27_0 ...
installing: wheel-0.29.0-py27_0 ...
installing: xlrd-1.0.0-py27_0 ...
installing: xlsxwriter-0.9.2-py27_0 ...
installing: xlwings-0.7.2-py27_0 ...
installing: xlwt-1.1.2-py27_0 ...
installing: xz-5.2.2-0 ...
installing: yaml-0.1.6-0 ...
installing: zlib-1.2.8-3 ...
installing: anaconda-4.1.1-np111py27_0 ...
installing: conda-4.1.6-py27_0 ...
installing: conda-build-1.21.3-py27_0 ...
installing: conda-env-2.5.1-py27_0 ...
Python 2.7.12 :: Continuum Analytics, Inc.
creating default environment...
installation finished.

Can confirm that this solved the original problem. Posting my log here and closing the issue. Though feel free to discuss further.

$ curl -L http://repo.continuum.io/archive/Anaconda2-4.1.1-MacOSX-x86_64.sh > anaconda.sh
$ openssl sha1 anaconda.sh
SHA1(anaconda.sh)= e9bc41c49993fbc1518f05f787e081f53b591e84
$ bash anaconda.sh -b -p anaconda-test
PREFIX=/Users/kirkhamj/anaconda-test
installing: python-2.7.12-1 ...
installing: _nb_ext_conf-0.2.0-py27_0 ...
installing: alabaster-0.7.8-py27_0 ...
installing: anaconda-client-1.4.0-py27_0 ...
installing: anaconda-navigator-1.2.1-py27_0 ...
installing: appnope-0.1.0-py27_0 ...
installing: appscript-1.0.1-py27_0 ...
installing: argcomplete-1.0.0-py27_1 ...
installing: astropy-1.2.1-np111py27_0 ...
installing: babel-2.3.3-py27_0 ...
installing: backports-1.0-py27_0 ...
installing: backports_abc-0.4-py27_0 ...
installing: beautifulsoup4-4.4.1-py27_0 ...
installing: bitarray-0.8.1-py27_0 ...
installing: blaze-0.10.1-py27_0 ...
installing: bokeh-0.12.0-py27_0 ...
installing: boto-2.40.0-py27_0 ...
installing: bottleneck-1.1.0-np111py27_0 ...
installing: cdecimal-2.3-py27_2 ...
installing: cffi-1.6.0-py27_0 ...
installing: chest-0.2.3-py27_0 ...
installing: click-6.6-py27_0 ...
installing: cloudpickle-0.2.1-py27_0 ...
installing: clyent-1.2.2-py27_0 ...
installing: colorama-0.3.7-py27_0 ...
installing: configobj-5.0.6-py27_0 ...
installing: configparser-3.5.0b2-py27_1 ...
installing: contextlib2-0.5.3-py27_0 ...
installing: cryptography-1.4-py27_0 ...
installing: curl-7.49.0-0 ...
installing: cycler-0.10.0-py27_0 ...
installing: cython-0.24-py27_0 ...
installing: cytoolz-0.8.0-py27_0 ...
installing: dask-0.10.0-py27_0 ...
installing: datashape-0.5.2-py27_0 ...
installing: decorator-4.0.10-py27_0 ...
installing: dill-0.2.5-py27_0 ...
installing: docutils-0.12-py27_2 ...
installing: dynd-python-0.7.2-py27_0 ...
installing: entrypoints-0.2.2-py27_0 ...
installing: enum34-1.1.6-py27_0 ...
installing: et_xmlfile-1.0.1-py27_0 ...
installing: fastcache-1.0.2-py27_1 ...
installing: flask-0.11.1-py27_0 ...
installing: flask-cors-2.1.2-py27_0 ...
installing: freetype-2.5.5-1 ...
installing: funcsigs-1.0.2-py27_0 ...
installing: functools32-3.2.3.2-py27_0 ...
installing: futures-3.0.5-py27_0 ...
installing: get_terminal_size-1.0.0-py27_0 ...
installing: gevent-1.1.1-py27_0 ...
installing: greenlet-0.4.10-py27_0 ...
installing: grin-1.2.1-py27_3 ...
installing: h5py-2.6.0-np111py27_1 ...
installing: hdf5-1.8.16-0 ...
installing: heapdict-1.0.0-py27_1 ...
installing: idna-2.1-py27_0 ...
installing: imagesize-0.7.1-py27_0 ...
installing: ipaddress-1.0.16-py27_0 ...
installing: ipykernel-4.3.1-py27_0 ...
installing: ipython-4.2.0-py27_1 ...
installing: ipython_genutils-0.1.0-py27_0 ...
installing: ipywidgets-4.1.1-py27_0 ...
installing: itsdangerous-0.24-py27_0 ...
installing: jbig-2.1-0 ...
installing: jdcal-1.2-py27_1 ...
installing: jedi-0.9.0-py27_1 ...
installing: jinja2-2.8-py27_1 ...
installing: jpeg-8d-1 ...
installing: jsonschema-2.5.1-py27_0 ...
installing: jupyter-1.0.0-py27_3 ...
installing: jupyter_client-4.3.0-py27_0 ...
installing: jupyter_console-4.1.1-py27_0 ...
installing: jupyter_core-4.1.0-py27_0 ...
installing: libdynd-0.7.2-0 ...
installing: libpng-1.6.22-0 ...
installing: libtiff-4.0.6-2 ...
installing: libxml2-2.9.2-0 ...
installing: libxslt-1.1.28-2 ...
installing: llvmlite-0.11.0-py27_0 ...
installing: locket-0.2.0-py27_1 ...
installing: lxml-3.6.0-py27_0 ...
installing: markupsafe-0.23-py27_2 ...
installing: matplotlib-1.5.1-np111py27_0 ...
installing: mistune-0.7.2-py27_1 ...
installing: mkl-11.3.3-0 ...
installing: mkl-service-1.1.2-py27_2 ...
installing: mpmath-0.19-py27_1 ...
installing: multipledispatch-0.4.8-py27_0 ...
installing: nb_anacondacloud-1.1.0-py27_0 ...
installing: nb_conda-1.1.0-py27_0 ...
installing: nb_conda_kernels-1.0.3-py27_0 ...
installing: nbconvert-4.2.0-py27_0 ...
installing: nbformat-4.0.1-py27_0 ...
installing: nbpresent-3.0.2-py27_0 ...
installing: networkx-1.11-py27_0 ...
installing: nltk-3.2.1-py27_0 ...
installing: nose-1.3.7-py27_1 ...
installing: notebook-4.2.1-py27_0 ...
installing: numba-0.26.0-np111py27_0 ...
installing: numexpr-2.6.0-np111py27_0 ...
installing: numpy-1.11.1-py27_0 ...
installing: odo-0.5.0-py27_1 ...
installing: openpyxl-2.3.2-py27_0 ...
installing: openssl-1.0.2h-1 ...
installing: pandas-0.18.1-np111py27_0 ...
installing: partd-0.3.4-py27_0 ...
installing: path.py-8.2.1-py27_0 ...
installing: pathlib2-2.1.0-py27_0 ...
installing: patsy-0.4.1-py27_0 ...
installing: pep8-1.7.0-py27_0 ...
installing: pexpect-4.0.1-py27_0 ...
installing: pickleshare-0.7.2-py27_0 ...
installing: pillow-3.2.0-py27_1 ...
installing: pip-8.1.2-py27_0 ...
installing: ply-3.8-py27_0 ...
installing: psutil-4.3.0-py27_0 ...
installing: ptyprocess-0.5.1-py27_0 ...
installing: py-1.4.31-py27_0 ...
installing: pyasn1-0.1.9-py27_0 ...
installing: pyaudio-0.2.7-py27_0 ...
installing: pycosat-0.6.1-py27_1 ...
installing: pycparser-2.14-py27_1 ...
installing: pycrypto-2.6.1-py27_4 ...
installing: pycurl-7.43.0-py27_0 ...
installing: pyflakes-1.2.3-py27_0 ...
installing: pygments-2.1.3-py27_0 ...
installing: pyopenssl-0.16.0-py27_0 ...
installing: pyparsing-2.1.4-py27_0 ...
installing: pyqt-4.11.4-py27_3 ...
installing: pytables-3.2.2-np111py27_4 ...
installing: pytest-2.9.2-py27_0 ...
installing: python-dateutil-2.5.3-py27_0 ...
installing: python.app-1.2-py27_4 ...
installing: pytz-2016.4-py27_0 ...
installing: pyyaml-3.11-py27_4 ...
installing: pyzmq-15.2.0-py27_1 ...
installing: qt-4.8.7-3 ...
installing: qtconsole-4.2.1-py27_0 ...
installing: qtpy-1.0.2-py27_0 ...
installing: readline-6.2-2 ...
installing: redis-3.2.0-0 ...
installing: redis-py-2.10.5-py27_0 ...
installing: requests-2.10.0-py27_0 ...
installing: rope-0.9.4-py27_1 ...
installing: ruamel_yaml-0.11.7-py27_0 ...
installing: scikit-image-0.12.3-np111py27_1 ...
installing: scikit-learn-0.17.1-np111py27_2 ...
installing: scipy-0.17.1-np111py27_1 ...
installing: setuptools-23.0.0-py27_0 ...
installing: simplegeneric-0.8.1-py27_1 ...
installing: singledispatch-3.4.0.3-py27_0 ...
installing: sip-4.16.9-py27_0 ...
installing: six-1.10.0-py27_0 ...
installing: snowballstemmer-1.2.1-py27_0 ...
installing: sockjs-tornado-1.0.3-py27_0 ...
installing: sphinx-1.4.1-py27_0 ...
installing: sphinx_rtd_theme-0.1.9-py27_0 ...
installing: spyder-2.3.9-py27_0 ...
installing: sqlalchemy-1.0.13-py27_0 ...
installing: sqlite-3.13.0-0 ...
installing: ssl_match_hostname-3.4.0.2-py27_1 ...
installing: statsmodels-0.6.1-np111py27_1 ...
installing: sympy-1.0-py27_0 ...
installing: terminado-0.6-py27_0 ...
installing: tk-8.5.18-0 ...
installing: toolz-0.8.0-py27_0 ...
installing: tornado-4.3-py27_1 ...
installing: traitlets-4.2.1-py27_0 ...
installing: unicodecsv-0.14.1-py27_0 ...
installing: werkzeug-0.11.10-py27_0 ...
installing: wheel-0.29.0-py27_0 ...
installing: xlrd-1.0.0-py27_0 ...
installing: xlsxwriter-0.9.2-py27_0 ...
installing: xlwings-0.7.2-py27_0 ...
installing: xlwt-1.1.2-py27_0 ...
installing: xz-5.2.2-0 ...
installing: yaml-0.1.6-0 ...
installing: zlib-1.2.8-3 ...
installing: anaconda-4.1.1-np111py27_0 ...
installing: conda-4.1.6-py27_0 ...
installing: conda-build-1.21.3-py27_0 ...
installing: conda-env-2.5.1-py27_0 ...
Python 2.7.12 :: Continuum Analytics, Inc.
creating default environment...
installation finished.
@maheshwarLigade

This comment has been minimized.

Show comment
Hide comment
@maheshwarLigade

maheshwarLigade Aug 19, 2017

I also have the same problem while try to clean the anaconda
anaconda-clean --yes
This throes same exception on my osx
env | sort output

Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.s3zsoACacK/Render
HOME=/Users/maheshwarligade
LC_CTYPE=UTF-8
LOGNAME=maheshwarligade
PATH=/Users/maheshwarligade/Documents/conda/anaconda/bin:/usr/local/opt/openssl/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin
PWD=/Users/maheshwarligade
SHELL=/bin/bash
SHLVL=1
SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.uKbv7pkOOj/Listeners
TERM=xterm-256color
TERM_PROGRAM=Apple_Terminal
TERM_PROGRAM_VERSION=343.7
TERM_SESSION_ID=A4E0B6DA-0649-4761-9966-F23E6E886F12
TMPDIR=/var/folders/0m/wkqlk31j5qjf6z16ckq176m40000gn/T/
USER=maheshwarligade
XPC_FLAGS=0x0
XPC_SERVICE_NAME=0
_=/usr/bin/env
__CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0

Kindly help me

I also have the same problem while try to clean the anaconda
anaconda-clean --yes
This throes same exception on my osx
env | sort output

Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.s3zsoACacK/Render
HOME=/Users/maheshwarligade
LC_CTYPE=UTF-8
LOGNAME=maheshwarligade
PATH=/Users/maheshwarligade/Documents/conda/anaconda/bin:/usr/local/opt/openssl/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin
PWD=/Users/maheshwarligade
SHELL=/bin/bash
SHLVL=1
SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.uKbv7pkOOj/Listeners
TERM=xterm-256color
TERM_PROGRAM=Apple_Terminal
TERM_PROGRAM_VERSION=343.7
TERM_SESSION_ID=A4E0B6DA-0649-4761-9966-F23E6E886F12
TMPDIR=/var/folders/0m/wkqlk31j5qjf6z16ckq176m40000gn/T/
USER=maheshwarligade
XPC_FLAGS=0x0
XPC_SERVICE_NAME=0
_=/usr/bin/env
__CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0

Kindly help me

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment