Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Creating Stage on EaselJS 1.0.2 doesn't work on iOS 8.3 / Safari (0.8.2 does work) #982

Open
Friksel opened this issue Sep 16, 2018 · 3 comments

Comments

@Friksel
Copy link

commented Sep 16, 2018

I recently found out some of my animations using EaselJs were and others weren't playing on iOS 8.3. iPad Air in Safari (but probably other browsers on iOS 8.3 neither). I was surprised to see the animations not even showing are build on EaselJs v1.0.2 and the animations that are fully working without problems are build on 0.8.2.

1.0.2 halts on creating the stage. According to the API creating the Stage is done the same way in 1.0.2 as in 0.8.2 and that makes sense, 'cause in all other devices I tested this on (and different browsers on those devices) just work fine with 1.0.2.

canvas = document.getElementById('soyouthinkyoucanvas');
stage = new createjs.Stage(canvas);

I had to move back to version 0.8.2 to support iOS 8.3 again, and now they work fine there too.
So something seems to be off in EaselJS 1.0.2.
I'm surprised to see this version is a year old and can't find any complaints about iOS problems on the issues here. iOS doesn't seem THAT old, 4 years. Or is the support dropped for iOS 8 from version 1?

@joseph-olivemultimedia

This comment has been minimized.

Copy link

commented Oct 25, 2018

Yes, i do get the same issue, I was not able to view the files in iOS

@lannymcnie lannymcnie added the bug label Oct 25, 2018

@lannymcnie

This comment has been minimized.

Copy link
Member

commented Oct 25, 2018

Thanks, will check it out.

@Friksel

This comment has been minimized.

Copy link
Author

commented Dec 27, 2018

This issue was opened in september, so about 3 months ago, and is about iOS 8.3 not working at all with EaselJs, so I'm a little bit surprised there's no fix for this yet. Projects here still have to go with a very old EaselJs version because of this. Is there any progress on this? Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.