Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Report a bug #18

Closed
XuPaperCup opened this issue Jul 1, 2018 · 0 comments

Comments

Projects
None yet
2 participants
@XuPaperCup
Copy link

commented Jul 1, 2018

Report a bug:

Information

Using:
MultiWorld V.1.4.3
PocketMine-MP verison:3.0.4
API: 3.0.0
PHP: 7.2

Bug Description

When I open the server,no error happen,but when I run reload command,it happened error and disable the plugin.I see that the error is about nether.I see the debug and think that error happened is because PocketMine is support nether now(which mean we can go to nether),it already assigned the nether and your plugin(MultiWorld) assigned again,whick make this error and disable this plugin.

Debug

[10:27:05] [Server thread/INFO]: Enabling MultiWorld v1.4.3
[10:27:05] [Server thread/CRITICAL]: InvalidArgumentException: "Alias "nether" is already assigned" (EXCEPTION) in "src/pocketmine/level/generator/GeneratorManager" at line 55
[10:27:05] [Server thread/DEBUG]: #0 MultiWorld_dev-111.phar/src/multiworld/MultiWorld(63): pocketmine\level\generator\GeneratorManager::addGenerator(string multiworld\generator\ender\EnderGenerator, string ender)
[10:27:05] [Server thread/DEBUG]: #1 src/pocketmine/plugin/PluginBase(102): multiworld\MultiWorld->onEnable()
[10:27:05] [Server thread/DEBUG]: #2 src/pocketmine/plugin/PluginManager(618): pocketmine\plugin\PluginBase->setEnabled(boolean 1)
[10:27:05] [Server thread/DEBUG]: #3 src/pocketmine/Server(1928): pocketmine\plugin\PluginManager->enablePlugin(multiworld\MultiWorld object)
[10:27:05] [Server thread/DEBUG]: #4 src/pocketmine/Server(1914): pocketmine\Server->enablePlugin(multiworld\MultiWorld object)
[10:27:05] [Server thread/DEBUG]: #5 src/pocketmine/Server(1708): pocketmine\Server->enablePlugins(integer 1)
[10:27:05] [Server thread/DEBUG]: #6 src/pocketmine/PocketMine(237): pocketmine\Server->__construct(BaseClassLoader object, pocketmine\utils\MainLogger object, string C:\Users\Administrator.USER-20180220MY\Desktop\PocketMine-MP, string C:\Users\Administrator.USER-20180220MY\Desktop\PocketMine-MP\plugins)
[10:27:05] [Server thread/DEBUG]: #7 C:/Users/Administrator.USER-20180220MY/Desktop/PocketMine-MP/PocketMine-MP.phar(1): require(string phar://C:/Users/Administrator.USER-20180220MY/Desktop/PocketMine-MP/PocketMine-MP.phar/src/pocketmine/PocketMine.php)
[10:27:05] [Server thread/INFO]: Disabling MultiWorld v1.4.3

Please also do:

Ask me if you need more infomation.
Please help to fix the bug.
When the bug fixed,please comment below to tell me and I will close this issue
Thank you for helping.Have a good day:D

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.