Skip to content
Commits on Feb 6, 2012
  1. @blt04

    Update readme

    blt04 committed Feb 6, 2012
  2. @blt04

    Fix issues with run stages, install rvm by default

    A few issues were popping up with regarding run stages (refs #29, refs #32).
    Rvm will now be installed using its own run stage when you `include rvm`
    in your manifest file.  You no longer need to include `rvm::system`,
    as it will be included by default.
    blt04 committed Feb 6, 2012
Commits on Jan 29, 2012
  1. @blt04
Commits on Jan 28, 2012
  1. @luxflux
Commits on Jan 22, 2012
  1. @blt04

    Fix broken default_use implementation in rvm_system_ruby

    Using rvm --default use 1.9.2 no longer works in scripting mode.  We use
    rvm alias create default instead.
    
    Also fix a bug that prevents the default from being set when fist
    installing a ruby version.
    
    References #30.
    blt04 committed Jan 21, 2012
  2. @blt04

    Improve gem/gemset not found detection

    Newer RVM versions exit with an error status when trying to list
    gems and gemsets for a Ruby version that is not installed
    blt04 committed Jan 21, 2012
Commits on Jan 21, 2012
  1. @blt04
  2. @blt04

    Add note about false errors in 2.7.4 through 2.7.9

    References #21.
    blt04 committed Jan 21, 2012
  3. @blt04

    Use run stages to install RVM first

    This enables installing RVM and rubies in one puppet run.
    
    References #29.
    blt04 committed Jan 21, 2012
  4. @blt04
  5. @blt04

    Ensure user and group resources are defined

    It is still best to define these resources outside of RVM, but this
    should make rvm::system_user work even if the user isn't previously
    defined.
    blt04 committed Jan 21, 2012
  6. @blt04

    Update README versions

    blt04 committed Jan 21, 2012
  7. @blt04
  8. @blt04

    Puppet style guide updates

    blt04 committed Jan 21, 2012
Commits on Dec 12, 2011
  1. @blt04

    Merge pull request #27 from sgp/master

    Fix missing dependency for mod_ssl for RHEL/CentOS
    blt04 committed Dec 12, 2011
Commits on Dec 2, 2011
  1. @blt04

    Merge pull request #25 from krissi/master

    Added Debian to dependencies
    blt04 committed Dec 2, 2011
  2. @krissi
Commits on Nov 21, 2011
  1. @blt04

    Merge pull request #24 from englishm/master

    Update gem command
    blt04 committed Nov 21, 2011
  2. @englishm

    Update gem command

    englishm committed Nov 21, 2011
Commits on Oct 18, 2011
  1. Add missing apache dependency for passenger

    Refs #22.
    Brandon Turner committed Oct 18, 2011
Commits on Oct 11, 2011
  1. @blt04
Commits on Sep 20, 2011
  1. @blt04

    Remove use of String#lines

    String#lines is not part of the ruby < 1.8.7 and the backport was not
    working as intended.
    
    Fixes #18.  Fixes #19.
    blt04 committed Sep 20, 2011
Commits on Aug 30, 2011
  1. Changed the gemset name separator from / to @

    This change makes a backwards incompatible change to the way gemsets are
    defined and used.  You should now use this syntax:
    
        rvm_gemset {
          'ruby-1.9.2-p290@mygemset':
            ensure => present,
            require => Rvm_system_ruby['ruby-1.9.2-p290'];
        }
    
        rvm_gem {
          'ruby-1.9.2-p290@mygemset/bundler':
            ensure => present,
            require => Rvm_gemset['ruby-1.9.2-p290@mygemset'];
        }
    
    Ruby versions are now separated from gemsets with an `@` instead of a
    `/`.  Gems still use a `/` in their name to separate them from the ruby
    version.  This should make it defining and using gemsets a bit cleaner
    and more like rvm.
    
    Sorry for the inconvenience.  Fixes #17.
    Brandon Turner committed Aug 30, 2011
Commits on Aug 24, 2011
  1. @blt04

    Merge pull request #16 from yarrow/tweaks

    3 Tweaks - RedHat, specific rvm version, fixup for Ruby 1.8
    blt04 committed Aug 24, 2011
  2. @fritz

    Work in Ruby 1.8 as well as 1.9

    fritz committed Aug 24, 2011
  3. @fritz

    Allow specification of a particular rvm version

    For instance, class { 'rvm::system': version => '1.7.2' }
    Default version is 'latest'
    fritz committed Aug 24, 2011
  4. @fritz

    Use CentOS code for Red Hat also

    fritz committed Aug 24, 2011
Commits on Aug 19, 2011
  1. Added support for creating and removing gemsets

    Brandon Turner committed Aug 19, 2011
  2. Updated default ruby version

    Brandon Turner committed Aug 18, 2011
  3. Fixed typo

    Brandon Turner committed Aug 18, 2011
  4. Removed rvm_prefix parameter as it isn't used anywhere

    Brandon Turner committed Aug 18, 2011
Commits on Aug 14, 2011
  1. @blt04

    Merge pull request #15 from johnf/master

    Ruby 1.9.2 compat: String isn't enumerable anymore:
    blt04 committed Aug 14, 2011
  2. @johnf
Commits on Aug 10, 2011
  1. Fixed typo

    Brandon Turner committed Aug 9, 2011
Something went wrong with that request. Please try again.