Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Custom enchant books override same enchantment (regardless of level) #209

Open
Aericio opened this issue Jul 21, 2019 · 0 comments

Comments

@Aericio
Copy link
Collaborator

commented Jul 21, 2019

Please make sure your issue complies with these guidelines:

    • Server Software must be the official PMMP w/o vanilla patching plugins (i.e. TeaSpoon)
    • Issue must have not been reported previously
    • Make sure you are on the latest version of PMMP & PiggyCustomEnchants
    • Have a detailed title, like "CustomEnchants::getName() must be..."
    • If possible, provide crashdumps/errors related to the issue.

General

Custom enchant books override same enchantment, regardless of level. If you apply a level 1 book to an item with level 5, it will override it. Goodbye, your hard work.

Version:

  • PiggyCustomEnchants: 1.4.6
  • PMMP: 3.9.1

Steps to Reproduce the Issue

  1. /ce enchant explosive 5 on a pickaxe. (any custom enchant works)
  2. /ce enchant explosive 1 on a book. (any custom enchant works)
  3. Apply the explosive book to the pickaxe.
  4. Pickaxe now has explosive level 1.

Extra Information

@Aericio Aericio added the bug label Jul 21, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.