Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add undo and redo button on toolbar #124

Closed
4goodapp opened this issue Nov 29, 2018 · 11 comments

Comments

@4goodapp
Copy link
Contributor

commented Nov 29, 2018

No description provided.

@DamirPorobic

This comment has been minimized.

Copy link
Owner

commented Nov 30, 2018

Thanks for opening this feature request. Is there a particular reason why you want to have undo and redo buttons on the toolbar? I've tried so far to keep the toolbar as minimalistic as possible in order to keep it simple. Undo/redo is already available via shortcuts and menu bar.

@DamirPorobic DamirPorobic changed the title Add undo and redo button on toolbar (Feature Request) Add undo and redo button on toolbar Nov 30, 2018

@4goodapp

This comment has been minimized.

Copy link
Contributor Author

commented Dec 8, 2018

image

Because when you edit an image, that space is always empty, so I think it could be used and we can save some extra click (Edit > Undo/Redo) when you use mouse only.

@DamirPorobic

This comment has been minimized.

Copy link
Owner

commented Dec 8, 2018

Personally I'm not a big fan of cockpit like toolbars, but others users have asked for this feature too so we will probably implement it. Eventually having something like a feature toggle to enable advanced toolbar with more options, like crop, undo&redo, .., and to disable ti in order to keep the current simple look.

@4goodapp

This comment has been minimized.

Copy link
Contributor Author

commented Dec 8, 2018

Eventually having something like a feature toggle to enable advanced toolbar with more options, like crop, undo&redo, .., and to disable ti in order to keep the current simple look.

Yes, that would be even better, I've been missing the crop feature as well.

And by the way, it would be great if you we can add an icon on the system menu automatically when using the AppImages.

@DamirPorobic

This comment has been minimized.

Copy link
Owner

commented Dec 12, 2018

With AppImage it's a bit tricky to get a menu item because you're not installing the AppImage but what can be done is having ksnip start on system boot, run in background an except shortcut input via dbus or any other way. There is already an issue for that #123

@smaragdus

This comment has been minimized.

Copy link

commented Dec 20, 2018

In my opinion the best solution would be customizable tool bar with two columns- used buttons/available buttons plus an option to reset it (restore default buttons).

Off-topic- the Windows build ('ksnip-1.5.0-continuous-x86_64.exe') does not work on my system (Windows 8 x64)- if the developer is not aware of the progblem I may open a new issue.

@DamirPorobic

This comment has been minimized.

Copy link
Owner

commented Dec 21, 2018

@smaragdus no, I'm not aware of this issue. Could you please open a new issue for that?

@smaragdus

This comment has been minimized.

Copy link

commented Mar 19, 2019

@DamirPorobic

I could not respond immediately and later I forgot about the problem I mentioned. As far as I can remember it crashed on my machine.

Today I did a brief test of ksnip version 1.5.0-continuous Build: 683-1e81649 and it worked just fine (no crashes). I may open several new issues concerning features and options I would like to see implemented in ksnip. I hope you don't mind that.

@DamirPorobic

This comment has been minimized.

Copy link
Owner

commented Mar 19, 2019

I think I know what it was, some libraries were missing but were installed on my machine so it worked for me but not for people that didn't have those libs. The latest package should have everything required.

Feature requests are always welcome, just like Pull Requests :)

@smaragdus

This comment has been minimized.

Copy link

commented Mar 19, 2019

@DamirPorobic

I think I know what it was, some libraries were missing but were installed on my machine so it worked for me but not for people that didn't have those libs. The latest package should have everything required.

Exactly- now I remember that there were error messages complaining about missing DLLs. I had some of these DLLs in other programs but copying some of them manually from other sources did not work (perhaps these copied DLLs had different versions).

@DamirPorobic DamirPorobic added this to the v1.6.0 milestone Mar 20, 2019

@DamirPorobic DamirPorobic added this to Open in v1.6.0 Apr 5, 2019

@DamirPorobic DamirPorobic moved this from Open to In progress in v1.6.0 Sep 3, 2019

@DamirPorobic DamirPorobic self-assigned this Sep 3, 2019

DamirPorobic added a commit that referenced this issue Sep 4, 2019
@DamirPorobic

This comment has been minimized.

Copy link
Owner

commented Sep 4, 2019

Done

@DamirPorobic DamirPorobic moved this from In progress to Done in v1.6.0 Sep 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
3 participants
You can’t perform that action at this time.