Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Locate SDK" button may not be saving SDK path correctly #1896

Closed
DanTup opened this issue Jul 30, 2019 · 3 comments
Closed

"Locate SDK" button may not be saving SDK path correctly #1896

DanTup opened this issue Jul 30, 2019 · 3 comments
Labels
in flutter Relates to running Flutter apps is bug
Milestone

Comments

@DanTup
Copy link
Member

DanTup commented Jul 30, 2019

I've seen reports this might not be working correctly before, but never really got a concrete example. Today @ClassicNations mentioned the same thing in Gitter, that selecting the Flutter SDK folder with "Locate SDK" didn't seem to persist the setting.

This needs some testing (and if I can't repro, the code reviewing for any obvious reasons it might not save).

@DanTup DanTup added is bug in flutter Relates to running Flutter apps labels Jul 30, 2019
@DanTup DanTup added this to the v3.4.0 milestone Jul 30, 2019
@mcachopas
Copy link

Solved here

Just downloading the SDK installer for Windows http://www.gekorm.com/dart-windows from the webpage https://dart.dev/get-dart, and instaled on my PC

Try out

@craigoha
Copy link

craigoha commented Aug 2, 2019

Same issue = "... selecting the Flutter SDK folder with "Locate SDK" didn't seem to persist the setting."

Like @ClassicNations, installed Flutter originally in programs directory but then moved it to another directory for organization reasons.

@DanTup Is there a way to manually change the path via VS Code > File > Preferences > Settings > Dart: Flutter Sdk Path? Current path is displayed after opening Edit in settings.json but cannot be changed.

image

@DanTup
Copy link
Member Author

DanTup commented Aug 5, 2019

@craigoha you should definitely be able to edit the setting in your Settings json editor - just add a comma to the end of that existing line, then start typing dart.flutterSdkPath and it should be in the auto-complete.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
in flutter Relates to running Flutter apps is bug
Projects
None yet
Development

No branches or pull requests

3 participants