Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Allow non-breaking updates of chef_handler #291

Conversation

Projects
None yet
5 participants
@eherot
Copy link
Contributor

commented Apr 11, 2016

Reading back to #25 when this constraint was first introduced, it doesn't seem like there's any compelling reason not to allow future non-breaking changes to come in automatically. However, refusing to allow anything above 1.1.x definitely causes problems for my other cookbooks that also need to use chef_handler (and there are several).

@miketheman

This comment has been minimized.

Copy link
Collaborator

commented Apr 15, 2016

I had reported a breaking change that made it into 1.2.0 of chef_handler here: https://github.com/chef-cookbooks/chef_handler/issues/34

I'm not entirely convinced yet what the right version is - especially if we want to continue to provide maximum compatibility.

Is there a particular feature from chef_handler that's needed?

@eherot

This comment has been minimized.

Copy link
Contributor Author

commented Jun 7, 2016

Sorry to leave this hanging for so long. There is not a particular feature that's needed. The problem is that it's very difficult to get such a specific version match to play nice with other cookbooks in the dependency tree (many of which are not maintained by me).

@mfischer-zd

This comment has been minimized.

Copy link
Contributor

commented Jul 13, 2016

What was the breaking change? Has the current release been tested against chef_handler 1.2+?

@olivielpeau

This comment has been minimized.

Copy link
Member

commented Jul 13, 2016

@mfischer-zd For reference see also #270

Basically the 1.2.0 release of chef-handler is compatible with Chef 12+ only whereas the previous 1.x releases were compatible with Chef 10+.

We need to test that the current version of chef-handler (1.4.0), which is advertised to work with Chef 11+, works well with this cookbook before loosening the version constraint. I'll make sure to prioritize this since the version constraint seems to be blocking for many users of the cookbook.

@mfischer-zd

This comment has been minimized.

Copy link
Contributor

commented Jul 13, 2016

While I think your desire to prevent breakage for folks running on Chef < 12 is high-minded, it's not the responsibility of this cookbook to prevent such breakage. That's an interaction between chef-handler and Chef, not you and chef-handler; and this cookbook should not intervene.

If the combination of this cookbook, the chef-handler cookbook, and Chef 12 work fine, then I would recommend noting the issue with Chef < 12 in the README, and leaving it at that.

@olivielpeau

This comment has been minimized.

Copy link
Member

commented Jul 19, 2016

@mfischer-zd: Makes a lot of sense, thanks. I'll spend some time testing the recipe with chef-handler 1.2/1.3/1.4, note the issue in the README, and include that in the next minor release.

We should be able to release it by early next week.

@olivielpeau olivielpeau added this to the 2.5.0 milestone Aug 3, 2016

@olivielpeau olivielpeau merged commit 0232c6c into DataDog:master Aug 3, 2016

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@volker-fr

This comment has been minimized.

Copy link

commented Aug 9, 2016

Still limited to version 1.1.x... even the current comment indicates that a higher version is recommended:

depends 'chef_handler', '~> 1.1' # We recommend '~> 1.3' with Chef < 12. See CHANGELOG.md for details

See https://github.com/DataDog/chef-datadog/blob/master/metadata.rb#L25

@olivielpeau

This comment has been minimized.

Copy link
Member

commented Aug 9, 2016

@volker-fr ~> 1.1 basically means ['>= 1.1', '< 2.0'] (see http://guides.rubygems.org/patterns/#declaring-dependencies)

You should try updating your cookbook dependencies (if you're using berks, berks update chef_handler should do the trick)

@volker-fr

This comment has been minimized.

Copy link

commented Aug 9, 2016

@olivielpeau: thanks, mixed it up with ~> 1.1.1 which wouldn't allow versions such as 1.2

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.