Browse files

use notify{} instead of fail, to be less invasive

  • Loading branch information...
1 parent c51494a commit adee13097018be746aa86935d5ae642c236fac3d @robbyt robbyt committed Dec 20, 2011
Showing with 3 additions and 3 deletions.
  1. +1 −1 manifests/init.pp
  2. +2 −2 manifests/params.pp
View
2 manifests/init.pp
@@ -35,7 +35,7 @@
case $operatingsystem {
"Ubuntu","Debian": { include datadog::ubuntu }
"RedHat","CentOS","Fedora": { include datadog::redhat }
- default: { fail("The DataDog module only support Red Hat and Ubuntu derivatives") }
+ default: { notify{'Unsupported OS': message => 'The DataDog module only support Red Hat and Ubuntu derivatives'} }
}
file { "/etc/dd-agent":
View
4 manifests/params.pp
@@ -15,7 +15,7 @@
# Sample Usage:
#
class datadog::params {
- $api_key = "key"
+ $api_key = "your API key"
$dd_url = "https://app.datadoghq.com"
case $operatingsystem {
@@ -27,7 +27,7 @@
$rubygems_package = 'rubygems'
$report_packages = ['ruby-devel']
}
- default: { fail("The DataDog module only support Red Hat and Ubuntu derivatives") }
+ default: { notify{'Unsupported OS': message => 'The DataDog module only support Red Hat and Ubuntu derivatives'} }
}
}

0 comments on commit adee130

Please sign in to comment.