Skip to content
Permalink
Browse files

Removed: Can no longer initialise Scroller using the `S` option in `-…

…init dom`. Use `-init scroller` instead.
  • Loading branch information...
Allan Jardine
Allan Jardine committed Jul 30, 2018
1 parent 0f7cfc3 commit 28f75547db9eb813368c44869d091b3a261df0ad
Showing with 0 additions and 21 deletions.
  1. +0 −21 js/dataTables.scroller.js
@@ -1204,27 +1204,6 @@ Scroller.version = "2.0.0-dev";
* Initialisation
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * */

// Legacy `dom` parameter initialisation support
if ( typeof $.fn.dataTable == "function" &&
typeof $.fn.dataTableExt.fnVersionCheck == "function" &&
$.fn.dataTableExt.fnVersionCheck('1.10.0') )
{
$.fn.dataTableExt.aoFeatures.push( {
"fnInit": function( oDTSettings ) {
var init = oDTSettings.oInit;
var opts = init.scroller || init.oScroller || {};

new Scroller( oDTSettings, opts );
},
"cFeature": "S",
"sFeature": "Scroller"
} );
}
else
{
alert( "Warning: Scroller requires DataTables 1.10.0 or greater - www.datatables.net/download");
}

// Attach a listener to the document which listens for DataTables initialisation
// events so we can automatically initialise
$(document).on( 'preInit.dt.dtscroller', function (e, settings) {

0 comments on commit 28f7554

Please sign in to comment.
You can’t perform that action at this time.