Permalink
Browse files

Fixed for travis

  • Loading branch information...
1 parent 386e4cd commit ced071f1440ef82d1506aeb10571b73b3c002e81 @bcardarella bcardarella committed Aug 13, 2012
Showing with 27 additions and 13 deletions.
  1. +4 −7 .travis.yml
  2. +3 −3 Gemfile
  3. +8 −2 Rakefile
  4. +1 −0 capybara-email.gemspec
  5. +11 −1 spec/spec_helper.rb
View
@@ -1,11 +1,8 @@
rvm:
- 1.8.7
- - 1.9.2
- 1.9.3
- ree
- - jruby
- - rbx
-before_install:
- - gem update --system
- - gem install bundler --pre
-script: "bundle exec rspec spec/"
+ - jruby-18mode
+ - jruby-19mode
+ - rbx-18mode
+ - rbx-19mode
View
@@ -1,6 +1,6 @@
source 'https://rubygems.org'
-# Specify your gem's dependencies in capybara-email.gemspec
+if RUBY_VERSION >= '1.9.2' && RUBY_DESCRIPTION[0..3] == 'ruby'
+ gem 'debugger'
+end
gemspec
-
-gem 'rake'
View
@@ -1,2 +1,8 @@
-#!/usr/bin/env rake
-require "bundler/gem_tasks"
+require 'bundler'
+require 'rspec/core/rake_task'
+Bundler::GemHelper.install_tasks
+
+RSpec::Core::RakeTask.new('default') do |t|
+ t.pattern = FileList['spec/**/*_spec.rb']
+end
+
View
@@ -19,4 +19,5 @@ Gem::Specification.new do |gem|
gem.add_development_dependency 'capybara'
gem.add_development_dependency 'bourne'
gem.add_development_dependency 'rspec'
+ gem.add_development_dependency 'rake'
end
View
@@ -1,4 +1,14 @@
-require 'rspec'
+require 'rubygems'
+begin
+ require 'debugger'
+rescue LoadError
+end
+require 'bundler/setup'
+
+RSpec.configure do |config|
+ config.mock_with :mocha
+end
+
require 'mail'
require 'bourne'
require 'action_mailer'

0 comments on commit ced071f

Please sign in to comment.