Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

special characters it does not works #279

Closed
hyperrjas opened this Issue Feb 18, 2012 · 9 comments

Comments

Projects
None yet
2 participants

I have this regex:

validates_format_of :content, :with => /^[\p{L}\s\p{N}._@-]+$/u

characters ñ,áéíóú are unrecognized.

you can see it working fine in http://www.rubular.com/r/BZ4CyHCwpP

How can I add this characters?

Thank you!

Contributor

bcardarella commented Feb 18, 2012

Is your file in UTF-8 mode?

I'm using in my model # encoding: utf-8

but it does not works :(.

Contributor

bcardarella commented Feb 18, 2012

can you gist the resulting html?

I have this head in my aplication.html.erb layout.

https://gist.github.com/1859398

Contributor

bcardarella commented Feb 18, 2012

If you're not going to give me what I ask for I cannot help you. I need the resulting HTML from the form

Sorry I have pasted form html from firebug. do you need this?

https://gist.github.com/1859398

Thank you!

Contributor

bcardarella commented Feb 18, 2012

I don't care about fire bug. Just copy/paste the entire html into gist. This is not what I need. Please do as I ask.

I have copy/pate now the new.html.erb file is this that you need? sorry for I dont understand...

https://gist.github.com/1859398

Contributor

bcardarella commented Feb 18, 2012

I'm closing this issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment