Permalink
Browse files

Removing Jeweler. Too many problems.

  • Loading branch information...
1 parent 3f9faaa commit 35dcbf7f0ba9a99ac567c3b441bad332a32dc52d @russ russ committed Dec 5, 2011
Showing with 35 additions and 153 deletions.
  1. +0 −2 .bundle/config
  2. +4 −22 .gitignore
  3. +2 −11 Gemfile
  4. +11 −33 Rakefile
  5. +0 −1 VERSION
  6. +15 −84 lacquer.gemspec
  7. +3 −0 lib/lacquer/version.rb
View
@@ -1,2 +0,0 @@
---- {}
-
View
@@ -1,22 +1,4 @@
-## MAC OS
-.DS_Store
-
-## TEXTMATE
-*.tmproj
-tmtags
-
-## EMACS
-*~
-\#*
-.\#*
-
-## VIM
-*.swp
-
-## PROJECT::GENERAL
-coverage
-rdoc
-pkg
-doc
-.yardoc
-Gemfile.lock
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
View
13 Gemfile
@@ -1,12 +1,3 @@
-source 'http://rubygems.org'
+source "http://rubygems.org"
-gem "activesupport", ">= 2.3"
-gem "i18n", "~> 0.4"
-gem "jeweler", "1.6.4"
-gem "rake"
-gem "yard"
-gem "erubis"
-
-group :test do
- gem "rspec", "~> 2.5", :require => false
-end
+gemspec
View
@@ -1,37 +1,15 @@
-# encoding: UTF-8
-require "rubygems"
-require "bundler/setup"
-
-require "rake"
-require "yard"
-require "rspec"
-require "rspec/core/rake_task"
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "lacquer"
- gem.summary = %Q{Rails drop in for Varnish support.}
- gem.description = %Q{Rails drop in for Varnish support.}
- gem.email = "russ@bashme.org"
- gem.homepage = "http://github.com/russ/lacquer"
- gem.authors = ["Russ Smith (russ@bashme.org)", "Ryan Johns", "Garry Tan (garry@posterous.com), Gabe da Silveira (gabe@websaviour.com)", "Håkon Lerring"]
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
+require 'bundler/gem_tasks'
+require 'rake'
+require 'rspec/core/rake_task'
+
+namespace :spec do
+ RSpec::Core::RakeTask.new(:normal) do |t|
+ t.pattern ='spec/**/*_spec.rb'
+ t.rcov = false
end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
end
-desc "Run all examples"
-RSpec::Core::RakeTask.new(:spec) do |t|
- t.rspec_path = "rspec"
- t.rspec_opts = %w[--color]
-end
-
-YARD::Rake::YardocTask.new do |t|
- t.files = [ "lib/**/*.rb" ]
- t.options = [ "--no-private" ]
-end
+desc "RSpec tests"
+task "spec" => "spec:normal"
-task :default => [ :spec ]
+task "default" => "spec"
View
@@ -1 +0,0 @@
-0.5.3
View
@@ -1,93 +1,24 @@
-# encoding: UTF-8
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "lacquer/version"
Gem::Specification.new do |s|
s.name = "lacquer"
- s.version = "0.5.3"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.version = Lacquer::VERSION
s.authors = ["Russ Smith (russ@bashme.org)", "Ryan Johns", "Garry Tan (garry@posterous.com), Gabe da Silveira (gabe@websaviour.com)", "H\u{e5}kon Lerring"]
- s.date = "2011-12-01"
- s.description = "Rails drop in for Varnish support."
s.email = "russ@bashme.org"
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".bundle/config",
- ".document",
- "Gemfile",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "init.rb",
- "lacquer.gemspec",
- "lib/generators/lacquer/USAGE",
- "lib/generators/lacquer/install_generator.rb",
- "lib/generators/lacquer/templates/initializer.rb",
- "lib/generators/lacquer/templates/varnish.vcl.erb",
- "lib/generators/lacquer/templates/varnishd.yml",
- "lib/lacquer.rb",
- "lib/lacquer/cache_control.rb",
- "lib/lacquer/cache_utils.rb",
- "lib/lacquer/capistrano.rb",
- "lib/lacquer/configuration.rb",
- "lib/lacquer/delayed_job_job.rb",
- "lib/lacquer/railtie.rb",
- "lib/lacquer/recipes.rb",
- "lib/lacquer/resque_job.rb",
- "lib/lacquer/tasks.rb",
- "lib/lacquer/varnish.rb",
- "lib/lacquer/varnishd.rb",
- "rails/init.rb",
- "recipes/lacquer.rb",
- "spec/config/generate.vcl.erb",
- "spec/config/varnish.vcl",
- "spec/config/varnishd.yml",
- "spec/lacquer/cache_control_spec.rb",
- "spec/lacquer/cache_utils_spec.rb",
- "spec/lacquer/delayed_job_job_spec.rb",
- "spec/lacquer/resque_job_spec.rb",
- "spec/lacquer/varnish_spec.rb",
- "spec/lacquer/varnishd_spec.rb",
- "spec/spec_helper.rb",
- "tasks/lacquer.rake"
- ]
s.homepage = "http://github.com/russ/lacquer"
- s.require_paths = ["lib"]
- s.rubygems_version = "1.8.10"
s.summary = "Rails drop in for Varnish support."
-
- if s.respond_to? :specification_version then
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<activesupport>, [">= 2.3"])
- s.add_runtime_dependency(%q<i18n>, ["~> 0.4"])
- s.add_runtime_dependency(%q<jeweler>, ["= 1.6.4"])
- s.add_runtime_dependency(%q<rake>, [">= 0"])
- s.add_runtime_dependency(%q<yard>, [">= 0"])
- s.add_runtime_dependency(%q<erubis>, [">= 0"])
- else
- s.add_dependency(%q<activesupport>, [">= 2.3"])
- s.add_dependency(%q<i18n>, ["~> 0.4"])
- s.add_dependency(%q<jeweler>, ["= 1.6.4"])
- s.add_dependency(%q<rake>, [">= 0"])
- s.add_dependency(%q<yard>, [">= 0"])
- s.add_dependency(%q<erubis>, [">= 0"])
- end
- else
- s.add_dependency(%q<activesupport>, [">= 2.3"])
- s.add_dependency(%q<i18n>, ["~> 0.4"])
- s.add_dependency(%q<jeweler>, ["= 1.6.4"])
- s.add_dependency(%q<rake>, [">= 0"])
- s.add_dependency(%q<yard>, [">= 0"])
- s.add_dependency(%q<erubis>, [">= 0"])
- end
+ s.description = "Rails drop in for Varnish support."
+ s.rubyforge_project = "lacquer"
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+ s.add_dependency('activesupport', '>= 2.3.10')
+ s.add_dependency('i18n', '~> 0.4')
+ s.add_dependency('erubis')
+ s.add_development_dependency('rake')
+ s.add_development_dependency('rspec', '~> 2.5')
+ s.add_development_dependency('yard')
end
-
View
@@ -0,0 +1,3 @@
+module Lacquer
+ VERSION = '0.5.4'
+end

0 comments on commit 35dcbf7

Please sign in to comment.