Skip to content
Branch: master
Clone or download
DenysVuika Merge pull request #4 from hanskerkhof/fix-depreciated-template
Changed to 'ng-template' in tlist.component.* since 'template' is depreciated since Angular v4.0.0-rc.1
Latest commit 9fdd1c5 Aug 1, 2017
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.vscode initial project structure Nov 24, 2016
app fix ng-template Aug 1, 2017
.gitignore initial project structure Nov 24, 2016
LICENSE initial project structure Nov 24, 2016
README.md update readme Jul 21, 2017
index.html initial project structure Nov 24, 2016
package-lock.json update angular to 4.3.1 Jul 21, 2017
package.json update angular to 4.3.1 Jul 21, 2017
systemjs.config.js initial project structure Nov 24, 2016
tsconfig.json initial project structure Nov 24, 2016
yarn.lock update angular to 4.3.1 Jul 21, 2017

README.md

Dynamic Content with Angular (examples)

Contains examples project for the article Dynamic Content with Angualar 2

Prerequisites

Node.js and npm are essential to Angular development.

Get it now if it's not already installed on your machine.

Verify that you are running at least node v5.x.x and npm 3.x.x by running node -v and npm -v in a terminal/console window. Older versions produce errors.

Running

git clone https://github.com/DenisVuyka/ng2-dynamic-content
cd ng2-dynamic-content

Install npm packages

See npm and nvm version notes above

Install the npm packages described in the package.json and verify that it works:

Attention Windows Developers: You must run all of these commands in administrator mode.

npm install
npm start

The npm start command first compiles the application, then simultaneously re-compiles and runs the wsrv web server. Both the compiler and the server watch for file changes.

Shut it down manually with Ctrl-C.

You can’t perform that action at this time.