New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Setting OpenGL version needs to be before window creation #27

Closed
MatthewFrench opened this Issue Feb 24, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@MatthewFrench

MatthewFrench commented Feb 24, 2015

SDL_GL_SetAttribute(SDL_GL_CONTEXT_MAJOR_VERSION, 3);
SDL_GL_SetAttribute(SDL_GL_CONTEXT_MINOR_VERSION, 0);
SDL_GL_SetAttribute(SDL_GL_CONTEXT_PROFILE_MASK, SDL_GL_CONTEXT_PROFILE_CORE);
SDL_GL_SetAttribute(SDL_GL_CONTEXT_FLAGS, SDL_GL_CONTEXT_FORWARD_COMPATIBLE_FLAG);

They are after window creation.

@Dgame

This comment has been minimized.

Owner

Dgame commented Feb 24, 2015

Should be fixed. New tag is published, Manual update is triggered on DUB.

@Dgame Dgame closed this Feb 24, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment