New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ubuntu install issue -- env output: /bin/sh: 1: gosublime.r13.03.03-1.margo.exe: not found #213

Closed
srid opened this Issue Mar 14, 2013 · 5 comments

Comments

Projects
None yet
4 participants
@srid
Copy link

srid commented Mar 14, 2013

sublime text 3 (beta) on ubuntu 12.10

install log ends with:

** 2013-03-13 21:08:55.624651 **:
MarGo: Cannot load env vars: Decode Error: No JSON object could be decoded
env output: /bin/sh: 1: gosublime.r13.03.03-1.margo.exe: not found
@srid

This comment has been minimized.

Copy link

srid commented Mar 14, 2013

later when i attempt to edit .go files

** 2013-03-13 21:15:09.877581 **:
MarGo: Cannot start MarGo: Error running command ['/home/sridharr/.config/sublime-text-3/Packages/User/GoSublime/9/bin/gosublime.r13.03.03-1.margo.exe', '-poll=30']: GoSublime: Traceback (most recent call last):
  File "/home/sridharr/.config/sublime-text-3/Installed Packages/GoSublime.sublime-package/gosubl/gsshell.py", line 90, in proc
    bufsize=bufsize
  File "X/subprocess.py", line 818, in __init__
  File "X/subprocess.py", line 1416, in _execute_child
FileNotFoundError: [Errno 2] No such file or directory: '/home/sridharr/.config/sublime-text-3/Packages/User/GoSublime/9/bin/gosublime.r13.03.03-1.margo.exe'
--------------------------------

strange that an .exe file is being executed ...

@DisposaBoy

This comment has been minimized.

Copy link
Owner

DisposaBoy commented Mar 16, 2013

When this happens, you should a spinning semi-circle in the status bar. it means that GS is still compiling margo, hopefully it shouldn't take too long then when it stops, you will get some output like the follow. if there are no errors after that then I'll consider this a part of #185

GoSublime init (3.366s)
| install margo: ok 3.311s
|        version: r13.03.16-1
@balkamm

This comment has been minimized.

Copy link

balkamm commented Mar 18, 2013

I guess you beat me to it but this is probably the same as issue #214

@anacrolix

This comment has been minimized.

Copy link

anacrolix commented Mar 20, 2013

I get this too, here's some more log details:

** 2013-03-20 13:22:14.352214 **:
MarGo: Cannot load env vars: Decode Error: No JSON object could be decoded
env output: /bin/sh: 1: gosublime.r13.03.16-2.margo.exe: not found
--------------------------------


** 2013-03-20 13:22:14.353674 **:
GoSublime init (0.377s)
| install margo: can't load package: package .: no Go source files in /home/mjoiner/.config/sublime-text-3/Packages/GoSublime/margo9
|        version: r13.03.16-2
|           ~bin: /home/mjoiner/.config/sublime-text-3/Packages/User/GoSublime/9/bin
|          MarGo: ~bin/gosublime.r13.03.16-2.margo.exe (missing)
|         GOROOT: /home/mjoiner/src/go
|         GOPATH: /home/mjoiner/gopath
|          GOBIN: (not set) (should usually be `(not set)`)
--------------------------------

reloading Packages/User/GoSublime-aux.sublime-settings
Unable to open /home/mjoiner/.config/sublime-text-3/Packages/GoSublime/CHANGELOG.md
@DisposaBoy

This comment has been minimized.

Copy link
Owner

DisposaBoy commented Mar 23, 2013

i'm assuming this was the same as #214, if not, feel free to re-open

@DisposaBoy DisposaBoy closed this Mar 23, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment