Check if connection responds to #supports_extensions? #61

Merged
merged 1 commit into from Feb 14, 2013

Conversation

Projects
None yet
2 participants
Contributor

vongruenigen commented Feb 7, 2013

Just added a check if @connection responds to supports_extensions? before calling it. This prevents errors if you have postgres_ext in your Gemfile but you're still using another database (e.g. SQLite3 in our case).

@danmcclain danmcclain added a commit that referenced this pull request Feb 14, 2013

@danmcclain danmcclain Merge pull request #61 from ncoders/master
Check if connection responds to #supports_extensions?
1167b57

@danmcclain danmcclain merged commit 1167b57 into DockYard:master Feb 14, 2013

1 check passed

default The Travis build passed
Details
Contributor

danmcclain commented Feb 14, 2013

Thanks, although I would argue that if you aren't using postgres_ext in dev or test, it should be in the correct group in your Gemfile

Contributor

vongruenigen commented Feb 15, 2013

We're currently in the progress of switching the database of our customer installations from SQLite to Postgres, that's the reason why we currently have both database adapters in our Gemfile.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment