Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Updated mysql dependency

For some reason specifying "0.9.x" for mysql version pulled only their
latest branch (0.9.0) and not the latest tag (0.9.6).

I was receiving this error from 0.9.0:

> /home/mdwyer/Desktop/src/TAMU-btsync/iris/tamu-ldap-proxy/node_modules/node-dbi/node_modules/mysql/lib/mysql/net_constan
> ts.js:8
> module.exports = process.binding('net');
>                          ^
> Error: No such module
>     at Object.<anonymous> (/home/mdwyer/Desktop/src/TAMU-btsync/iris/tamu-ldap-proxy/node_modules/node-dbi/node_modules/
> mysql/lib/mysql/net_constants.js:8:26)
>     at Module._compile (module.js:449:26)
>     at Object.Module._extensions..js (module.js:467:10)
>     at Module.load (module.js:356:32)
>     at Function.Module._load (module.js:312:12)
>     at Module.require (module.js:362:17)
>     at require (module.js:378:17)
>     at Object.<anonymous> (/home/mdwyer/Desktop/src/TAMU-btsync/iris/tamu-ldap-proxy/node_modules/node-dbi/node_modules/
> mysql/lib/mysql/client.js:10:20)
>     at Module._compile (module.js:449:26)
>     at Object.Module._extensions..js (module.js:467:10)
>

This is fixed in
[1928c78](felixge/node-mysql@1928c78).
  • Loading branch information...
commit 0b3bd876780699a626dce5a81f482e99095d0672 1 parent 798c8ab
Michael Dwyer kalifg authored
Showing with 2 additions and 2 deletions.
  1. +2 −2 package.json
4 package.json
View
@@ -27,7 +27,7 @@
},
"optionalDependencies": {
"mysql-libmysqlclient": "1.3.x",
- "mysql": "0.9.x",
+ "mysql": "0.9.6",
"sqlite3": "2.1.x",
"pg": "0.8.x"
},
@@ -35,7 +35,7 @@
"test": "node test/all.js"
},
"keywords": [
- "database", "SQL", "abstraction", "common", "mysql", "sqlite", "pg",
+ "database", "SQL", "abstraction", "common", "mysql", "sqlite", "pg",
"postgres", "postgresql"
],
"engines": {
Please sign in to comment.
Something went wrong with that request. Please try again.