Skip to content

EC-CUBE/eccube-api4

master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

EC-CUBE4 対応の Web API プラグイン

Packaging for EC-CUBE Plugin

外部サービスと連携するため、GraphQL による Web API 機能を実現します。

本プラグインの利用には EC-CUBE 4.0.5 以上へのアップデートが必要になる予定です。 ほんプラグインおよびEC-CUBEのリリーススケジュールはEC-CUBE 4.1 Roadmapをご確認ください。

より良い Web API とするため Issue や PullRequest にてフィードバック/開発協力を募集しています。

インストール

EC-CUBE 4.0のインストール方法

EC-CUBE4 Web API プラグイン 開発ドキュメント の手順に従ってインストールしてください。

動作確認環境

  • PHP 7.2 or higher
  • PostgreSQL or MySQL
  • SSLサーバー証明書(TLS) は必須

詳しくは EC-CUBE4 Web API プラグイン 開発ドキュメント をご確認ください。