Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

unable to find plugin: eosio::wallet_api_plugin #7833

Closed
limchienhoo opened this issue Aug 30, 2019 · 3 comments

Comments

@limchienhoo
Copy link

commented Aug 30, 2019

A new developer of EOSIO,hope some help!

programming environment:
win10-pro+ubuntu18.04LTS+eosio_1.8.1

sudo apt install ./eosio_1.8.1-1-ubuntu-18.04_amd64.deb
cleos --help
nodeos --help
keosd --help

All above was certained to be correct.
when I went to run eosio,it ecurred error like follow:

lim@PC-201908291114:/home$ nodeos -e -p eosio --plugin eosio::wallet_api_plugin --plugin eosio::chain_api_plugin --plugin eosio::account_history_api_plugin

error 2019-08-30T10:35:12.304 nodeos main.cpp:120 main ] /home/cicd/eos/libraries/appbase/application.cpp(435): Throw in function appbase::abstract_plugin &appbase::application::get_plugin(const std::__1::string &) const
Dynamic exception type: boost::wrapexceptstd::runtime_error
std::exception::what: unable to find plugin: eosio::wallet_api_plugin

@heifner

This comment has been minimized.

Copy link
Contributor

commented Aug 30, 2019

wallet_api_plugin is no longer supported as part of nodeos. Use keosd instead.
https://developers.eos.io/keosd/docs

@heifner heifner closed this Aug 30, 2019
@limchienhoo

This comment has been minimized.

Copy link
Author

commented Aug 30, 2019

so how can i run nodeos?

@heifner

This comment has been minimized.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.