Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Scheduled weekly dependency update for week 03 #41

Merged
merged 7 commits into from Jan 28, 2018

Conversation

Projects
None yet
2 participants
@pyup-bot
Copy link
Contributor

commented Jan 22, 2018

Updates

Here's a list of all the updates bundled in this pull request. I've added some links to make it easier for you to find all the information you need.

arrow 0.10.0 » 0.12.1 PyPI | Changelog | Repo
boto3 1.4.8 » 1.5.19 PyPI | Changelog | Repo
botocore 1.8.13 » 1.8.33 PyPI | Changelog | Repo
certifi 2017.11.5 » 2018.1.18 PyPI | Homepage
distro 1.1.0 » 1.2.0 PyPI | Changelog | Repo
raven[flask] 6.3.0 » 6.5.0 PyPI | Changelog | Repo
werkzeug 0.12.2 » 0.14.1 PyPI | Changelog | Homepage

Changelogs

arrow 0.10.0 -> 0.12.1

0.12.0

  • [FIX] Compatibility fix for Python 2.x

0.11.0

  • [FIX] Fix grammar of ArabicLocale
  • [NEW] Add Nepali Locale
  • [FIX] Fix month name + rename AustriaLocale -> AustrianLocale
  • [FIX] Fix typo in Basque Locale
  • [FIX] Fix grammar in PortugueseBrazilian locale
  • [FIX] Remove pip --user-mirrors flag
  • [NEW] Add Indonesian Locale

boto3 1.4.8 -> 1.5.19

1.5.19

======

  • api-change:glue: [botocore] Update glue client to latest version
  • api-change:transcribe: [botocore] Update transcribe client to latest version

1.5.18

======

  • api-change:sagemaker: [botocore] Update sagemaker client to latest version

1.5.17

======

  • api-change:ec2: [botocore] Update ec2 client to latest version
  • api-change:autoscaling-plans: [botocore] Update autoscaling-plans client to latest version

1.5.16

======

  • api-change:application-autoscaling: [botocore] Update application-autoscaling client to latest version
  • api-change:autoscaling-plans: [botocore] Update autoscaling-plans client to latest version
  • api-change:rds: [botocore] Update rds client to latest version

1.5.15

======

  • api-change:lambda: [botocore] Update lambda client to latest version
  • enhancement:cloudformation get_template template body ordering: [botocore] fixes boto/boto31378 <https://github.com/boto/boto3/issues/1378>__

1.5.14

======

  • api-change:glue: [botocore] Update glue client to latest version

1.5.13

======

  • api-change:ssm: [botocore] Update ssm client to latest version
  • api-change:elbv2: [botocore] Update elbv2 client to latest version
  • api-change:rds: [botocore] Update rds client to latest version
  • api-change:elb: [botocore] Update elb client to latest version

1.5.12

======

  • api-change:kms: [botocore] Update kms client to latest version

1.5.11

======

  • api-change:ds: [botocore] Update ds client to latest version

1.5.10

======

  • api-change:route53: [botocore] Update route53 client to latest version
  • api-change:discovery: [botocore] Update discovery client to latest version
  • api-change:codedeploy: [botocore] Update codedeploy client to latest version

1.5.9

=====

  • api-change:ssm: [botocore] Update ssm client to latest version
  • api-change:inspector: [botocore] Update inspector client to latest version
  • api-change:snowball: [botocore] Update snowball client to latest version

1.5.8

=====

  • api-change:rds: [botocore] Update rds client to latest version

1.5.7

=====

  • api-change:workspaces: [botocore] Update workspaces client to latest version

1.5.6

=====

  • api-change:ecs: [botocore] Update ecs client to latest version
  • api-change:ec2: [botocore] Update ec2 client to latest version
  • api-change:inspector: [botocore] Update inspector client to latest version
  • api-change:sagemaker: [botocore] Update sagemaker client to latest version

1.5.5

=====

  • api-change:ec2: [botocore] Update ec2 client to latest version
  • enhancement:Paginator: [botocore] Added paginator support for lambda list aliases operation.
  • api-change:kinesisanalytics: [botocore] Update kinesisanalytics client to latest version
  • api-change:codebuild: [botocore] Update codebuild client to latest version

1.5.4

=====

  • api-change:iot: [botocore] Update iot client to latest version
  • api-change:config: [botocore] Update config client to latest version

1.5.3

=====

  • api-change:route53: [botocore] Update route53 client to latest version
  • api-change:apigateway: [botocore] Update apigateway client to latest version
  • api-change:mediastore-data: [botocore] Update mediastore-data client to latest version

1.5.2

=====

  • bugfix:presigned-url: [botocore] Fixes a bug where content-type would be set on presigned requests for query services.
  • api-change:cloudwatch: [botocore] Update cloudwatch client to latest version

1.5.1

=====

  • api-change:appstream: [botocore] Update appstream client to latest version

1.5.0

=====

  • bugfix:Filters: Fixes a bug where parameters passed to resource collections could be mutated after the collections were created.
  • api-change:ses: [botocore] Update ses client to latest version
  • enhancement:credentials: [botocore] Moved the JSONFileCache from the CLI into botocore so that it can be used without importing from the cli.
  • feature:botocore dependency: Update dependency strategy to always take a floor on the most recent version of botocore. This means whenever there is a release of botocore, boto3 will release as well to account for the new version of botocore.
  • api-change:apigateway: [botocore] Update apigateway client to latest version

botocore 1.8.13 -> 1.8.33

1.8.33

======

  • api-change:glue: Update glue client to latest version
  • api-change:transcribe: Update transcribe client to latest version

1.8.32

======

  • api-change:sagemaker: Update sagemaker client to latest version

1.8.31

======

  • api-change:ec2: Update ec2 client to latest version
  • api-change:autoscaling-plans: Update autoscaling-plans client to latest version

1.8.30

======

  • api-change:application-autoscaling: Update application-autoscaling client to latest version
  • api-change:autoscaling-plans: Update autoscaling-plans client to latest version
  • api-change:rds: Update rds client to latest version

1.8.29

======

  • api-change:lambda: Update lambda client to latest version
  • enhancement:cloudformation get_template template body ordering: fixes boto/boto31378 <https://github.com/boto/boto3/issues/1378>__

1.8.28

======

  • api-change:glue: Update glue client to latest version

1.8.27

======

  • api-change:ssm: Update ssm client to latest version
  • api-change:elbv2: Update elbv2 client to latest version
  • api-change:rds: Update rds client to latest version
  • api-change:elb: Update elb client to latest version

1.8.26

======

  • api-change:kms: Update kms client to latest version

1.8.25

======

  • api-change:ds: Update ds client to latest version

1.8.24

======

  • api-change:route53: Update route53 client to latest version
  • api-change:discovery: Update discovery client to latest version
  • api-change:codedeploy: Update codedeploy client to latest version

1.8.23

======

  • api-change:ssm: Update ssm client to latest version
  • api-change:inspector: Update inspector client to latest version
  • api-change:snowball: Update snowball client to latest version

1.8.22

======

  • api-change:rds: Update rds client to latest version

1.8.21

======

  • api-change:workspaces: Update workspaces client to latest version

1.8.20

======

  • api-change:ecs: Update ecs client to latest version
  • api-change:ec2: Update ec2 client to latest version
  • api-change:inspector: Update inspector client to latest version
  • api-change:sagemaker: Update sagemaker client to latest version

1.8.19

======

  • api-change:ec2: Update ec2 client to latest version
  • enhancement:Paginator: Added paginator support for lambda list aliases operation.
  • api-change:kinesisanalytics: Update kinesisanalytics client to latest version
  • api-change:codebuild: Update codebuild client to latest version

1.8.18

======

  • api-change:iot: Update iot client to latest version
  • api-change:config: Update config client to latest version

1.8.17

======

  • api-change:route53: Update route53 client to latest version
  • api-change:apigateway: Update apigateway client to latest version
  • api-change:mediastore-data: Update mediastore-data client to latest version

1.8.16

======

  • bugfix:presigned-url: Fixes a bug where content-type would be set on presigned requests for query services.
  • api-change:cloudwatch: Update cloudwatch client to latest version

1.8.15

======

  • api-change:appstream: Update appstream client to latest version

1.8.14

======

  • api-change:ses: Update ses client to latest version
  • enhancement:credentials: Moved the JSONFileCache from the CLI into botocore so that it can be used without importing from the cli.
  • api-change:apigateway: Update apigateway client to latest version

distro 1.1.0 -> 1.2.0

1.2.0

  • Lazily load parsers to speed up import time.
  • Don't raise import error on non-linux os.
  • Decode stdout of shell sys.getfilesystemencoding().
  • Explicitly set Python versions for flake8 tests.

raven[flask] 6.3.0 -> 6.5.0

6.5.0


  • [Core] Fixed missing deprecation on processors.SanitizePasswordsProcessor
  • [Core] Improve exception handling in Serializer.transform
  • [Core] Fixed celery.register_logger_signal ignoring subclasses
  • [Core] Fixed sanitizer skipping byte instances
  • [Lambda] Fixed AttributeError when requestContext not present

6.4.0


  • [Core] Support for defining sanitized_keys on the client (pr/990)
  • [Django] Support for Django 2.0 Urlresolver
  • [Docs] Several fixes and improvements

werkzeug 0.12.2 -> 0.14.1

0.14.1


Released on December 31st 2017

  • Resolved a regression with status code handling in the integrated
    development server.

0.14


Released on December 31st 2017

  • HTTP exceptions are now automatically caught by
    Request.application.
  • Added support for edge as browser.
  • Added support for platforms that lack SpooledTemporaryFile.
  • Add support for etag handling through if-match
  • Added support for the SameSite cookie attribute.
  • Added werkzeug.wsgi.ProxyMiddleware
  • Implemented has for NullCache
  • get_multi on cache clients now returns lists all the time.
  • Improved the watchdog observer shutdown for the reloader to not crash
    on exit on older Python versions.
  • Added support for filename* filename attributes according to
    RFC 2231
  • Resolved an issue where machine ID for the reloader PIN was not
    read accurately on windows.
  • Added a workaround for syntax errors in init files in the reloader.
  • Added support for using the reloader with console scripts on windows.
  • The built-in HTTP server will no longer close a connection in cases
    where no HTTP body is expected (204, 204, HEAD requests etc.)
  • The EnvironHeaders object now skips over empty content type and
    lengths if they are set to falsy values.
  • Werkzeug will no longer send the content-length header on 1xx or
    204/304 responses.
  • Cookie values are now also permitted to include slashes and equal
    signs without quoting.
  • Relaxed the regex for the routing converter arguments.
  • If cookies are sent without values they are now assumed to have an
    empty value and the parser accepts this. Previously this could have
    corrupted cookies that followed the value.
  • The test Client and EnvironBuilder now support mimetypes like
    the request object does.
  • Added support for static weights in URL rules.
  • Better handle some more complex reloader scenarios where sys.path
    contained non directory paths.
  • EnvironHeaders no longer raises weird errors if non string keys
    are passed to it.

0.13


Released on December 7th 2017

  • Deprecate support for Python 2.6 and 3.3. CI tests will not run
    for these versions, and support will be dropped completely in the next
    version. (pallets/meta24_)
  • Raise TypeError when port is not an integer. (1088_)
  • Fully deprecate werkzeug.script. Use Click_ instead. (1090_)
  • response.age is parsed as a timedelta. Previously, it was
    incorrectly treated as a datetime. The header value is an integer
    number of seconds, not a date string. (414_)
  • Fix a bug in TypeConversionDict where errors are not propagated
    when using the converter. (1102_)
  • Authorization.qop is a string instead of a set, to comply with
    RFC 2617. (984_)
  • An exception is raised when an encoded cookie is larger than, by
    default, 4093 bytes. Browsers may silently ignore cookies larger than
    this. BaseResponse has a new attribute max_cookie_size and
    dump_cookie has a new argument max_size to configure this.
    (780, 1109)
  • Fix a TypeError in werkzeug.contrib.lint.GuardedIterator.close.
    (1116_)
  • BaseResponse.calculate_content_length now correctly works for
    Unicode responses on Python 3. It first encodes using
    iter_encoded. (705_)
  • Secure cookie contrib works with string secret key on Python 3.
    (1205_)
  • Shared data middleware accepts a list instead of a dict of static
    locations to preserve lookup order. (1197_)
  • HTTP header values without encoding can contain single quotes.
    (1208_)
  • The built-in dev server supports receiving requests with chunked
    transfer encoding. (1198_)

.. _Click: https://www.palletsprojects.com/p/click/
.. _pallets/meta24: pallets/meta#24
.. _414: pallets/werkzeug#414
.. _705: pallets/werkzeug#705
.. _780: pallets/werkzeug#780
.. _984: pallets/werkzeug#984
.. _1088: pallets/werkzeug#1088
.. _1090: pallets/werkzeug#1090
.. _1102: pallets/werkzeug#1102
.. _1109: pallets/werkzeug#1109
.. _1116: pallets/werkzeug#1116
.. _1197: pallets/werkzeug#1197
.. _1198: pallets/werkzeug#1198
.. _1205: pallets/werkzeug#1205
.. _1208: pallets/werkzeug#1208

That's it for now!

Happy merging! 🤖

@codecov

This comment has been minimized.

Copy link

commented Jan 22, 2018

Codecov Report

Merging #41 into master will not change coverage.
The diff coverage is n/a.

Impacted file tree graph

@@           Coverage Diff           @@
##           master      #41   +/-   ##
=======================================
  Coverage   69.58%   69.58%           
=======================================
  Files           8        8           
  Lines         720      720           
=======================================
  Hits          501      501           
  Misses        219      219

Continue to review full report at Codecov.

Legend - Click here to learn more
Δ = absolute <relative> (impact), ø = not affected, ? = missing data
Powered by Codecov. Last update bffd6ac...b6a2467. Read the comment docs.

@joelb123 joelb123 merged commit 2117d0c into master Jan 28, 2018

6 checks passed

Codacy/PR Quality Review Good work! A positive pull request.
Details
codecov/patch Coverage not affected when comparing bffd6ac...b6a2467
Details
codecov/project 69.58% remains the same compared to bffd6ac
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
pyup.io/safety-ci No dependencies with known security vulnerabilities.
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.