New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Support multiple PHP versions #245

Open
kirtangajjar opened this Issue Nov 29, 2018 · 1 comment

Comments

2 participants
@kirtangajjar
Copy link
Member

kirtangajjar commented Nov 29, 2018

Many projects rely on a specific version of PHP and do not run on newer versions. i.e. https://community.easyengine.io/t/install-and-apply-php-7-1-on-the-v4-version/11517

EasyEngine should allow creating sites in all minor PHP versions from 5.4 onwards (5.4, 5.6, 7.0, 7.1...)

Seeing the pace at which PHP is progressing, it seems there might be more features getting deprecated in future. Hence, such use cases of using specific versions of PHP will increase. So it seems like a good idea to have it in the core.

@kirtangajjar kirtangajjar added this to To do in v4.1 and Later via automation Nov 29, 2018

@othaner

This comment has been minimized.

Copy link

othaner commented Jan 17, 2019

I have same issue with just one site, it requires PHP 7.0. :(

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment