Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[RM2kE Bug] Element with E rate negative % bug #1391

Closed
Albeleon opened this issue Jul 5, 2018 · 7 comments · Fixed by #2329
Closed

[RM2kE Bug] Element with E rate negative % bug #1391

Albeleon opened this issue Jul 5, 2018 · 7 comments · Fixed by #2329

Comments

@Albeleon
Copy link
Member

Albeleon commented Jul 5, 2018

Platform: RPG Maker 2000 v1.62 (Windows)

Description:

  1. There is the option of changing the E rate of an element to less than 0% with the purpose of absorbing damage. It's even included in the manual: https://i.imgur.com/0gOXXTM.png https://imgur.com/UawGdqv
  2. However, when you attack an enemy with E rate with that element in those conditions, the damage is like it was 100% damage. It doesn't matter if it's -1%, -100% or -999%.

How to reproduce it:

  1. Create an element with E rating less than 0%.
  2. Put an enemy with E to that state and a player character that can attack or skill with only that state.
  3. Fight and throw that skill to the enemy. Compare with other values.

Videos:

@Ghabry
Copy link
Member

Ghabry commented Jul 5, 2018

@CherryDT: RPG_RT documentation vs. implementation mismatch?

@Ghabry Ghabry changed the title [RM2kE] Element with E rate negative % bug [RM2kE Bug] Element with E rate negative % bug Jul 5, 2018
@Ghabry Ghabry added Battle Needs feedback Waiting for the issue author to give further information. labels Jul 5, 2018
@CherryDT
Copy link

CherryDT commented Jul 5, 2018

Possibly a bug...! Thanks for the info

@Ghabry Ghabry removed the Needs feedback Waiting for the issue author to give further information. label Jul 5, 2018
@fmatthew5876
Copy link
Contributor

Also leaving a note that we don't implement this in 2k3 battle system yet.

@ghost
Copy link

ghost commented Aug 29, 2020

I know from older RPG Maker 2000 versions that negative attribute rates are not supported and can I confirm that negative attribute rates are always interpreted as 100% which makes the attacks do normal damage. The video shows that the feature is still not supported in version 1.62 which means that the documentation has an error. And the RPG Maker 2000 changelog doesn't even mention that feature. So it looks like that negative attribute rates are only supported in RPG Maker 2003.

@CherryDT
Copy link

We probably didn't realize that this feature isn't working in 2k. We translated and reformatted the 2k3 help file and for 2k we copied everything from the 2k3 translation which we believed was the same in both and modified only what we believed was different.

@Ghabry Ghabry added this to the 0.6.3 milestone Sep 10, 2020
@Ghabry Ghabry assigned ghost Sep 10, 2020
@ghost
Copy link

ghost commented Sep 23, 2020

This issue should be fixed now. Negative attribute rates are implemented now and RPG Maker 2000 does not support them.

@Ghabry
Copy link
Member

Ghabry commented Sep 23, 2020

@rueter37
Please write next time "Fix #issuenumber" in the commit message or in the Github PR message. Thanks.
Makes the maintanance easier :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Development

Successfully merging a pull request may close this issue.

5 participants