Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Android: migrate from deprecated support library to AndroidX #2018

Closed
carstene1ns opened this issue Dec 27, 2019 · 5 comments · Fixed by #2261
Closed

Android: migrate from deprecated support library to AndroidX #2018

carstene1ns opened this issue Dec 27, 2019 · 5 comments · Fixed by #2261

Comments

@carstene1ns
Copy link
Member

https://developer.android.com/jetpack/androidx/migrate

@BlisterB
Copy link
Member

BlisterB commented Jul 3, 2020

I can watch for that, but preferably after my PR are processed (this seems to be a big subject, source for many conflicts and problems).

I'm discovering the topic but we will probably have to change the minimum API.
At the time I targeted API 10 (which was already overkilled at the time). It brought a lot of constraints but it will be the opportunity to do/redo a lot of nice things.

For information:

Capture d’écran 2020-07-03 à 10 59 55

Capture d’écran 2020-07-03 à 11 02 01

@BlisterB
Copy link
Member

BlisterB commented Jul 3, 2020

@fdelapena Do we have the distribution of Android versions using the app ?

@Ghabry
Copy link
Member

Ghabry commented Jul 3, 2020

@BlisterB right now we target API 15 as the NDK dropped support a while ago for older version.

@Ghabry
Copy link
Member

Ghabry commented Jul 3, 2020

@BlisterB in the ongoing approach of Google to make there Uis more crap it is not possible anymore in the Android console to plot more than 5 Android versions at once m(. In general they made all the statistic stuff really bad and hard to use... (and of course no CSV export)

Copy paste from the website: (List of active devices [last 30 days online])

Alle Android-Versionen | 20.908
-- | --
  | Android 9 | 6.706
  | Android 10 | 6.089
  | Android 8.0 | 1.719
  | Android 8.1 | 1.511
  | Android 7.0 | 1.365
  | Android 6.0 | 1.167
  | Android 7.1 | 751
  | Android 5.1 | 607
  | Android 4.4 | 513
  | Android 5.0 | 294
  | Android 4.2 | 93
  | Android 4.1 | 52
  | Android 4.3 | 19
  | Android 4.0.3 - 4.0.4 | 8
  | Android 2.3.3 - 2.3.7 | 4

@BlisterB
Copy link
Member

BlisterB commented Jul 3, 2020

@Ghabry Thank you for the information.

I've been able to migrate to AndroidX without too many problems. I didn't have to change the minimum API (currently set to 14).

@carstene1ns carstene1ns added this to the 0.6.3 milestone Jul 6, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Development

Successfully merging a pull request may close this issue.

4 participants