New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Battle/2k3: actor placement is wrong #851

Closed
carstene1ns opened this Issue Mar 28, 2016 · 5 comments

Comments

Projects
None yet
3 participants
@carstene1ns
Member

carstene1ns commented Mar 28, 2016

bug
Game: "Space Funeral: EARTH BIRTH" (http://duckstapler.com/earthbirth.html)
To reproduce, run battle 41, either through battle test, or attached save game.

Expected:
RPG_RT

Issue reported by mail.


At first I thought this would be related to #278, but the actors have all coordinates set here.

@Ghabry

This comment has been minimized.

Show comment
Hide comment
@Ghabry

Ghabry Apr 14, 2016

Member

RPG_RT has completely different HP in the screenshots. Is this a bug or did you use different savegames to create them?

Member

Ghabry commented Apr 14, 2016

RPG_RT has completely different HP in the screenshots. Is this a bug or did you use different savegames to create them?

@carstene1ns

This comment has been minimized.

Show comment
Hide comment
@carstene1ns

carstene1ns Apr 14, 2016

Member

I have replaced the screenshot now. It was from battle test, whereas now both are from the savegame.

Member

carstene1ns commented Apr 14, 2016

I have replaced the screenshot now. It was from battle test, whereas now both are from the savegame.

@Ghabry

This comment has been minimized.

Show comment
Hide comment
@Ghabry

Ghabry Apr 14, 2016

Member

Wine emulates the glitchy font rendering that happens under Windows (when Cleartype is enabled) perfectly btw 👍

Member

Ghabry commented Apr 14, 2016

Wine emulates the glitchy font rendering that happens under Windows (when Cleartype is enabled) perfectly btw 👍

@Ghabry

This comment has been minimized.

Show comment
Hide comment
@Ghabry

Ghabry Apr 14, 2016

Member

By just moving the characters by 4 pixels in all directions I figured out the default values are (instead of 0):

battle_x: 220
battle_y: 120

This should be adjusted in liblcf

Member

Ghabry commented Apr 14, 2016

By just moving the characters by 4 pixels in all directions I figured out the default values are (instead of 0):

battle_x: 220
battle_y: 120

This should be adjusted in liblcf

@Ghabry

This comment has been minimized.

Show comment
Hide comment
@Ghabry

Ghabry Apr 15, 2016

Member

Reported as fixed since EasyRPG/liblcf#178

Member

Ghabry commented Apr 15, 2016

Reported as fixed since EasyRPG/liblcf#178

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment