Embric of Wulfhammer's Castle: Post-credits scene incorrectly appears twice #963

Closed
Siltala opened this Issue Jul 27, 2016 · 1 comment

Projects

None yet

4 participants

@Siltala
Siltala commented Jul 27, 2016

After finishing an ending and going through the game credits, you end up back ingame (unless you choose to quit) and a short post-credits scene follows. This works perfectly fine, if you skip the credits (press enter during credits), but if you actually wait all the way to the end before going back ingame, after said post-credits scene the game actually asks if you want to skip the credits again, though they aren't even rolling anymore, after which it does a second post-credits scene. This doesn't happen with RPG_RT.

Videos illustrating the problem (spoilers!!!):

To reproduce, load the savegame, talk to Scheherazade right in front of the Duchess, choose 'Girls night out tonight' and watch the shortest ending ingame by far. As far as I could tell, all endings have the issue, though.

@Zegeri
Member
Zegeri commented Aug 2, 2016

bb95079 should fix this.

@fdelapena fdelapena added this to the 0.5.0 milestone Aug 2, 2016
@Ghabry Ghabry pushed a commit that closed this issue Aug 8, 2016
@Zegeri Zegeri In Wait until Decision Key command, ignore keys while a message is vi…
…sible

Just like in bf902a3 for KeyInputProc. Fixes #963.
aa0e546
@Ghabry Ghabry closed this in aa0e546 Aug 8, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment