Interpreter: Fix Equipment command and Vehicle movement #1050

Merged
merged 3 commits into from Jan 7, 2017

Conversation

Projects
None yet
3 participants
@Ghabry
Member

Ghabry commented Oct 3, 2016

Vehicles with custom event routes were not moving at all, one function call missing.
This fixes "Dunkle Schatten" - The ship never reached our heros.

The equipment command has a function "unequip all", for some reason this was never implemented :o
This removes our "Item -1 is invalid" debugmsg ;). "Item 0 is invalid" is still generated when a variable is really 0, that's correct.

@Ghabry Ghabry added this to the 0.5.1 milestone Oct 3, 2016

@Ghabry

This comment has been minimized.

Show comment
Hide comment
@Ghabry

Ghabry Oct 4, 2016

Member

When reviewing please do a full text search and look for GetEquipment, SetEquipment, ChangeEquipment calls that I missed or fixed incorrectly.

Member

Ghabry commented Oct 4, 2016

When reviewing please do a full text search and look for GetEquipment, SetEquipment, ChangeEquipment calls that I missed or fixed incorrectly.

@carstene1ns carstene1ns self-assigned this Jan 7, 2017

@carstene1ns carstene1ns merged commit c8adee8 into EasyRPG:master Jan 7, 2017

6 checks passed

Android (armeabi-v7a) Build finished.
Details
GNU/Linux Build finished.
Details
OSX Build finished.
Details
Windows (x64) Build finished.
Details
Windows (x86) Build finished.
Details
web Build finished.
Details
@Ghabry

This comment has been minimized.

Show comment
Hide comment
@Ghabry

Ghabry Jan 7, 2017

Member

Oh, thanks :)

Member

Ghabry commented Jan 7, 2017

Oh, thanks :)

Ghabry pushed a commit to libretro/easyrpg-libretro that referenced this pull request May 22, 2018

Merge pull request #1050 from Ghabry/development
Interpreter: Fix Equipment command and Vehicle movement
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment