Skip to content
Permalink
Browse files

Jenkinsfile: diable website autodeploy

  • Loading branch information
mpranj committed Dec 1, 2019
1 parent f1fa395 commit 68d4bb69c0e6a5e12993c1540eb51dc6fc2423a8
Showing with 3 additions and 3 deletions.
  1. +3 −3 scripts/jenkins/Jenkinsfile
@@ -160,9 +160,9 @@ def main() {
parallel generateArtifactStages()
}

maybeStage("Deploy Website", isMaster()) {
deployWebsite()
}
// maybeStage("Deploy Website", isMaster()) {
// deployWebsite()
// }

// maybeStage("Deploy Web UI", isMaster()) {
// deployWebUI()

5 comments on commit 68d4bb6

@mpranj

This comment has been minimized.

Copy link
Member Author

mpranj replied Dec 1, 2019

Somehow the deploy website step fails repeatedly on master (the image cannot be pulled from our hub). When testing this on PR builds it was successful. I don't know what's going on here.

Pull fails with

$ docker pull hub.libelektra.org/build-elektra-website-backend:latest
Error response from daemon: manifest for hub.libelektra.org/build-elektra-website-backend:latest not found: manifest unknown: manifest unknown

even though on a7 the manifest exists (at least as a file on disk). 😕

@markus2330

This comment has been minimized.

Copy link
Contributor

markus2330 replied Dec 2, 2019

Yes, @Mistreated can you please fix this by creating a new VM on our server and make the deployment of this website and webui there? (Within docker containers)

This should not replace the current webpage but it is very good to have a backup. (The webui, however, would be productive. If we have it on our server and on a7 it would be a plus.)

@Mistreated

This comment has been minimized.

Copy link
Contributor

Mistreated replied Dec 2, 2019

I created a new VM web but somehow I get a permission denied when I try to use ssh to another machine from the network or when I try to login to the VM from a machine in the network.

@markus2330

This comment has been minimized.

Copy link
Contributor

markus2330 replied Dec 2, 2019

Please create an issue in the buildserver repo for what exactly you tried and what fails.

@Mistreated

This comment has been minimized.

Copy link
Contributor

Mistreated replied Dec 3, 2019

Please create an issue in the buildserver repo for what exactly you tried and what fails.

no need, solved.
In the VM notes is written how to reach the container.

Please sign in to comment.
You can’t perform that action at this time.