Skip to content
This repository
Fetching contributors…

Cannot retrieve contributors at this time

file 20 lines (16 sloc) 0.432 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20
<?php
/**
* Elgg install script
*
* @package Elgg
* @subpackage Core
*/

// check for PHP 4 before we do anything else
if (version_compare(PHP_VERSION, '5.0.0', '<')) {
echo "Your server's version of PHP (" . PHP_VERSION . ") is too old to run Elgg.\n";
exit;
}

require_once(dirname(__FILE__) . "/install/ElggInstaller.php");

$installer = new ElggInstaller();

$step = get_input('step', 'welcome');
$installer->run($step);
Something went wrong with that request. Please try again.