Permalink
Browse files

fix(composer): composer post-update script no longer crashes

The `use` statement had been updated, but not the type-hint. This blocked
updating Elgg in the `www.elgg.org` repo, forcing use of `--no-scripts`.
  • Loading branch information...
mrclay committed Oct 2, 2016
1 parent 9bbbcdb commit be4235a0a75d6bbb8f95f823dd5eff52ed27c2d6
Showing with 2 additions and 2 deletions.
  1. +2 −2 engine/classes/Elgg/Composer/PostUpdate.php
@@ -10,11 +10,11 @@ class PostUpdate {
/**
* Todo
*
- * @param Event $event The Composer event (install/upgrade)
+ * @param PackageEvent $event The Composer event (install/upgrade)
*
* @return void
*/
- public static function execute(Event $event) {
+ public static function execute(PackageEvent $event) {
}
}

0 comments on commit be4235a

Please sign in to comment.