Permalink
Browse files

chore(widgets): removed usage of pre 1.8 widget migration action

BREAKING CHANGE:
The action widgets/upgrade is no longer available
  • Loading branch information...
jdalsem committed Jun 30, 2015
1 parent d95dd38 commit c3273d1da04e3767f2003d9b30911e2baeb96cb2

This file was deleted.

Oops, something went wrong.
@@ -437,6 +437,12 @@ Removed Plugin Hooks
--------------------
- ``[display, view]``: See the :ref:`new plugin hook<guides/views#altering-view-output>`.
Removed Actions
---------------
- ``widgets/upgrade``
Removed View Variables
----------------------
View
@@ -122,7 +122,7 @@ function elgg_get_widget_types($context = "", $exact = false) {
/**
* Set the widget title on ajax return from save action
*
*
* @param string $hook Hook name
* @param string $type Hook type
* @param array $results Array to be encoded as json
@@ -152,7 +152,6 @@ function _elgg_widgets_init() {
elgg_register_action('widgets/add');
elgg_register_action('widgets/move');
elgg_register_action('widgets/delete');
elgg_register_action('widgets/upgrade', '', 'admin');
elgg_register_plugin_hook_handler('output', 'ajax', '_elgg_widgets_set_ajax_title');
}
@@ -162,7 +161,7 @@ function _elgg_widgets_init() {
* register menu items for default widgets with the admin section.
*
* A plugin that wants to register a new context for default widgets should
* register for the plugin hook 'get_list', 'default_widgets'. The handler
* register for the plugin hook 'get_list', 'default_widgets'. The handler
* can register the new type of default widgets by adding an associate array to
* the return value array like this:
* array(
@@ -6,24 +6,6 @@
* @subpackage Administration.DefaultWidgets
*/
$object = elgg_get_entities(array(
'type' => 'object',
'subtype' => 'moddefaultwidgets',
'distinct' => false,
'limit' => 1,
));
if ($object) {
echo elgg_view('output/url', array(
'text' => elgg_echo('upgrade'),
'href' => 'action/widgets/upgrade',
'is_action' => true,
'is_trusted' => true,
'class' => 'elgg_button elgg-button-submit',
'title' => 'Upgrade your default widgets to work on Elgg 1.8',
));
}
elgg_push_context('default_widgets');
$widget_context = get_input('widget_context');
$list = elgg_trigger_plugin_hook('get_list', 'default_widgets', null, array());

0 comments on commit c3273d1

Please sign in to comment.