Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

elgg_deprecated_notice()'s version compare break on some locales (Trac #2749) #2749

Closed
elgg-gitbot opened this issue Feb 16, 2013 · 2 comments
Closed
Labels
Milestone

Comments

@elgg-gitbot
Copy link

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

Original ticket http://trac.elgg.org/ticket/2749 on 40993669-12-27 by brettp, assigned to unknown.

Elgg version: 1.7

If the locale's decimal point string is set to ',' it breaks the version compare, which causes deprecation notices to show up when they shouldn't.

To duplicate, call setlocale(LC_ALL, $locale) in engine/start.php where $locale is one that uses a comma. pt_BR works for me.

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

cash wrote on 41084569-09-04

(In [svn:7963]) Fixes #2749 treating deprecated_version as a number rather than string

@elgg-gitbot
Copy link
Author

@elgg-gitbot elgg-gitbot commented Feb 16, 2013

brettp wrote on 41141175-10-23

(In [svn:8364]) Refs #2749, #2956. Merged elgg_depracated_notice() fixes to trunk.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.