Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Site submenu dropdown in IE7 doesn't work. (Trac #3770) #3770

Closed
elgg-gitbot opened this issue Feb 16, 2013 · 10 comments
Closed

Site submenu dropdown in IE7 doesn't work. (Trac #3770) #3770

elgg-gitbot opened this issue Feb 16, 2013 · 10 comments
Labels
Milestone

Comments

@elgg-gitbot
Copy link

elgg-gitbot commented Feb 16, 2013

Original ticket http://trac.elgg.org/ticket/3770 on 41681324-08-01 by brettp, assigned to unknown.

Elgg version: Github Master

It should be possible in CSS, but in the interest of releasing 1.8.0 I've used a horribly hacky method in JS to get it work. We should look at either using a better method through JS or getting the CSS working.

Setting at difficult because I've wasted hours of my life on it and am bitter.

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

trac user Brett Profitt wrote on 41681343-03-09

Refs #3449, #3770. Using JS to fix submenu dropdown in IE7.
Changeset: 826310d

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

trac user illifly wrote on 41688895-08-16

Replying to [comment:1 Brett Profitt]:

Refs #3449, #3770. Using JS to fix submenu dropdown in IE7.
Changeset: 826310d

I updated today but the same issue is still in IE9!
Should i delete #3772?

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

Milestone changed to Elgg 1.8.1b by cash on 41693726-07-29

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

cash wrote on 41724012-10-31

The JavaScript solution did not work for me with IE8. I was able to get a pure CSS solution to work for IE8 but not for IE7.

I'm able to get a CSS menu to work with IE7 on the same page as the site menu. I cannot get the site menu to work. It appears to have something to do with the fact that the menu drops below the elgg-page-header div.

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

cash wrote on 41724031-05-04

Maybe this is related to one of IE's z-index bugs: http://www.quirksmode.org/bugreports/archives/2006/01/Explorer_z_index_bug.html

I know that the dropdown menu appears and the content in the main div appears over it - that points to z-index. That would explain why moving the mouse to the part of the menu below the header div causes it to disappear.

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

brettp wrote on 41724146-12-21

The problem with the JS + CSS solution is that the JS applied is only for IE7 but the CSS applied is for IE >= 7.

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

brettp wrote on 41724148-12-30

See also #3772, which I'm resolving as a dupe of this one because the base problem is the same.

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

cash wrote on 41725048-07-19

Fixes #3770 CSS only site menu that works in IE7
Changeset: 9a44acd

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

cash wrote on 41725059-08-22

Fixed spaces issues in [49d433e]

Changes were:

  • slight change in selector for display hidden/block
  • added z-index 1 to the header container

@elgg-gitbot
Copy link
Author

elgg-gitbot commented Feb 16, 2013

cash wrote on 41850784-04-06

Fixes #3770 CSS only site menu that works in IE7
Changeset: 9a44acd

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Development

No branches or pull requests

1 participant