System cache is broken on 2.1.1 #9602

Closed
juho-jaakkola opened this Issue Apr 1, 2016 · 6 comments

Comments

Projects
None yet
2 participants
@juho-jaakkola
Member

juho-jaakkola commented Apr 1, 2016

Not yet sure what exactly is happening...

@juho-jaakkola

This comment has been minimized.

Show comment
Hide comment
@juho-jaakkola

juho-jaakkola Apr 1, 2016

Member

Ok, I'm not able to reproduce in other 2.1 environment. It's probably something site specific.

Member

juho-jaakkola commented Apr 1, 2016

Ok, I'm not able to reproduce in other 2.1 environment. It's probably something site specific.

@juho-jaakkola

This comment has been minimized.

Show comment
Hide comment
@juho-jaakkola

juho-jaakkola Apr 1, 2016

Member

This might be a bug after all.

I had set dataroot to $CONFIG->dataroot property in settings.php, and the dataroot setting in the database had an outdated path.

It seems that in some cases dataroot gets read from the database instead of settings.php causing an error if the value is not valid.

Member

juho-jaakkola commented Apr 1, 2016

This might be a bug after all.

I had set dataroot to $CONFIG->dataroot property in settings.php, and the dataroot setting in the database had an outdated path.

It seems that in some cases dataroot gets read from the database instead of settings.php causing an error if the value is not valid.

@juho-jaakkola

This comment has been minimized.

Show comment
Hide comment
@juho-jaakkola

juho-jaakkola Apr 1, 2016

Member

The problem started when I upgraded the site from 2.0 to 2.1. Apparently something has been changed in between.

Member

juho-jaakkola commented Apr 1, 2016

The problem started when I upgraded the site from 2.0 to 2.1. Apparently something has been changed in between.

@mrclay

This comment has been minimized.

Show comment
Hide comment
@mrclay

mrclay Apr 1, 2016

Member

Does it affect all requests? The big change is the migration of boot stuff into BootService.

Member

mrclay commented Apr 1, 2016

Does it affect all requests? The big change is the migration of boot stuff into BootService.

@juho-jaakkola

This comment has been minimized.

Show comment
Hide comment
@juho-jaakkola

juho-jaakkola Apr 1, 2016

Member

Haven't had the time to debug properly, but no, doesn't affect all requests.

Member

juho-jaakkola commented Apr 1, 2016

Haven't had the time to debug properly, but no, doesn't affect all requests.

@mrclay

This comment has been minimized.

Show comment
Hide comment
@mrclay

mrclay Apr 1, 2016

Member

Fix in #9605

Member

mrclay commented Apr 1, 2016

Fix in #9605

@mrclay mrclay closed this in 64c23f7 Apr 5, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment