installation issue on Ubuntu says - unmet dependency #306

Closed
vaibhavtolia opened this Issue Feb 27, 2014 · 3 comments

Projects

None yet

2 participants

@vaibhavtolia

Installation on ubuntu on beaglebone black gives error.

Node version - v0.10.5

npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/npm-install-checks requires npmlog@'0.0.6' but will load
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/npmlog,
npm WARN unmet dependency which is version 0.0.2
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/npm-install-checks requires semver@'~2.2.1' but will load
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/semver,
npm WARN unmet dependency which is version 1.1.4
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data requires semver@'2' but will load
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/semver,
npm WARN unmet dependency which is version 1.1.4

@reconbot

Can you give the npm erorr log in a gist? It includes the full command you typed and a lot more debugging output.

@vaibhavtolia

Apparently the debug log is empty

But i tried installing it locally instead of globally and it worked
so
npm install -g serialport gives the error I mentioned
but doing npm install serialport after installing those dependencies locally gives no error and I can use the library, can I not install this globally ?

@reconbot
@reconbot reconbot closed this Apr 2, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment