Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't use "vh" as unit for section minimum height anymore #65

Closed
Arood opened this issue Oct 31, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@Arood
Copy link

commented Oct 31, 2016

After updating to 1.7.2, it seems like it's not possible to set 100vh as minimum height on a section to achieve full-height content anymore. Is this an intended change or a bug?

@andrew-worsfold

This comment has been minimized.

Copy link
Contributor

commented Nov 1, 2016

The latest version validates both the numerical value of a setting and the unit provided (if any) for certain fields. The whitelist doesn't currently include vh and vw units, but I will add these in the next release.

FYI - the "whitelist" currently comprises:

[ "px", "%", "in", "cm", "mm", "pt", "pc", "em", "rem", "ex" ]

Defaulting to px if no unit is specified.

Let me know if there are any others that you'd like to see added.

@andrew-worsfold andrew-worsfold added this to the 1.7.3 milestone Nov 1, 2016

@andrew-worsfold andrew-worsfold self-assigned this Nov 1, 2016

andrew-worsfold added a commit that referenced this issue Nov 1, 2016

Tailor 1.7.3.
* Added - Add button to container elements (e.g., Carousels, Grids, Lists, Tabs and Toggles).
* Added - Support for vh and vw units [GitHub #65](https://github.com/andrew-worsfold/tailor/issues/65).
* Added - Ability for third-party extensions to override live CSS rule generation for all default elements.
* Fixed - Grid Item padding custom CSS selectors are not specific enough to override default styles [GitHub #64](https://github.com/andrew-worsfold/tailor/issues/64).
* Fixed - Incorrect validation being performed for border-style setting.
* Developer - Moved SCSS folder to assets folder.

@andrew-worsfold andrew-worsfold added the bug label Nov 1, 2016

@andrew-worsfold

This comment has been minimized.

Copy link
Contributor

commented Nov 1, 2016

@Arood - Can you please confirm whether the latest commit (1.7.3) resolves this issue for you?

@Arood

This comment has been minimized.

Copy link
Author

commented Nov 1, 2016

Seems to work now! Thanks!

@Arood Arood closed this Nov 1, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.