Small error in CUP Enabled logic #543

Closed
morgoth0 opened this Issue May 29, 2016 · 1 comment

Projects

None yet

2 participants

@morgoth0

Was making a couple of changes in server_init and I noticed the following two lines:

EPOCH_modCUPWeaponsEnabled = (getNumber (configFile >> "CfgPatches" >> "CUP_WheeledVehicles_Core" >> "requiredVersion") > 0);
EPOCH_modCUPVehiclesEnabled = (getNumber (configFile >> "CfgPatches" >> "CUP_Weapons_WeaponsCore" >> "requiredVersion") > 0);

This would be a problem for those only using CUP Weapons since the patch check is reversed, i.e. WeaponsEnabled is set by the Vehicles addon and vice versa.

@vbawol
Member
vbawol commented May 29, 2016 edited

Wow, I really need to get those glasses. This will be fixed in next experimental build.

Thanks!

@vbawol vbawol closed this May 29, 2016
@vbawol vbawol added a commit that referenced this issue May 29, 2016
@vbawol vbawol fixed CUP Enabled logic typo a41700f
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment