Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 34 lines (27 sloc) 1.318 kb
7c1ad50 ErwinM restructuring
authored
1 # -*- encoding: utf-8 -*-
2 $:.push File.expand_path("../lib", __FILE__)
3 require "acts_as_tenant/version"
4
5 Gem::Specification.new do |s|
6 s.name = "acts_as_tenant"
7 s.version = ActsAsTenant::VERSION
8 s.authors = ["Erwin Matthijssen"]
9 s.email = ["erwin.matthijssen@gmail.com"]
ba0936d ErwinM Updates to readme formatting
authored
10 s.homepage = "http://www.rollcallapp.com/blog"
61cbffa ErwinM Finalize readme
authored
11 s.summary = %q{Add multi-tenancy to Rails applications using a shared db strategy}
ba0936d ErwinM Updates to readme formatting
authored
12 s.description = %q{Integrates multi-tenancy into a Rails application in a convenient and out-of-your way manner}
7c1ad50 ErwinM restructuring
authored
13
14 s.rubyforge_project = "acts_as_tenant"
15
16 s.files = `git ls-files`.split("\n")
17 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
18 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
19 s.require_paths = ["lib"]
2a6c1d9 ErwinM Update RSPEC to 3.0. Convert all specs.
authored
20
5325b47 ErwinM Use RequestStore instead of Thread.current to fix #24. Clean up dependen...
authored
21 #add_runtime_dependency("rails")
22 s.add_runtime_dependency('request_store', '>= 1.0.5')
9370379 Aaron Renner Added runtime and development dependencies to gemspec
aaronrenner authored
23 s.add_dependency('rails','>= 3.1')
5325b47 ErwinM Use RequestStore instead of Thread.current to fix #24. Clean up dependen...
authored
24 #s.add_dependency('request_store', '>= 1.0.5')
9370379 Aaron Renner Added runtime and development dependencies to gemspec
aaronrenner authored
25
2a6c1d9 ErwinM Update RSPEC to 3.0. Convert all specs.
authored
26 s.add_development_dependency('rspec', '>=3.0')
0ee4514 ErwinM Changed subdomain resolution. Added specs for controller extensions.
authored
27 s.add_development_dependency('rspec-rails')
ca93e35 Ian Young Lock database_cleaner version
iangreenleaf authored
28 s.add_development_dependency('database_cleaner', '~> 1.3.0')
9370379 Aaron Renner Added runtime and development dependencies to gemspec
aaronrenner authored
29 s.add_development_dependency('sqlite3')
cb90983 Ian Young Run specs against Mongoid as well as ActiveRecord
iangreenleaf authored
30 s.add_development_dependency('mongoid', '~> 4.0')
ffdda06 Tobias L. Maier Add specs for sidekiq
tmaier authored
31
852d47d ErwinM Sidekiq 3.2.2+ no longer supports Ruby 1.9. Locking Sidekiq in gemspec a...
authored
32 s.add_development_dependency('sidekiq', '3.2.1')
7c1ad50 ErwinM restructuring
authored
33 end
Something went wrong with that request. Please try again.