Skip to content
0592920
Compare
Choose a tag to compare

Labrador Installer for Windows 7 or later (32-bit and 64-bit supported)

806a539
Compare
Choose a tag to compare

EspoTek Labrador software for macOS 10.13 and later. If you are running an older version of macOS, please use the macOS Legacy build below.

806a539
Compare
Choose a tag to compare

EspoTek Labrador software for Linux. This should be compatible with all modern 64-bit distros. If you're running 32-bit Linux, please see the wiki for build instructions. https://github.com/EspoTek/Labrador/wiki/Building-for-32-bit-Linux

ac5052c
Compare
Choose a tag to compare

EspoTek Labrador software for macOS 10.12 to 10.15.
If you're running 10.10 or 10.11, please use the release titled "Update 2"
If you're running OSX 11.0 or later, please use the standard release titled "Continuous (macOS)".

ac5052c
Compare
Choose a tag to compare

EspoTek Labrador software for Linux. Please note that the .deb is unsupported - it's recommended you install the AppImage or build from source (instructions available in main page).

Please note that the 32-bit version of Raspbian version 9 (Stretch) or later is required to install this software.

To install Labrador on the Raspberry Pi, open a terminal and copy the following command:
wget -O /tmp/labrador_bootstrap_pi https://raw.githubusercontent.com/EspoTek/Labrador/master/labrador_bootstrap_pi && sudo chmod +x /tmp/labrador_bootstrap_pi && sudo /tmp/labrador_bootstrap_pi

This will automatically download, compile and installs the latest version of the Labrador software from source. After running it, a desktop entry will appear for the Labrador software (under Education), and running the labrador command from the terminal will launch the software interface.

Compare
Choose a tag to compare

Labrador Christmas Update!
Download the version for your platform, install and enjoy the updates.

It's highly probable that the Raspberry Pi version will run on other ARM-based Linux microcomputers such as Orange Pi or CHIP. If you try it out, please let me know how it goes and we can get a compatibility list going.

Windows 32-bit users
If you're getting an error related to msvcp140.dll, please see issue #24

NOTES FOR LINUX USERS
Please make sure you install using the script.
If you don't, you'll need to reset your computer before the board will connect.

To do so, extract the .tar.gz, then open a terminal in the directory you extracted to and run the following commands:
chmod +x ./labradeb-install
sudo ./labradeb-install

The "Compatibility_Mint17" version is built on Linux Mint 17 and meant for older distributions. If you use Ubuntu 16.04 LTS or later, just use the normal x86 or x64 file.

Special Thanks
Thanks to grocid for the Mac Icon.
Thanks to Steve Hills for help building the Linux x86 Compatibility_Min17 mode binary.

Compare
Choose a tag to compare
Pre-release

This is the first release on GitHub.
It's similar to the version on Google Drive, but with a few updates related to the saving of snapshots/recordings.